aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/vdr-plugin-osdpip/Makefile38
-rw-r--r--multimedia/vdr-plugin-osdpip/distinfo2
-rw-r--r--multimedia/vdr-plugin-osdpip/files/patch-Makefile9
-rw-r--r--multimedia/vdr-plugin-osdpip/files/patch-vdr-osdpip-0.1.015
-rw-r--r--multimedia/vdr-plugin-osdpip/pkg-descr8
-rw-r--r--multimedia/vdr-plugin-osdpip/pkg-plist22
7 files changed, 95 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index e82b54fc141c..9ac538fc853b 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -340,6 +340,7 @@
SUBDIR += vdr-plugin-femon
SUBDIR += vdr-plugin-infosatepg
SUBDIR += vdr-plugin-iptv
+ SUBDIR += vdr-plugin-osdpip
SUBDIR += vic
SUBDIR += vlc
SUBDIR += vodcatcher
diff --git a/multimedia/vdr-plugin-osdpip/Makefile b/multimedia/vdr-plugin-osdpip/Makefile
new file mode 100644
index 000000000000..07a39e0896ae
--- /dev/null
+++ b/multimedia/vdr-plugin-osdpip/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: vdr-plugin-osdpip
+# Date created: Wed Apr 14 18:11:42 CEST 2010
+# Whom: Juergen Lock <nox@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdr-plugin-osdpip
+PORTVERSION= 0.1.0
+PORTREVISION= 6
+CATEGORIES= multimedia
+MASTER_SITES= http://projects.vdr-developer.org/attachments/download/267/
+DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video Disk Recorder - picture-in-picture plugin
+
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+
+DIST_SUBDIR= vdr
+PATCH_STRIP= -p1
+HAVE_CONFIGURE= yes
+PORTDOCS= COPYING README
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION}
+
+.include "${.CURDIR}/../vdr/Makefile.plugins"
+
+post-patch: post-patch-plugin
+
+post-install: post-install-pluginlocales
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-osdpip/distinfo b/multimedia/vdr-plugin-osdpip/distinfo
new file mode 100644
index 000000000000..31fc7e290490
--- /dev/null
+++ b/multimedia/vdr-plugin-osdpip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vdr/vdr-osdpip-0.1.0.tgz) = 40f5e8acc57c82d922b0a415bb0f12ac3cb68c014f9bafd090b71ded6a25a821
+SIZE (vdr/vdr-osdpip-0.1.0.tgz) = 52090
diff --git a/multimedia/vdr-plugin-osdpip/files/patch-Makefile b/multimedia/vdr-plugin-osdpip/files/patch-Makefile
new file mode 100644
index 000000000000..99cd31e3d542
--- /dev/null
+++ b/multimedia/vdr-plugin-osdpip/files/patch-Makefile
@@ -0,0 +1,9 @@
+--- osdpip-0.1.0/Makefile.orig
++++ osdpip-0.1.0/Makefile
+@@ -171,3 +173,6 @@ dist: clean
+
+ clean:
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot
++
++install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
diff --git a/multimedia/vdr-plugin-osdpip/files/patch-vdr-osdpip-0.1.0 b/multimedia/vdr-plugin-osdpip/files/patch-vdr-osdpip-0.1.0
new file mode 100644
index 000000000000..c16b90058974
--- /dev/null
+++ b/multimedia/vdr-plugin-osdpip/files/patch-vdr-osdpip-0.1.0
@@ -0,0 +1,15 @@
+diff -ur orig/osdpip-0.1.0/Makefile osdpip-0.1.0/Makefile
+--- orig/osdpip-0.1.0/Makefile 2010-03-27 16:38:13.000000000 +0100
++++ osdpip-0.1.0/Makefile 2010-03-29 09:35:59.000000000 +0200
+@@ -155,7 +155,11 @@
+
+ libvdr-$(PLUGIN).so: $(OBJS)
+ $(CXX) $(CXXFLAGS) -shared -o $@ $^ $(LIBS)
++ifdef FREEBSD
++ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
++else
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
++endif
+
+ dist: clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
diff --git a/multimedia/vdr-plugin-osdpip/pkg-descr b/multimedia/vdr-plugin-osdpip/pkg-descr
new file mode 100644
index 000000000000..77ea4e07e99f
--- /dev/null
+++ b/multimedia/vdr-plugin-osdpip/pkg-descr
@@ -0,0 +1,8 @@
+http://www.linuxtv.org/vdrwiki/index.php/Osdpip-plugin
+
+OSD Picture-in-Picture is a VDR PlugIn that displays the current channel
+in a small box on the screen (default upper right corner). You can switch
+up and down now, watching the progress of the previous channel in the box.
+Quality is not too good yet, and only I-Frames are displayed.
+
+WWW: http://projects.vdr-developer.org/projects/show/plg-osdpip
diff --git a/multimedia/vdr-plugin-osdpip/pkg-plist b/multimedia/vdr-plugin-osdpip/pkg-plist
new file mode 100644
index 000000000000..1b86acc7c776
--- /dev/null
+++ b/multimedia/vdr-plugin-osdpip/pkg-plist
@@ -0,0 +1,22 @@
+lib/vdr/libvdr-osdpip.so.1.7.17
+%%NLS%%share/locale/ca_ES/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/cs_CZ/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/da_DK/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/de_DE/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/el_GR/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/et_EE/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/hr_HR/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/hu_HU/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/nl_NL/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/nn_NO/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/pl_PL/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/ro_RO/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/sl_SI/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/sv_SE/LC_MESSAGES/vdr-osdpip.mo
+%%NLS%%share/locale/tr_TR/LC_MESSAGES/vdr-osdpip.mo