aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-XML_RPC/Makefile27
-rw-r--r--devel/pear-XML_RPC/distinfo2
-rw-r--r--devel/pear-XML_RPC/pkg-descr8
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6e1a931c40f9..a3de29454415 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -912,6 +912,7 @@
SUBDIR += pear-I18N
SUBDIR += pear-PEAR
SUBDIR += pear-XML_Parser
+ SUBDIR += pear-XML_RPC
SUBDIR += pear-XML_RSS
SUBDIR += pear-XML_Serializer
SUBDIR += pear-XML_Tree
diff --git a/devel/pear-XML_RPC/Makefile b/devel/pear-XML_RPC/Makefile
new file mode 100644
index 000000000000..efd1e397b2c7
--- /dev/null
+++ b/devel/pear-XML_RPC/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: pear-XML_RPC
+# Date created: 4 October 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML_RPC
+PORTVERSION= 1.0.4
+CATEGORIES= devel www pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PHP implementation of the XML-RPC protocol
+
+USE_PHP= yes
+WANT_PHP_PEAR= yes
+
+CATEGORY= XML
+FILES= RPC.php RPC/Server.php
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/RPC
+ @${MV} ${WRKSRC}/Server.php ${WRKSRC}/RPC
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-XML_RPC/distinfo b/devel/pear-XML_RPC/distinfo
new file mode 100644
index 000000000000..b8dddd654269
--- /dev/null
+++ b/devel/pear-XML_RPC/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/XML_RPC-1.0.4.tgz) = 33cefbc8a78ae111ea122a5581a6167f
+SIZE (PEAR/XML_RPC-1.0.4.tgz) = 11991
diff --git a/devel/pear-XML_RPC/pkg-descr b/devel/pear-XML_RPC/pkg-descr
new file mode 100644
index 000000000000..1efaac2456a5
--- /dev/null
+++ b/devel/pear-XML_RPC/pkg-descr
@@ -0,0 +1,8 @@
+XML-RPC is a spec and a set of implementations that allow software running
+on disparate operating systems, running in different environments to make
+procedure calls over the Internet.
+
+And this is a PEAR-ified version of useful inc's XML-RPC for PHP.
+It has support for HTTP transport, proxies and authentication.
+
+WWW: http://pear.php.net/package/XML_RPC