aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/clipgrab/Makefile40
-rw-r--r--multimedia/clipgrab/distinfo3
-rw-r--r--multimedia/clipgrab/pkg-descr13
4 files changed, 57 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index b730766849d3..239db4ecc915 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -24,6 +24,7 @@
SUBDIR += castpodder
SUBDIR += cclive
SUBDIR += cheese
+ SUBDIR += clipgrab
SUBDIR += clive
SUBDIR += clive-utils
SUBDIR += clive1
diff --git a/multimedia/clipgrab/Makefile b/multimedia/clipgrab/Makefile
new file mode 100644
index 000000000000..4ebf1861a85c
--- /dev/null
+++ b/multimedia/clipgrab/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: clipgrab
+# Date created: 2009-12-06
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clipgrab
+PORTVERSION= 3.0.4.1
+CATEGORIES= multimedia
+MASTER_SITES= http://clipgrab.de/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Program to download videos from YouTube and etc
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml qmake_build uic_build moc_build \
+ rcc_build network
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/${PORTNAME}/icon.png \
+ share/${PORTNAME}/logo.png \
+ share/${PORTNAME}/splash.png
+PLIST_DIRS= share/${PORTNAME}
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,img/,share/${PORTNAME}/,g' \
+ ${WRKSRC}/*.cpp
+
+do-configure:
+ cd ${WRKSRC} && ${QMAKE}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/*.png ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/multimedia/clipgrab/distinfo b/multimedia/clipgrab/distinfo
new file mode 100644
index 000000000000..5169a8febda9
--- /dev/null
+++ b/multimedia/clipgrab/distinfo
@@ -0,0 +1,3 @@
+MD5 (clipgrab-3.0.4.1.tar.bz2) = 1e07d9a2b0fb2ae528b2637e495d9455
+SHA256 (clipgrab-3.0.4.1.tar.bz2) = 677ad67aa634597201ff3e82ded868ba344c71be46fcd9d81dd2a2b9902360f6
+SIZE (clipgrab-3.0.4.1.tar.bz2) = 277322
diff --git a/multimedia/clipgrab/pkg-descr b/multimedia/clipgrab/pkg-descr
new file mode 100644
index 000000000000..1759fe8bc368
--- /dev/null
+++ b/multimedia/clipgrab/pkg-descr
@@ -0,0 +1,13 @@
+ClipGrab doesn\'t only allow you to download videos from sites like Youtube,
+Dailymotion or Veoh but also gives you the ability to convert them at a single
+blow into "usabl" formats like WMV, MPEG or MP3. So you\'ll be able to wat
+h (or listen to) your favourite Youtube clips wherever you are.
+ClipGrab currently supports these sites:
+
+-YouTube
+-Dailymotion
+-Vimeo
+-MyVideo
+-MySpass
+
+WWW: http://clipgrab.de