aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/dspam-devel/Makefile4
-rw-r--r--mail/dspam/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 807481496cee..9be779410391 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -31,6 +31,8 @@ SED_SCRIPT= -e 's,%%DOCSDIR%%,${DOCSDIR},g' \
-e 's,%%EXAMPLESDIR%%,${EXAMPLESDIR},g' \
-e 's,%%LOCALBASE%%,${LOCALBASE},g'
+.include <bsd.port.pre.mk>
+
.if defined(WITH_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-storage-driver=mysql_drv \
@@ -88,4 +90,4 @@ post-install:
.endif
@${SED} ${SED_SCRIPT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 807481496cee..9be779410391 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -31,6 +31,8 @@ SED_SCRIPT= -e 's,%%DOCSDIR%%,${DOCSDIR},g' \
-e 's,%%EXAMPLESDIR%%,${EXAMPLESDIR},g' \
-e 's,%%LOCALBASE%%,${LOCALBASE},g'
+.include <bsd.port.pre.mk>
+
.if defined(WITH_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-storage-driver=mysql_drv \
@@ -88,4 +90,4 @@ post-install:
.endif
@${SED} ${SED_SCRIPT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>