aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/nbsmtp/Makefile1
-rw-r--r--mail/nbsmtp/files/patch-util.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/nbsmtp/Makefile b/mail/nbsmtp/Makefile
index 5ea7f15e765c..4336e0ceace8 100644
--- a/mail/nbsmtp/Makefile
+++ b/mail/nbsmtp/Makefile
@@ -10,6 +10,7 @@
PORTNAME= nbsmtp
PORTVERSION= 0.99
CATEGORIES= mail
+PORTREVISION= 1
MASTER_SITES= http://www.gentoo-es.org/~ferdy/ \
http://www.it.uc3m.es/~ferdy/nbsmtp/
diff --git a/mail/nbsmtp/files/patch-util.c b/mail/nbsmtp/files/patch-util.c
new file mode 100644
index 000000000000..48f78b790281
--- /dev/null
+++ b/mail/nbsmtp/files/patch-util.c
@@ -0,0 +1,11 @@
+--- util.orig Tue Jul 12 11:43:06 2005
++++ util.c Tue Jul 12 11:43:32 2005
+@@ -187,7 +187,7 @@
+ if (debug==0 || debug==1)
+ {
+ openlog("nbSMTP", LOG_PID, LOG_MAIL);
+- syslog(priority,buffer);
++ syslog(priority,"%s",buffer);
+ closelog();
+ }
+ else /* if (debug==2) */