aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/dcc-dccd/Makefile14
-rw-r--r--mail/dcc-dccd/files/pkg-install.in16
-rw-r--r--mail/dcc-dccd/pkg-plist2
3 files changed, 13 insertions, 19 deletions
diff --git a/mail/dcc-dccd/Makefile b/mail/dcc-dccd/Makefile
index f9d4fad9f1fa..8596ddc89d4c 100644
--- a/mail/dcc-dccd/Makefile
+++ b/mail/dcc-dccd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dcc-dccd
PORTVERSION= 1.3.159
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://www.dcc-servers.net/dcc/source/old/ \
ftp://ftp.dcc-servers.net/src/dcc/old/ \
@@ -48,7 +48,7 @@ DCCHOME= ${PREFIX}/dcc
PLIST_SUB+= DCCUSER="${DCCUSER}" DCCGROUP="${DCCGROUP}"
SUB_FILES= pkg-install pkg-message
-SUB_LIST+= WRKSRC=${WRKSRC} DCCHOME=${DCCHOME}
+SUB_LIST+= WRKSRC=${WRKSRC} DCCHOME=${DCCHOME} DCCUSER="${DCCUSER}"
## Use the configure script to explicitly set the locations of all files,
## in case the standard locations have been locally overridden
@@ -107,24 +107,24 @@ post-install:
${STAGEDIR}${PREFIX}/dcc/cgi-bin/header.sample
.for sf in bin/dccproc bin/cdcc dcc/libexec/dccsight dcc/libexec/check_ip_range \
dcc/libexec/wlist dcc/libexec/ck2ip
- ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/${sf}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${sf}
.endfor
.if ${PORT_OPTIONS:MDCCIFD} || ${PORT_OPTIONS:MDCCM}
- ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/dcc/libexec/dns-helper
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/dcc/libexec/dns-helper
.endif
post-install-DCCIFD-on:
.for sf in bin/dccif-test dcc/libexec/dccifd
- ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/${sf}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${sf}
.endfor
post-install-DCCD-on:
.for sf in dcc/libexec/dump-clients dcc/libexec/dbclean \
dcc/libexec/dblist dcc/libexec/dccd
- ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/${sf}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${sf}
.endfor
post-install-DCCM-on:
- ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/dcc/libexec/dccm
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/dcc/libexec/dccm
.include <bsd.port.mk>
diff --git a/mail/dcc-dccd/files/pkg-install.in b/mail/dcc-dccd/files/pkg-install.in
index 75f40d4b5bb6..39cf983c0037 100644
--- a/mail/dcc-dccd/files/pkg-install.in
+++ b/mail/dcc-dccd/files/pkg-install.in
@@ -2,24 +2,20 @@
# $FreeBSD: /tmp/pcvs/ports/mail/dcc-dccd/files/pkg-install.in,v 1.2 2011-07-04 19:39:45 crees Exp $
PREFIX=${PKG_PREFIX:-%%PREFIX%%}
-
DCCHOME=%%DCCHOME%%
+DCCUSER=%%DCCUSER%%
if [ "$2" = "POST-INSTALL" ]; then
- echo "=> Generating unique passwords for your DCC install..."
- echo "=>"
- echo "=> Note this will make map.sample, map.txt.sample and"
- echo "=> ids.sample fail their MD5 checks on package removal."
-
/bin/sh $PREFIX/dcc/libexec/fix-map \
- -n .sample \
- -I $DCCHOME/ids.sample -i $DCCHOME/ids \
- -T $DCCHOME/map.txt.sample -t $DCCHOME/map.txt \
+ -n .nopasswd \
+ -I $DCCHOME/ids.nopasswd -i $DCCHOME/ids \
+ -T $DCCHOME/map.txt.nopasswd -t $DCCHOME/map.txt \
-m $DCCHOME/map
for file in ids map map.txt ; do
- /bin/cp -p $DCCHOME/$file $DCCHOME/${file}.sample
+ /bin/cp -p $DCCHOME/$file $DCCHOME/${file}.nopasswd
+ /usr/sbin/chown $DCCUSER $DCCHOME/${file} $DCCHOME/${file}.nopasswd
done
fi
diff --git a/mail/dcc-dccd/pkg-plist b/mail/dcc-dccd/pkg-plist
index bc693952ad29..9670a4628262 100644
--- a/mail/dcc-dccd/pkg-plist
+++ b/mail/dcc-dccd/pkg-plist
@@ -76,6 +76,4 @@ man/man8/dccsight.8.gz
%%DCCGREY%%@unexec [ -e %D/dcc/grey_flod.map ] && rm -f %D/dcc/grey_flod.map || true
%%DCCGREY%%@unexec [ -e %D/dcc/grey_clients ] && rm -f %D/dcc/grey_clients || true
@dir dcc/log
-@group wheel
-@owner root
@dir dcc