aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/resin2/Makefile15
-rw-r--r--www/resin2/distinfo3
-rw-r--r--www/resin2/files/install.sh4
-rw-r--r--www/resin2/files/patch-Makefile.in11
-rw-r--r--www/resin2/pkg-descr16
-rw-r--r--www/resin2/pkg-plist2
6 files changed, 31 insertions, 20 deletions
diff --git a/www/resin2/Makefile b/www/resin2/Makefile
index c3640a76a942..4dfb53b9fb58 100644
--- a/www/resin2/Makefile
+++ b/www/resin2/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= resin
-PORTVERSION= 2.1.11
-PORTREVISION= 1
+PORTVERSION= 2.1.12
CATEGORIES= www java
MASTER_SITES= http://www.caucho.com/download/
@@ -19,6 +18,7 @@ COMMENT= Resin, a Java-based Application Server, 2.x branch
USE_JAVA= 1.2+
HAS_CONFIGURE= yes
USE_PERL5= yes
+USE_REINPLACE= yes
# Customizable settings
RUNASUSER?= www
@@ -30,6 +30,7 @@ PORT?= 8080
# If we used PKGNAMESUFFIX, the package name would be resin2-2.1.11
APP_NAME_SUFFIX= ${PORTVERSION:C/\..*$//}
APP_NAME?= ${PORTNAME}${APP_NAME_SUFFIX}
+LATEST_LINK= ${APP_NAME}
APP_HOME?= ${PREFIX}/${APP_NAME}
WITH_APACHE?= NO
WITH_APACHE2?= NO
@@ -53,6 +54,7 @@ REPLACE_FILES= ${FILESDIR}/pkg-install \
${WRKSRC}/conf/resin.conf \
${WRKSRC}/bin/wrapper.pl.in \
${FILESDIR}/resin.sh.in
+COPYDIRS= doc lib libexec xsl
# Pass JAVA_HOME as determined by bsd.java.mk
CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME}
@@ -88,6 +90,7 @@ PLIST_SUB+= APXS=${APXS}
SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
-e "s|%%APP_NAME%%|${APP_NAME}|g" \
-e "s|%%APXS%%|${APXS}|g" \
+ -e "s|%%COPYDIRS%%|${COPYDIRS}|g" \
-e "s|%%FILESDIR%%|${FILESDIR}|g" \
-e "s|%%GROUP%%|${GROUP}|g" \
-e "s|%%GID%%|${GID}|g" \
@@ -106,7 +109,7 @@ SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
post-patch:
.for FILE in ${REINPLACE_FILES}
- @${SED} -i bak ${SUBSTITUTIONS} ${FILE}
+ @${REINPLACE_CMD} ${SUBSTITUTIONS} ${FILE}
.endfor
.for FILE in ${REPLACE_FILES}
@${SED} ${SUBSTITUTIONS} ${FILE} > ${WRKDIR}/`basename ${FILE}`
@@ -116,9 +119,9 @@ post-patch:
defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
@${ECHO_CMD} >> ${PKGMESSAGE}
@${ECHO_CMD} The Resin Apache module mod_caucho has been activated \
- in the Apache configuration file, where you should also \
- add a line to specify the location of the Resin configuration \
- file, for example: | fmt -w 80 >> ${PKGMESSAGE}
+ in the Apache configuration file, where you should also \
+ add a line to specify the location of the Resin configuration \
+ file, for example: | fmt -w 80 >> ${PKGMESSAGE}
@${ECHO_CMD} CauchoConfigFile ${PREFIX}/etc/${APP_NAME}.xml >> ${PKGMESSAGE}
.endif
@${MV} ${WRKDIR}/wrapper.pl.in ${WRKSRC}/bin/wrapper.pl.in
diff --git a/www/resin2/distinfo b/www/resin2/distinfo
index 331c69b26591..be999a73c836 100644
--- a/www/resin2/distinfo
+++ b/www/resin2/distinfo
@@ -1 +1,2 @@
-MD5 (resin-2.1.11.tar.gz) = 97cd4be46138bf86ce582e437d747d1e
+MD5 (resin-2.1.12.tar.gz) = d435aae4b9a7154d643bba19a6d06098
+SIZE (resin-2.1.12.tar.gz) = 3301331
diff --git a/www/resin2/files/install.sh b/www/resin2/files/install.sh
index 36e53c1e9bac..b7497633e60d 100644
--- a/www/resin2/files/install.sh
+++ b/www/resin2/files/install.sh
@@ -36,13 +36,13 @@ echo Created installation directory %%APP_HOME%%
list()
{
- for dir in doc lib xsl ; do
+ for dir in %%COPYDIRS%% ; do
( cd %%WRKSRC%% ; find $dir )
done
}
# Remove all empty dirs
-( cd %%WRKSRC%% ; find doc -type d -empty -delete )
+( cd %%WRKSRC%% && find %%COPYDIRS%% -type d -empty -delete )
echo Installing in %%APP_HOME%%
list | xargs tar -C %%WRKSRC%% -cf- | tar -C %%APP_HOME%% -xpf-
diff --git a/www/resin2/files/patch-Makefile.in b/www/resin2/files/patch-Makefile.in
deleted file mode 100644
index 5754ce64ac6d..000000000000
--- a/www/resin2/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/c/plugin/resin/Makefile.in.orig Fri Feb 14 21:48:23 2003
-+++ src/c/plugin/resin/Makefile.in Wed Mar 5 19:11:12 2003
-@@ -20,7 +20,7 @@
- all : resin libresin.$(SO)
-
- resin : resin.o $(OBJ)
-- $(CC) $(LDFLAGS) -o $@ resin.o $(OBJ) $(PROXY_LIBS) -ldl
-+ $(CC) $(LDFLAGS) -o $@ resin.o $(OBJ) $(PROXY_LIBS)
-
- resin_so : libresin.$(SO)
-
diff --git a/www/resin2/pkg-descr b/www/resin2/pkg-descr
index 20d0cc9d42e9..015d3d5586de 100644
--- a/www/resin2/pkg-descr
+++ b/www/resin2/pkg-descr
@@ -6,4 +6,20 @@ includes a full-featured HTTP/1.1 web server, provides a fast servlet runner
for Apache, and supports the latest Servlet 2.3 and JSP 1.2 specifications from
Sun.
+o You may use Resin for development, evaluation, and demos.
+o You must contact us to purchase a deployment license if either:
+
+ * You are paid to use Resin.
+ * You are paying someone else to use Resin.
+
+o If no one is paid to use Resin, you may use Resin for deployment:
+
+ * students
+ * private use
+ * tiny startups with neither funding nor income.
+
+o Anyone falling in between should contact us for a waiver.
+o Distributors must contact us.
+o If you are allowed to use Resin, you may modify the source for that use.
+
WWW: http://www.caucho.com/
diff --git a/www/resin2/pkg-plist b/www/resin2/pkg-plist
index 3992967ac5e4..5d8a8b488a57 100644
--- a/www/resin2/pkg-plist
+++ b/www/resin2/pkg-plist
@@ -381,6 +381,7 @@
%%APP_NAME%%/xsl/js/caucho/defaultcopy.xsl
%%APP_NAME%%/xsl/js/caucho/format.xsl
%%APP_NAME%%/xsl/js/caucho/weblog.xsl
+%%APP_NAME%%/libexec/libresin.so
etc/rc.d/%%APP_NAME%%.sh
sbin/%%APP_NAME%%ctl
%%MOD_DIR%%/mod_caucho.so
@@ -451,6 +452,7 @@ sbin/%%APP_NAME%%ctl
@dirrm %%APP_NAME%%/xsl/js/caucho
@dirrm %%APP_NAME%%/xsl/js
@dirrm %%APP_NAME%%/xsl
+@dirrm %%APP_NAME%%/libexec
@dirrm %%APP_NAME%%
@unexec if cmp -s %D/etc/%%APP_NAME%%.xml %D/etc/%%APP_NAME%%.xml-dist; then rm -f %D/etc/%%APP_NAME%%.xml; else echo If permanently deleting this package, %D/etc/%%APP_NAME%%.xml must be removed manually; fi
etc/%%APP_NAME%%.xml-dist