aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/erlang-eredis/Makefile2
-rw-r--r--devel/erlang-getopt/Makefile4
-rw-r--r--devel/erlang-gproc/Makefile2
-rw-r--r--devel/erlang-msgpack/Makefile6
-rw-r--r--devel/erlang-protobuffs/Makefile4
-rw-r--r--devel/erlang-recon/Makefile2
6 files changed, 0 insertions, 20 deletions
diff --git a/databases/erlang-eredis/Makefile b/databases/erlang-eredis/Makefile
index dff4bf75dab0..863e4efdde68 100644
--- a/databases/erlang-eredis/Makefile
+++ b/databases/erlang-eredis/Makefile
@@ -21,8 +21,6 @@ USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= wooga
-.include <bsd.port.options.mk>
-
do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
diff --git a/devel/erlang-getopt/Makefile b/devel/erlang-getopt/Makefile
index 1b4a94c8424e..9c35bf6e8519 100644
--- a/devel/erlang-getopt/Makefile
+++ b/devel/erlang-getopt/Makefile
@@ -20,13 +20,9 @@ USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= jcomellas
-.include <bsd.port.options.mk>
-
do-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
-.endif
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
diff --git a/devel/erlang-gproc/Makefile b/devel/erlang-gproc/Makefile
index 46cf5ded0ddd..ecbb8478ce60 100644
--- a/devel/erlang-gproc/Makefile
+++ b/devel/erlang-gproc/Makefile
@@ -21,8 +21,6 @@ PLIST_SUB= VERSION="${PORTVERSION}"
USE_GITHUB= yes
GH_ACCOUNT= uwiger
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -i '' -e 's/{ *vsn, git *}/{vsn, "${PORTVERSION}"}/' ${WRKSRC}/src/*.app.src
diff --git a/devel/erlang-msgpack/Makefile b/devel/erlang-msgpack/Makefile
index d34601d74379..0c0b5f4a7341 100644
--- a/devel/erlang-msgpack/Makefile
+++ b/devel/erlang-msgpack/Makefile
@@ -20,18 +20,12 @@ USE_GITHUB= yes
GH_ACCOUNT= msgpack
GH_PROJECT= msgpack-erlang
-OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -i '' -e 's/{ *vsn, git *}/{vsn, "${PORTVERSION}"}/' ${WRKSRC}/src/*.app.src
do-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
-.endif
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
diff --git a/devel/erlang-protobuffs/Makefile b/devel/erlang-protobuffs/Makefile
index 575eb80a5ecb..a7e4a41464af 100644
--- a/devel/erlang-protobuffs/Makefile
+++ b/devel/erlang-protobuffs/Makefile
@@ -18,18 +18,14 @@ USE_GITHUB= yes
GH_ACCOUNT= basho
GH_PROJECT= erlang_protobuffs
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -i '' -e 's/{ *vsn, git *}/{vsn, "${PORTVERSION}"}/' ${WRKSRC}/src/*.app.src
do-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.markdown ${STAGEDIR}${DOCSDIR}
-.endif
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
diff --git a/devel/erlang-recon/Makefile b/devel/erlang-recon/Makefile
index 96e9fef522e4..69e236209aba 100644
--- a/devel/erlang-recon/Makefile
+++ b/devel/erlang-recon/Makefile
@@ -18,8 +18,6 @@ PLIST_SUB= VERSION="${PORTVERSION}"
USE_GITHUB= yes
GH_ACCOUNT= ferd
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -i '' -e "s@%%LOCALBASE%%@${LOCALBASE}@" ${WRKSRC}/script/app_deps.erl