aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/secretmaryochronicles-music/Makefile26
-rw-r--r--games/secretmaryochronicles-music/pkg-plist2
2 files changed, 7 insertions, 21 deletions
diff --git a/games/secretmaryochronicles-music/Makefile b/games/secretmaryochronicles-music/Makefile
index caf9a61b79a3..c7ce60e26a72 100644
--- a/games/secretmaryochronicles-music/Makefile
+++ b/games/secretmaryochronicles-music/Makefile
@@ -18,30 +18,14 @@ WRKSRC= ${WRKDIR}
DATADIR= ${PREFIX}/share/smc
NO_BUILD= yes
-PORTDOCS= Addon_-_Music_Readme.txt
-
-NO_STAGE= yes
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-post-patch:
-# The pointyhat build system doesn't like spaces in $PORTDOCS,
-# so this makes it happier
- ${MV} ${WRKSRC}/docs/Addon\ -\ Music\ Readme.txt \
- ${WRKSRC}/docs/Addon_-_Music_Readme.txt
-
do-install:
- cd ${WRKSRC}/data && \
- ${FIND} music | ${CPIO} -pdmvu ${DATADIR}
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
-.endfor
-.endif
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} music ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/Addon\ -\ Music\ Readme.txt \
+ ${STAGEDIR}${DOCSDIR}/Addon_-_Music_Readme.txt
.include <bsd.port.mk>
diff --git a/games/secretmaryochronicles-music/pkg-plist b/games/secretmaryochronicles-music/pkg-plist
index 6954a2c20dcf..1414106b2cb6 100644
--- a/games/secretmaryochronicles-music/pkg-plist
+++ b/games/secretmaryochronicles-music/pkg-plist
@@ -48,3 +48,5 @@
@dirrm %%DATADIR%%/music/overworld
@dirrm %%DATADIR%%/music/land
@dirrm %%DATADIR%%/music/game
+@dirrmtry %%DATADIR%%/music
+@dirrmtry %%DATADIR%%