aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/window/Makefile31
-rw-r--r--misc/window/distinfo3
-rw-r--r--misc/window/pkg-descr3
4 files changed, 38 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d99959d3bb96..a881572ac34e 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -573,6 +573,7 @@
SUBDIR += voltcraft304
SUBDIR += wanpipe
SUBDIR += whichman
+ SUBDIR += window
SUBDIR += wmScoreBoard
SUBDIR += wmcalendar
SUBDIR += wmfirew
diff --git a/misc/window/Makefile b/misc/window/Makefile
new file mode 100644
index 000000000000..3a1e5f574f7f
--- /dev/null
+++ b/misc/window/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: window
+# Date created: 31 May 2009
+# Whom: Tom Rhodes <trhodes@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= window
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= http://people.FreeBSD.org/~trhodes/
+
+MAINTAINER= trhodes@FreeBSD.org
+COMMENT= The FreeBSD usr.bin/window application
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800093
+IGNORE= window-1.0 is still part of the base system
+.endif
+
+WRKSRC= ${WRKDIR}/window
+
+MAN1= window.1
+PLIST_FILES= bin/window
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/window ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/misc/window/distinfo b/misc/window/distinfo
new file mode 100644
index 000000000000..a3986754d55f
--- /dev/null
+++ b/misc/window/distinfo
@@ -0,0 +1,3 @@
+MD5 (window-1.0.tar.gz) = a121850e0913578033559f90914b7540
+SHA256 (window-1.0.tar.gz) = f70e9cf01c7459563a321b7db62460ad5f714166fa98e3da92076cbd2d72a8cd
+SIZE (window-1.0.tar.gz) = 84083
diff --git a/misc/window/pkg-descr b/misc/window/pkg-descr
new file mode 100644
index 000000000000..fc19654100c0
--- /dev/null
+++ b/misc/window/pkg-descr
@@ -0,0 +1,3 @@
+The window utility implements a window environment on ASCII terminals.
+It was once distributed as part of the base system. This version includes
+several code fixes such as removal of 'register' keyword.