aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.mk2
-rw-r--r--Tools/scripts/dialog4ports.sh4
2 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 2fa3c44700ee..b0aabb50006e 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6099,6 +6099,8 @@ D4P_ENV= PKGNAME="${PKGNAME}" \
OPTIONS_RADIO="${OPTIONS_RADIO}" \
OPTIONS_GROUP="${OPTIONS_GROUP}" \
DIALOG4PORTS="${DIALOG4PORTS}" \
+ PREFIX="${PREFIX}" \
+ LOCALBASE="${LOCALBASE}" \
PORTSDIR="${PORTSDIR}" \
MAKE="${MAKE}" \
D4PHEIGHT="${D4PHEIGHT}" \
diff --git a/Tools/scripts/dialog4ports.sh b/Tools/scripts/dialog4ports.sh
index b3303efb972a..77f3495cb668 100644
--- a/Tools/scripts/dialog4ports.sh
+++ b/Tools/scripts/dialog4ports.sh
@@ -15,7 +15,9 @@ OPTIONSFILE="$1"
if ! [ -e $DIALOG4PORTS ]; then
# If INSTALL_AS_USER is set then just build and use the WRKDIR version
- if [ -n "${INSTALL_AS_USER}" ]; then
+ # Also do this if PREFIX!=LOCALBASE to avoid missing file or double
+ # installs
+ if [ -n "${INSTALL_AS_USER}" -o "${PREFIX}" != "${LOCALBASE}" ]; then
if ! [ -d "${PORTSDIR}/${DIALOGPORT}" ]; then
echo "===> Skipping 'config' as ${DIALOGPORT} is not checked out" >&2
exit 1