aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--converters/osm2mp/Makefile16
-rw-r--r--converters/p5-PerlIO-via-Unidecode/Makefile4
-rw-r--r--math/p5-Math-Geometry-Planar-GPC-Polygon/Makefile4
-rw-r--r--math/p5-Math-Polygon-Tree/Makefile8
-rw-r--r--textproc/p5-Geo-Parse-OSM/Makefile6
5 files changed, 19 insertions, 19 deletions
diff --git a/converters/osm2mp/Makefile b/converters/osm2mp/Makefile
index 3a403f87cea8..4571a188a71e 100644
--- a/converters/osm2mp/Makefile
+++ b/converters/osm2mp/Makefile
@@ -13,14 +13,14 @@ MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= OpenStreetMap data into Polish map format (MP) convertor
-RUN_DEPENDS= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
- ${SITE_PERL}/Encode/Locale.pm:${PORTSDIR}/converters/p5-Encode-Locale \
- ${SITE_PERL}/Math/Polygon.pm:${PORTSDIR}/math/p5-Math-Polygon \
- ${SITE_PERL}/Math/Polygon/Tree.pm:${PORTSDIR}/math/p5-Math-Polygon-Tree \
- ${SITE_PERL}/Tree/R.pm:${PORTSDIR}/devel/p5-Tree-R \
- ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
- ${SITE_PERL}/${PERL_ARCH}/Math/Geometry/Planar/GPC/Polygon.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC-Polygon \
- ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils
+RUN_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
+ p5-Encode-Locale>=0:${PORTSDIR}/converters/p5-Encode-Locale \
+ p5-Math-Polygon>=0:${PORTSDIR}/math/p5-Math-Polygon \
+ p5-Math-Polygon-Tree>=0:${PORTSDIR}/math/p5-Math-Polygon-Tree \
+ p5-Tree-R>=0:${PORTSDIR}/devel/p5-Tree-R \
+ p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-Math-Geometry-Planar-GPC-Polygon>=0:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC-Polygon \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
LICENSE= GPLv2
diff --git a/converters/p5-PerlIO-via-Unidecode/Makefile b/converters/p5-PerlIO-via-Unidecode/Makefile
index 3f4d066ba1d6..c6308859c163 100644
--- a/converters/p5-PerlIO-via-Unidecode/Makefile
+++ b/converters/p5-PerlIO-via-Unidecode/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A perlio layer for Unidecode
-BUILD_DEPENDS= ${SITE_PERL}/Text/Unidecode.pm:${PORTSDIR}/converters/p5-Text-Unidecode
-RUN_DEPENDS= ${SITE_PERL}/Text/Unidecode.pm:${PORTSDIR}/converters/p5-Text-Unidecode
+BUILD_DEPENDS= p5-Text-Unidecode>=0:${PORTSDIR}/converters/p5-Text-Unidecode
+RUN_DEPENDS= p5-Text-Unidecode>=0:${PORTSDIR}/converters/p5-Text-Unidecode
PERL_CONFIGURE= yes
diff --git a/math/p5-Math-Geometry-Planar-GPC-Polygon/Makefile b/math/p5-Math-Geometry-Planar-GPC-Polygon/Makefile
index 3fd0c1a39900..a6aa389114d9 100644
--- a/math/p5-Math-Geometry-Planar-GPC-Polygon/Makefile
+++ b/math/p5-Math-Geometry-Planar-GPC-Polygon/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= OO wrapper to gpc library
-BUILD_DEPENDS= ${SITE_PERL}/Inline/MakeMaker.pm:${PORTSDIR}/devel/p5-Inline
-RUN_DEPENDS= ${SITE_PERL}/Inline/MakeMaker.pm:${PORTSDIR}/devel/p5-Inline
+BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
+RUN_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
PERL_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/math/p5-Math-Polygon-Tree/Makefile b/math/p5-Math-Polygon-Tree/Makefile
index 473a6469e649..d499159bb0cd 100644
--- a/math/p5-Math-Polygon-Tree/Makefile
+++ b/math/p5-Math-Polygon-Tree/Makefile
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Class for fast check if point is inside polygon
-BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils \
- ${SITE_PERL}/${PERL_ARCH}/Math/Geometry/Planar/GPC/Polygon.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC-Polygon
+BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Math-Geometry-Planar-GPC-Polygon>=0:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC-Polygon
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/textproc/p5-Geo-Parse-OSM/Makefile b/textproc/p5-Geo-Parse-OSM/Makefile
index d33c294d6e95..01580e76da37 100644
--- a/textproc/p5-Geo-Parse-OSM/Makefile
+++ b/textproc/p5-Geo-Parse-OSM/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= OpenStreetMap XML file regexp parser
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils
+BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
RUN_DEPENDS:= ${BUILD_DEPENDS}
PORTSCOUT= skipv:0.221