aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/rhythmbox-devel/Makefile2
-rw-r--r--audio/rhythmbox-devel/pkg-plist3
-rw-r--r--audio/rhythmbox/Makefile2
-rw-r--r--audio/rhythmbox/pkg-plist3
-rw-r--r--deskutils/drivel/Makefile2
-rw-r--r--deskutils/drivel/pkg-plist3
-rw-r--r--games/monster-masher/Makefile2
-rw-r--r--games/monster-masher/pkg-plist3
-rw-r--r--misc/quick-lounge-applet/Makefile2
-rw-r--r--misc/quick-lounge-applet/pkg-plist3
-rw-r--r--x11/brightside/Makefile2
-rw-r--r--x11/brightside/pkg-plist3
12 files changed, 12 insertions, 18 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
index 87b2633919b3..078a9a472e8f 100644
--- a/audio/rhythmbox-devel/Makefile
+++ b/audio/rhythmbox-devel/Makefile
@@ -31,6 +31,8 @@ CONFIGURE_ARGS= --enable-nautilus-menu
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+GCONF_SCHEMAS= rhythmbox.schemas
+
OPTIONS= XINE "Use xine backend instead of GStreamer" off \
MONKEYMEDIA "Use MonkeyMedia metadata reader" off \
IPOD "Enable iPod support" off
diff --git a/audio/rhythmbox-devel/pkg-plist b/audio/rhythmbox-devel/pkg-plist
index 576f86e139a5..74aaaf42d9f5 100644
--- a/audio/rhythmbox-devel/pkg-plist
+++ b/audio/rhythmbox-devel/pkg-plist
@@ -1,7 +1,4 @@
bin/rhythmbox
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/rhythmbox.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/rhythmbox.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/rhythmbox.schemas > /dev/null || /usr/bin/true
lib/bonobo/librb-nautilus-context-menu.so
libdata/bonobo/servers/GNOME_Rhythmbox.server
libdata/bonobo/servers/Rhythmbox_Nautilus_Context_Menu.server
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 87b2633919b3..078a9a472e8f 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -31,6 +31,8 @@ CONFIGURE_ARGS= --enable-nautilus-menu
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+GCONF_SCHEMAS= rhythmbox.schemas
+
OPTIONS= XINE "Use xine backend instead of GStreamer" off \
MONKEYMEDIA "Use MonkeyMedia metadata reader" off \
IPOD "Enable iPod support" off
diff --git a/audio/rhythmbox/pkg-plist b/audio/rhythmbox/pkg-plist
index 576f86e139a5..74aaaf42d9f5 100644
--- a/audio/rhythmbox/pkg-plist
+++ b/audio/rhythmbox/pkg-plist
@@ -1,7 +1,4 @@
bin/rhythmbox
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/rhythmbox.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/rhythmbox.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/rhythmbox.schemas > /dev/null || /usr/bin/true
lib/bonobo/librb-nautilus-context-menu.so
libdata/bonobo/servers/GNOME_Rhythmbox.server
libdata/bonobo/servers/Rhythmbox_Nautilus_Context_Menu.server
diff --git a/deskutils/drivel/Makefile b/deskutils/drivel/Makefile
index 284926683156..bb01aca3eba5 100644
--- a/deskutils/drivel/Makefile
+++ b/deskutils/drivel/Makefile
@@ -26,6 +26,8 @@ USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+GCONF_SCHEMAS= drivel.schemas
+
.ifndef(WITHOUT_RHYTHMBOX)
CONFIGURE_ARGS+= --with-rhythmbox
BUILD_DEPENDS+= rhythmbox:${PORTSDIR}/audio/rhythmbox
diff --git a/deskutils/drivel/pkg-plist b/deskutils/drivel/pkg-plist
index c5e1f0f9d2d5..5d1c0e58478e 100644
--- a/deskutils/drivel/pkg-plist
+++ b/deskutils/drivel/pkg-plist
@@ -1,7 +1,4 @@
bin/drivel
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/drivel.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/drivel.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/drivel.schemas > /dev/null || /usr/bin/true
share/gnome/application-registry/drivel.applications
share/gnome/applications/drivel.desktop
share/gnome/drivel/glade/drivel.glade
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index 420f15ecb2b4..f3d81cf45cd3 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -26,6 +26,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASA}/lib"
+GCONF_SCHEMAS= monster-masher.schemas
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500010
diff --git a/games/monster-masher/pkg-plist b/games/monster-masher/pkg-plist
index 0ab24d520632..aabe0d9a2edd 100644
--- a/games/monster-masher/pkg-plist
+++ b/games/monster-masher/pkg-plist
@@ -1,7 +1,4 @@
bin/monster-masher
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/monster-masher.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/monster-masher.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/monster-masher.schemas > /dev/null || /usr/bin/true
share/gnome/applications/monster-masher.desktop
share/gnome/monster-masher/glade/ui.glade
share/gnome/monster-masher/pixmaps/block-24.png
diff --git a/misc/quick-lounge-applet/Makefile b/misc/quick-lounge-applet/Makefile
index e772cf9a85a2..4ab78b2f2eef 100644
--- a/misc/quick-lounge-applet/Makefile
+++ b/misc/quick-lounge-applet/Makefile
@@ -25,4 +25,6 @@ USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+GCONF_SCHEMAS= quick-lounge.schemas
+
.include <bsd.port.mk>
diff --git a/misc/quick-lounge-applet/pkg-plist b/misc/quick-lounge-applet/pkg-plist
index e5b837556669..596b446d5a49 100644
--- a/misc/quick-lounge-applet/pkg-plist
+++ b/misc/quick-lounge-applet/pkg-plist
@@ -1,6 +1,3 @@
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/quick-lounge.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/quick-lounge.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/quick-lounge.schemas > /dev/null || /usr/bin/true
libdata/bonobo/servers/GNOME_QuickLoungeApplet_Factory.server
libexec/quick-lounge-applet
share/gnome/gnome-2.0/ui/GNOME_QuickLoungeApplet.xml
diff --git a/x11/brightside/Makefile b/x11/brightside/Makefile
index 54d0a30b43e8..1b9763080ac6 100644
--- a/x11/brightside/Makefile
+++ b/x11/brightside/Makefile
@@ -23,4 +23,6 @@ CONFIGURE_ARGS= --enable-tray-icon
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+GCONF_SCHEMAS= brightside.schemas
+
.include <bsd.port.mk>
diff --git a/x11/brightside/pkg-plist b/x11/brightside/pkg-plist
index dd11f2686058..746479636cea 100644
--- a/x11/brightside/pkg-plist
+++ b/x11/brightside/pkg-plist
@@ -1,8 +1,5 @@
bin/brightside
bin/brightside-properties
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/brightside.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/brightside.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/brightside.schemas > /dev/null || /usr/bin/true
share/gnome/brightside/brightside-16.png
share/gnome/brightside/brightside-48.png
share/gnome/brightside/brightside-brightness.png