aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pglogical/Makefile41
-rw-r--r--databases/pglogical/distinfo3
-rw-r--r--databases/pglogical/pkg-descr7
-rw-r--r--databases/pglogical/pkg-message6
-rw-r--r--databases/pglogical/pkg-plist11
6 files changed, 69 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 33a4773d6f29..f4e951560f0e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -567,6 +567,7 @@
SUBDIR += pgfouine
SUBDIR += pglesslog
SUBDIR += pgloader
+ SUBDIR += pglogical
SUBDIR += pglogical-output
SUBDIR += pgpool
SUBDIR += pgpool-II
diff --git a/databases/pglogical/Makefile b/databases/pglogical/Makefile
new file mode 100644
index 000000000000..754e38aff751
--- /dev/null
+++ b/databases/pglogical/Makefile
@@ -0,0 +1,41 @@
+# Created by: Matthew Seaman
+# $FreeBSD$
+
+PORTNAME= pglogical
+PORTVERSION= 1.1.1
+CATEGORIES= databases
+MASTER_SITES= http://packages.2ndquadrant.com/pglogical/tarballs/
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Logical replication system as a PostgreSQL extension
+
+LICENSE= PostgreSQL
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/postgresql/pglogical_output.so:databases/pglogical-output
+RUN_DEPENDS= ${LOCALBASE}/lib/postgresql/pglogical_output.so:databases/pglogical-output
+
+USES= gmake pgsql:9.4+ tar:bzip2
+WANT_PGSQL= client server
+
+MAKE_ARGS= USE_PGXS=1
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_PORTDOCS= *
+
+# FFI
+#TEST_DEPENDS= pg_regress:databases/postgresql${PGSQL_VER_NODOT}-pg_regress
+#TEST_TARGET= do-test
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pglogical_create_subscriber
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pglogical.so
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
+
+#do-test:
+# ${MAKE} ${MAKE_ARGS} check
+
+.include <bsd.port.mk>
diff --git a/databases/pglogical/distinfo b/databases/pglogical/distinfo
new file mode 100644
index 000000000000..ecbd5347befc
--- /dev/null
+++ b/databases/pglogical/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465421707
+SHA256 (pglogical-1.1.1.tar.bz2) = 1c66e52e43cae208b31d6d6f5cdcf01dc67371fe4ea7f079ac86d49834055d55
+SIZE (pglogical-1.1.1.tar.bz2) = 256832
diff --git a/databases/pglogical/pkg-descr b/databases/pglogical/pkg-descr
new file mode 100644
index 000000000000..6d627e92af11
--- /dev/null
+++ b/databases/pglogical/pkg-descr
@@ -0,0 +1,7 @@
+pglogical is a logical replication system implemented entirely as a
+PostgreSQL extension. Fully integrated, it requires no triggers or
+external programs. This alternative to physical replication is a
+highly efficient method of replicating data using a publish/subscribe
+model for selective replication.
+
+WWW: http://2ndquadrant.com/en/resources/pglogical/
diff --git a/databases/pglogical/pkg-message b/databases/pglogical/pkg-message
new file mode 100644
index 000000000000..88327cd5b9b6
--- /dev/null
+++ b/databases/pglogical/pkg-message
@@ -0,0 +1,6 @@
+
+The pglogical extension is pointless without the pglogical-output
+extension, and vice versa. Please install both pglogical and
+pglogical-output extensions (that match the local postgresql server
+version) on both the sending and receiving instances of postgresql
+server.
diff --git a/databases/pglogical/pkg-plist b/databases/pglogical/pkg-plist
new file mode 100644
index 000000000000..c0577c3b0bf4
--- /dev/null
+++ b/databases/pglogical/pkg-plist
@@ -0,0 +1,11 @@
+bin/pglogical_create_subscriber
+lib/postgresql/pglogical.so
+share/postgresql/extension/pglogical--1.0.0--1.0.1.sql
+share/postgresql/extension/pglogical--1.0.0--1.1.0.sql
+share/postgresql/extension/pglogical--1.0.0.sql
+share/postgresql/extension/pglogical--1.0.1--1.1.0.sql
+share/postgresql/extension/pglogical--1.0.1.sql
+share/postgresql/extension/pglogical--1.1.0--1.1.1.sql
+share/postgresql/extension/pglogical--1.1.0.sql
+share/postgresql/extension/pglogical--1.1.1.sql
+share/postgresql/extension/pglogical.control