aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Inline-CPP/Makefile4
-rw-r--r--devel/p5-Inline-CPP/distinfo4
-rw-r--r--devel/p5-Inline-CPP/files/patch-Makefile.PL8
3 files changed, 8 insertions, 8 deletions
diff --git a/devel/p5-Inline-CPP/Makefile b/devel/p5-Inline-CPP/Makefile
index 357db286bf61..556d44903b79 100644
--- a/devel/p5-Inline-CPP/Makefile
+++ b/devel/p5-Inline-CPP/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Inline-CPP
-PORTVERSION= 0.73
+PORTVERSION= 0.74
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,7 +16,7 @@ BUILD_DEPENDS= p5-Inline>=0.78:${PORTSDIR}/devel/p5-Inline \
p5-Inline-C>=0.67:${PORTSDIR}/devel/p5-Inline-C \
p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
RUN_DEPENDS:= ${BUILD_DEPENDS}
-BUILD_DEPENDS+= p5-ExtUtils-CppGuess>=0.07:${PORTSDIR}/devel/p5-ExtUtils-CppGuess
+BUILD_DEPENDS+= p5-ExtUtils-CppGuess>=0.11:${PORTSDIR}/devel/p5-ExtUtils-CppGuess
NO_ARCH= yes
USES= perl5
diff --git a/devel/p5-Inline-CPP/distinfo b/devel/p5-Inline-CPP/distinfo
index 6ba739b90ae0..89eec45d1b41 100644
--- a/devel/p5-Inline-CPP/distinfo
+++ b/devel/p5-Inline-CPP/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Inline-CPP-0.73.tar.gz) = 42be80f4de265ea2641f9db32439d59ad02f116900899cd30631dd3b8366f7fe
-SIZE (Inline-CPP-0.73.tar.gz) = 63259
+SHA256 (Inline-CPP-0.74.tar.gz) = 2f2fda43d760cf398ee07d5d0ac1f60c7880ea48e544136f6ecd663783fe8858
+SIZE (Inline-CPP-0.74.tar.gz) = 63298
diff --git a/devel/p5-Inline-CPP/files/patch-Makefile.PL b/devel/p5-Inline-CPP/files/patch-Makefile.PL
index 99a5dd7bcda2..07edc94273fb 100644
--- a/devel/p5-Inline-CPP/files/patch-Makefile.PL
+++ b/devel/p5-Inline-CPP/files/patch-Makefile.PL
@@ -1,12 +1,12 @@
---- Makefile.PL.orig 2014-12-26 05:17:26.000000000 +0800
-+++ Makefile.PL 2015-01-01 04:23:51.734420696 +0800
-@@ -37,10 +37,10 @@
+--- Makefile.PL.orig 2015-09-10 19:21:06 UTC
++++ Makefile.PL
+@@ -37,10 +37,10 @@ check_prereqs( \%PREREQ_PM ) or warn "!!
my( $cc_guess, $libs_guess ) = guess_compiler();
my $cpp_compiler
- = prompt( "What C++ compiler would you like to use?", $cc_guess );
+ = $cc_guess;
-
+
my $libs
- = prompt( "What default libraries would you like to include?", $libs_guess );
+ = $libs_guess;