aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--chinese/chiconv/Makefile1
-rw-r--r--chinese/chiconv/files/patch-Makefile11
-rw-r--r--chinese/lunar/Makefile10
-rw-r--r--chinese/lunar/pkg-plist1
-rw-r--r--chinese/pcmanx/Makefile5
-rw-r--r--chinese/pcmanx/pkg-plist5
-rw-r--r--chinese/scim-pinyin/Makefile4
-rw-r--r--chinese/scim-pinyin/pkg-plist2
-rw-r--r--chinese/scim-tables/Makefile10
-rw-r--r--chinese/scim-tables/pkg-plist8
-rw-r--r--chinese/ttf2pt1/Makefile1
-rw-r--r--chinese/ttf2pt1/files/patch-Makefile18
-rw-r--r--chinese/ttf2pt1/pkg-plist16
13 files changed, 53 insertions, 39 deletions
diff --git a/chinese/chiconv/Makefile b/chinese/chiconv/Makefile
index f115f947b003..79fd6f09d7b9 100644
--- a/chinese/chiconv/Makefile
+++ b/chinese/chiconv/Makefile
@@ -18,7 +18,6 @@ GH_ACCOUNT= buganini
GH_COMMIT= 9501c80
MAKE_ARGS= PREFIX=${PREFIX}
-NO_STAGE= yes
PLIST_FILES= bin/chiconv
diff --git a/chinese/chiconv/files/patch-Makefile b/chinese/chiconv/files/patch-Makefile
new file mode 100644
index 000000000000..8761d9e65a6c
--- /dev/null
+++ b/chinese/chiconv/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2014-01-07 14:47:56.000000000 +0800
++++ Makefile 2014-01-07 14:48:06.000000000 +0800
+@@ -9,7 +9,7 @@ chiconv: chiconv.c
+ $(CC) ${CFLAGS} -o chiconv chiconv.c ${LIBS}
+
+ install:
+- install -m 555 chiconv ${PREFIX}/bin
++ install -m 555 chiconv $(DESTDIR)${PREFIX}/bin
+
+ clean:
+ rm -f chiconv
diff --git a/chinese/lunar/Makefile b/chinese/lunar/Makefile
index 468df39b03ba..0e73006a9f46 100644
--- a/chinese/lunar/Makefile
+++ b/chinese/lunar/Makefile
@@ -11,13 +11,11 @@ MAINTAINER= obrien@FreeBSD.org
COMMENT= Convert between Gregorian Solar Calendar (SC) and Lunar Calendar (LC)
ALL_TARGET=
-MAN1= lunar.1
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/share/chinese
- ${INSTALL_PROGRAM} ${WRKSRC}/lunar ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/lunar.bitmap ${PREFIX}/share/chinese
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/chinese
+ ${INSTALL_PROGRAM} ${WRKSRC}/lunar ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/lunar.bitmap ${STAGEDIR}${PREFIX}/share/chinese
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/chinese/lunar/pkg-plist b/chinese/lunar/pkg-plist
index 171c713a3971..207392f6ed28 100644
--- a/chinese/lunar/pkg-plist
+++ b/chinese/lunar/pkg-plist
@@ -1,4 +1,5 @@
@comment $FreeBSD$
bin/lunar
+man/man1/lunar.1.gz
share/chinese/lunar.bitmap
@dirrmtry share/chinese
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
index e3723e3639af..9776bdf7c378 100644
--- a/chinese/pcmanx/Makefile
+++ b/chinese/pcmanx/Makefile
@@ -29,9 +29,6 @@ EXTERNAL_DESC= External SSH/Telnet support
IPLOOKUP_DESC= IP location lookup support
PROXY_DESC= Proxy support
-MAN1= pcmanx.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -83,6 +80,6 @@ CONFIGURE_ARGS+=--enable-proxy
post-install:
@# create directory for user friendly
- ${MKDIR} ${DATADIR}/script/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/script/
.include <bsd.port.mk>
diff --git a/chinese/pcmanx/pkg-plist b/chinese/pcmanx/pkg-plist
index 285fdd91eb05..d214f16b2d0e 100644
--- a/chinese/pcmanx/pkg-plist
+++ b/chinese/pcmanx/pkg-plist
@@ -1,6 +1,6 @@
bin/pcmanx
+man/man1/pcmanx.1.gz
share/applications/pcmanx.desktop
-share/pixmaps/pcmanx.svg
%%NLS%%share/locale/zh_CN/LC_MESSAGES/pcmanx.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/pcmanx.mo
%%DATADIR%%/emoticons
@@ -11,6 +11,7 @@ share/pixmaps/pcmanx.svg
%%DATADIR%%/nancy_bot/example_msg.data
%%DATADIR%%/nancy_bot/example_usages.data
%%DATADIR%%/sitelist
-@dirrmtry %%DATADIR%%/nancy_bot
+share/pixmaps/pcmanx.svg
@dirrmtry %%DATADIR%%/script
+@dirrmtry %%DATADIR%%/nancy_bot
@dirrmtry %%DATADIR%%
diff --git a/chinese/scim-pinyin/Makefile b/chinese/scim-pinyin/Makefile
index 41a496e05415..28538565f5e5 100644
--- a/chinese/scim-pinyin/Makefile
+++ b/chinese/scim-pinyin/Makefile
@@ -23,7 +23,6 @@ LDFLAGS+= -L${LOCALBASE}/lib -lintl
OPTIONS_DEFINE= NLS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -34,7 +33,4 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/chinese/scim-pinyin/pkg-plist b/chinese/scim-pinyin/pkg-plist
index c3403f338b6b..b1aa34abd156 100644
--- a/chinese/scim-pinyin/pkg-plist
+++ b/chinese/scim-pinyin/pkg-plist
@@ -12,10 +12,10 @@ lib/scim-1.0/1.4.0/SetupUI/pinyin-imengine-setup.so
%%NLS%%share/locale/nl/LC_MESSAGES/scim-pinyin.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/scim-pinyin.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/scim-pinyin.mo
+share/scim/icons/smart-pinyin.png
share/scim/pinyin/phrase_lib
share/scim/pinyin/pinyin_phrase_index
share/scim/pinyin/pinyin_phrase_lib
share/scim/pinyin/pinyin_table
share/scim/pinyin/special_table
-share/scim/icons/smart-pinyin.png
@dirrm share/scim/pinyin
diff --git a/chinese/scim-tables/Makefile b/chinese/scim-tables/Makefile
index eed00472f6fd..4ea7d8f83d57 100644
--- a/chinese/scim-tables/Makefile
+++ b/chinese/scim-tables/Makefile
@@ -13,11 +13,9 @@ COMMENT= SCIM table based Chinese input methods
BUILD_DEPENDS= scim-make-table:${PORTSDIR}/textproc/scim-table-imengine
RUN_DEPENDS= scim-make-table:${PORTSDIR}/textproc/scim-table-imengine
-USES= pkgconfig
-USE_GMAKE= yes
+USES= pkgconfig gmake
GNU_CONFIGURE= yes
-NO_STAGE= yes
.include <bsd.port.pre.mk>
CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
@@ -28,10 +26,4 @@ LDFLAGS+= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS+= --disable-skim-support
-post-install:
- @${CAT} ${PKGMESSAGE}
- @${ECHO}
- @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
- @${ECHO}
-
.include <bsd.port.post.mk>
diff --git a/chinese/scim-tables/pkg-plist b/chinese/scim-tables/pkg-plist
index 598ec549b25f..42fe79cfc82e 100644
--- a/chinese/scim-tables/pkg-plist
+++ b/chinese/scim-tables/pkg-plist
@@ -1,9 +1,9 @@
share/scim/icons/Array30.png
+share/scim/icons/CNS11643.png
share/scim/icons/CangJie.png
share/scim/icons/CangJie3.png
share/scim/icons/CantonHK.png
share/scim/icons/Cantonese.png
-share/scim/icons/CNS11643.png
share/scim/icons/Dayi.png
share/scim/icons/EZ.png
share/scim/icons/Erbi-QS.png
@@ -18,12 +18,12 @@ share/scim/icons/Wubi.png
share/scim/icons/ZhuYin.png
share/scim/icons/Ziranma.png
share/scim/tables/Array30.bin
+share/scim/tables/CNS11643.bin
share/scim/tables/CangJie.bin
share/scim/tables/CangJie3.bin
share/scim/tables/CangJie5.bin
share/scim/tables/CantonHK.bin
share/scim/tables/Cantonese.bin
-share/scim/tables/CNS11643.bin
share/scim/tables/Dayi3.bin
share/scim/tables/EZ-Big.bin
share/scim/tables/Erbi-QS.bin
@@ -35,8 +35,8 @@ share/scim/tables/SmartCangJie6.bin
share/scim/tables/Stroke5.bin
share/scim/tables/Wu.bin
share/scim/tables/Wubi.bin
-share/scim/tables/ZhuYin.bin
share/scim/tables/ZhuYin-Big.bin
+share/scim/tables/ZhuYin.bin
share/scim/tables/Ziranma.bin
-@dirrmtry share/scim/icons
@dirrmtry share/scim/tables
+@dirrmtry share/scim/icons
diff --git a/chinese/ttf2pt1/Makefile b/chinese/ttf2pt1/Makefile
index 4dd18ba4e737..b0462f1efad5 100644
--- a/chinese/ttf2pt1/Makefile
+++ b/chinese/ttf2pt1/Makefile
@@ -17,5 +17,4 @@ MAKE_ARGS= INSTDIR="${PREFIX}"
NO_BUILD= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/chinese/ttf2pt1/files/patch-Makefile b/chinese/ttf2pt1/files/patch-Makefile
new file mode 100644
index 000000000000..db9fbc8d210a
--- /dev/null
+++ b/chinese/ttf2pt1/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig 2014-01-09 15:01:13.000000000 +0800
++++ Makefile 2014-01-09 15:02:05.000000000 +0800
+@@ -22,10 +22,11 @@ snapshot:
+ ./mkrel snapshot
+
+ install:
+- cp -p *.map $(SHAREDIR)/maps
+- chown $(OWNER) $(SHAREDIR)/maps/*.map
+- chgrp $(GROUP) $(SHAREDIR)/maps/*.map
+- chmod 0644 $(SHAREDIR)/maps/*.map
++ mkdir -p $(DESTDIR)$(SHAREDIR)/maps
++ cp -p *.map $(DESTDIR)$(SHAREDIR)/maps
++ chown $(OWNER) $(DESTDIR)$(SHAREDIR)/maps/*.map
++ chgrp $(GROUP) $(DESTDIR)$(SHAREDIR)/maps/*.map
++ chmod 0644 $(DESTDIR)$(SHAREDIR)/maps/*.map
+
+ uninstall:
+ for i in *.map; do rm -f $(SHAREDIR)/maps/$$i || exit 1; done
diff --git a/chinese/ttf2pt1/pkg-plist b/chinese/ttf2pt1/pkg-plist
index cfd9fc24e03c..7b2fd5719099 100644
--- a/chinese/ttf2pt1/pkg-plist
+++ b/chinese/ttf2pt1/pkg-plist
@@ -1,7 +1,9 @@
-share/ttf2pt1/maps/cubg5plus.map
-share/ttf2pt1/maps/cubig5.map
-share/ttf2pt1/maps/cugb.map
-share/ttf2pt1/maps/cugbk.map
-share/ttf2pt1/maps/ubig5.map
-share/ttf2pt1/maps/ugb.map
-share/ttf2pt1/maps/ugbk.map
+%%DATADIR%%/maps/cubg5plus.map
+%%DATADIR%%/maps/cubig5.map
+%%DATADIR%%/maps/cugb.map
+%%DATADIR%%/maps/cugbk.map
+%%DATADIR%%/maps/ubig5.map
+%%DATADIR%%/maps/ugb.map
+%%DATADIR%%/maps/ugbk.map
+@dirrmtry %%DATADIR%%/maps
+@dirrmtry %%DATADIR%%