aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/exim-devel/Makefile2
-rw-r--r--mail/exim-devel/files/patch-src::configure.default4
-rw-r--r--mail/exim-devel/pkg-install8
-rw-r--r--mail/exim-devel/pkg-message4
-rw-r--r--mail/exim-old/Makefile2
-rw-r--r--mail/exim-old/files/patch-src::configure.default4
-rw-r--r--mail/exim-old/pkg-install8
-rw-r--r--mail/exim-old/pkg-message4
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-src::configure.default4
-rw-r--r--mail/exim/pkg-install8
-rw-r--r--mail/exim/pkg-message4
12 files changed, 30 insertions, 24 deletions
diff --git a/mail/exim-devel/Makefile b/mail/exim-devel/Makefile
index a00321c119bf..10e2874d80d3 100644
--- a/mail/exim-devel/Makefile
+++ b/mail/exim-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.31
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
diff --git a/mail/exim-devel/files/patch-src::configure.default b/mail/exim-devel/files/patch-src::configure.default
index 9096beabbc5b..a5876067d758 100644
--- a/mail/exim-devel/files/patch-src::configure.default
+++ b/mail/exim-devel/files/patch-src::configure.default
@@ -4,7 +4,7 @@
# normal user. This isn't usually a problem, as most sites have an alias for
# root that redirects such mail to a human administrator.
-+exim_user = sendmail
++exim_user = exim
+exim_group = mail
never_users = root
@@ -34,7 +34,7 @@
file = /etc/aliases
search_type = lsearch
-# user = exim
-+ user = sendmail
++ user = exim
+ group = mail
file_transport = address_file
pipe_transport = address_pipe
diff --git a/mail/exim-devel/pkg-install b/mail/exim-devel/pkg-install
index 7f20505f46ef..85811906091a 100644
--- a/mail/exim-devel/pkg-install
+++ b/mail/exim-devel/pkg-install
@@ -1,8 +1,10 @@
#!/bin/sh
#
# Since FreeBSD does not supply a user for running an MTA in a sandbox
-# by default, use the traditional sendmail sandbox user, sendmail,
-# adding it if it does not exist.
+# by default, use user 'exim', adding it if it does not exist. Even
+# if FreeBSD supplied an MTA user, it's neglected to do so for so long
+# that every sandboxed MTA under the sun uses its own user, so user
+# 'exim' should probably be used forever.
#
# Modern FreeBSD systems already have a group mail.
#
@@ -11,7 +13,7 @@
PKG_PREFIX=${PKG_PREFIX:=/usr/local}
-user=sendmail
+user=exim
group=mail
if [ "$2" = "PRE-INSTALL" ]; then
diff --git a/mail/exim-devel/pkg-message b/mail/exim-devel/pkg-message
index c9528f875335..37cad9514031 100644
--- a/mail/exim-devel/pkg-message
+++ b/mail/exim-devel/pkg-message
@@ -18,6 +18,6 @@ To run Exim instead of sendmail on startup:
You may also want to configure newsyslog(8) to rotate Exim log files:
# Only HUP Exim once when rejectlog and mainlog are rotated.
-/var/log/exim/mainlog sendmail:mail 640 7 * @T00 Z /var/run/exim.pid
-/var/log/exim/rejectlog sendmail:mail 640 7 * @T00 Z
+/var/log/exim/mainlog exim:mail 640 7 * @T00 Z /var/run/exim.pid
+/var/log/exim/rejectlog exim:mail 640 7 * @T00 Z
diff --git a/mail/exim-old/Makefile b/mail/exim-old/Makefile
index a00321c119bf..10e2874d80d3 100644
--- a/mail/exim-old/Makefile
+++ b/mail/exim-old/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.31
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
diff --git a/mail/exim-old/files/patch-src::configure.default b/mail/exim-old/files/patch-src::configure.default
index 9096beabbc5b..a5876067d758 100644
--- a/mail/exim-old/files/patch-src::configure.default
+++ b/mail/exim-old/files/patch-src::configure.default
@@ -4,7 +4,7 @@
# normal user. This isn't usually a problem, as most sites have an alias for
# root that redirects such mail to a human administrator.
-+exim_user = sendmail
++exim_user = exim
+exim_group = mail
never_users = root
@@ -34,7 +34,7 @@
file = /etc/aliases
search_type = lsearch
-# user = exim
-+ user = sendmail
++ user = exim
+ group = mail
file_transport = address_file
pipe_transport = address_pipe
diff --git a/mail/exim-old/pkg-install b/mail/exim-old/pkg-install
index 7f20505f46ef..85811906091a 100644
--- a/mail/exim-old/pkg-install
+++ b/mail/exim-old/pkg-install
@@ -1,8 +1,10 @@
#!/bin/sh
#
# Since FreeBSD does not supply a user for running an MTA in a sandbox
-# by default, use the traditional sendmail sandbox user, sendmail,
-# adding it if it does not exist.
+# by default, use user 'exim', adding it if it does not exist. Even
+# if FreeBSD supplied an MTA user, it's neglected to do so for so long
+# that every sandboxed MTA under the sun uses its own user, so user
+# 'exim' should probably be used forever.
#
# Modern FreeBSD systems already have a group mail.
#
@@ -11,7 +13,7 @@
PKG_PREFIX=${PKG_PREFIX:=/usr/local}
-user=sendmail
+user=exim
group=mail
if [ "$2" = "PRE-INSTALL" ]; then
diff --git a/mail/exim-old/pkg-message b/mail/exim-old/pkg-message
index c9528f875335..37cad9514031 100644
--- a/mail/exim-old/pkg-message
+++ b/mail/exim-old/pkg-message
@@ -18,6 +18,6 @@ To run Exim instead of sendmail on startup:
You may also want to configure newsyslog(8) to rotate Exim log files:
# Only HUP Exim once when rejectlog and mainlog are rotated.
-/var/log/exim/mainlog sendmail:mail 640 7 * @T00 Z /var/run/exim.pid
-/var/log/exim/rejectlog sendmail:mail 640 7 * @T00 Z
+/var/log/exim/mainlog exim:mail 640 7 * @T00 Z /var/run/exim.pid
+/var/log/exim/rejectlog exim:mail 640 7 * @T00 Z
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index a00321c119bf..10e2874d80d3 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.31
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
diff --git a/mail/exim/files/patch-src::configure.default b/mail/exim/files/patch-src::configure.default
index 9096beabbc5b..a5876067d758 100644
--- a/mail/exim/files/patch-src::configure.default
+++ b/mail/exim/files/patch-src::configure.default
@@ -4,7 +4,7 @@
# normal user. This isn't usually a problem, as most sites have an alias for
# root that redirects such mail to a human administrator.
-+exim_user = sendmail
++exim_user = exim
+exim_group = mail
never_users = root
@@ -34,7 +34,7 @@
file = /etc/aliases
search_type = lsearch
-# user = exim
-+ user = sendmail
++ user = exim
+ group = mail
file_transport = address_file
pipe_transport = address_pipe
diff --git a/mail/exim/pkg-install b/mail/exim/pkg-install
index 7f20505f46ef..85811906091a 100644
--- a/mail/exim/pkg-install
+++ b/mail/exim/pkg-install
@@ -1,8 +1,10 @@
#!/bin/sh
#
# Since FreeBSD does not supply a user for running an MTA in a sandbox
-# by default, use the traditional sendmail sandbox user, sendmail,
-# adding it if it does not exist.
+# by default, use user 'exim', adding it if it does not exist. Even
+# if FreeBSD supplied an MTA user, it's neglected to do so for so long
+# that every sandboxed MTA under the sun uses its own user, so user
+# 'exim' should probably be used forever.
#
# Modern FreeBSD systems already have a group mail.
#
@@ -11,7 +13,7 @@
PKG_PREFIX=${PKG_PREFIX:=/usr/local}
-user=sendmail
+user=exim
group=mail
if [ "$2" = "PRE-INSTALL" ]; then
diff --git a/mail/exim/pkg-message b/mail/exim/pkg-message
index c9528f875335..37cad9514031 100644
--- a/mail/exim/pkg-message
+++ b/mail/exim/pkg-message
@@ -18,6 +18,6 @@ To run Exim instead of sendmail on startup:
You may also want to configure newsyslog(8) to rotate Exim log files:
# Only HUP Exim once when rejectlog and mainlog are rotated.
-/var/log/exim/mainlog sendmail:mail 640 7 * @T00 Z /var/run/exim.pid
-/var/log/exim/rejectlog sendmail:mail 640 7 * @T00 Z
+/var/log/exim/mainlog exim:mail 640 7 * @T00 Z /var/run/exim.pid
+/var/log/exim/rejectlog exim:mail 640 7 * @T00 Z