aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/powerdns-recursor/Makefile11
-rw-r--r--dns/powerdns-recursor/distinfo4
-rw-r--r--dns/powerdns-recursor/files/patch-sendmsg_fix23
-rw-r--r--dns/powerdns/distinfo1
4 files changed, 9 insertions, 30 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 7ac4dca58508..1c78b0f3e084 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -1,11 +1,12 @@
# Created by: sten@blinkenlights.nl
# $FreeBSD$
-PORTNAME= powerdns-recursor
-PORTVERSION= 3.7.1
+PORTNAME= recursor
+PORTVERSION= 3.7.2
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
-DISTNAME= pdns-recursor-${PORTVERSION}
+PKGNAMEPREFIX= powerdns-
+DISTNAME= pdns-${PORTNAME}-${PORTVERSION}
MAINTAINER= tremere@cainites.net
COMMENT= Advanced DNS recursor
@@ -15,9 +16,11 @@ LICENSE= GPLv2
BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam \
${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-USES= gmake tar:bzip2
+USES= cpe gmake tar:bzip2
GNU_CONFIGURE= YES
+CPE_VENDOR= powerdns
+
OPTIONS_DEFINE= SETUID LUA STATIC
OPTIONS_DEFAULT= SETUID
SETUID_DESC= Run as pdns_recursor user
diff --git a/dns/powerdns-recursor/distinfo b/dns/powerdns-recursor/distinfo
index b223f7785cbe..ee43aed34578 100644
--- a/dns/powerdns-recursor/distinfo
+++ b/dns/powerdns-recursor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pdns-recursor-3.7.1.tar.bz2) = e6b0d255a0d8cd023ebd63c50f453a305c649d04873859b4119745d64b8bd36d
-SIZE (pdns-recursor-3.7.1.tar.bz2) = 245155
+SHA256 (pdns-recursor-3.7.2.tar.bz2) = 1366bc1bed7c96fbd3926cf7a9e6d365c53b8a99182642debe1b2863dd015a7e
+SIZE (pdns-recursor-3.7.2.tar.bz2) = 244582
diff --git a/dns/powerdns-recursor/files/patch-sendmsg_fix b/dns/powerdns-recursor/files/patch-sendmsg_fix
deleted file mode 100644
index 7646b7bc1c51..000000000000
--- a/dns/powerdns-recursor/files/patch-sendmsg_fix
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/pdns/pdns_recursor.cc b/pdns/pdns_recursor.cc
-index fdee0f1..23fca87 100644
---- pdns_recursor.cc
-+++ pdns_recursor.cc
-@@ -688,6 +688,8 @@ void startDoResolve(void *p)
- fillMSGHdr(&msgh, &iov, cbuf, 0, (char*)&*packet.begin(), packet.size(), &dc->d_remote);
- if(dc->d_local.sin4.sin_family)
- addCMsgSrcAddr(&msgh, cbuf, &dc->d_local);
-+ else
-+ msgh.msg_control=NULL;
- sendmsg(dc->d_socket, &msgh, 0);
- if(!SyncRes::s_nopacketcache && !variableAnswer ) {
- t_packetCache->insertResponsePacket(string((const char*)&*packet.begin(), packet.size()),
-@@ -961,6 +963,9 @@ string* doProcessUDPQuestion(const std::string& question, const ComboAddress& fr
- if(destaddr.sin4.sin_family) {
- addCMsgSrcAddr(&msgh, cbuf, &destaddr);
- }
-+ else {
-+ msgh.msg_control=NULL;
-+ }
- sendmsg(fd, &msgh, 0);
-
- if(response.length() >= sizeof(struct dnsheader)) {
diff --git a/dns/powerdns/distinfo b/dns/powerdns/distinfo
index 12cb09f77ded..583a8214eba6 100644
--- a/dns/powerdns/distinfo
+++ b/dns/powerdns/distinfo
@@ -1,3 +1,2 @@
SHA256 (pdns-3.4.4.tar.bz2) = ec49f5a0b55b69ba057bf9ce28ab81e5258fc60c8d4954d9100fe3bb3efd09c8
SIZE (pdns-3.4.4.tar.bz2) = 1336624
-