aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/arts/Makefile2
-rw-r--r--audio/arts/files/patch-mcop_mt_threads_posix.cc10
2 files changed, 11 insertions, 1 deletions
diff --git a/audio/arts/Makefile b/audio/arts/Makefile
index fb6991fcfe2e..23fc76aa4aa0 100644
--- a/audio/arts/Makefile
+++ b/audio/arts/Makefile
@@ -8,7 +8,7 @@
PORTNAME= arts
PORTVERSION= 1.5.10
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
diff --git a/audio/arts/files/patch-mcop_mt_threads_posix.cc b/audio/arts/files/patch-mcop_mt_threads_posix.cc
new file mode 100644
index 000000000000..533892223eaf
--- /dev/null
+++ b/audio/arts/files/patch-mcop_mt_threads_posix.cc
@@ -0,0 +1,10 @@
+--- mcop_mt/threads_posix.cc.orig 2009-01-12 11:45:39.000000000 +0100
++++ mcop_mt/threads_posix.cc 2009-01-12 11:46:13.000000000 +0100
+@@ -27,6 +27,7 @@
+ /* only compile this if we have libpthread available */
+ #ifdef HAVE_LIBPTHREAD
+
++#include <signal.h>
+ #include <gsl/gslconfig.h>
+
+ #include <sys/types.h>