aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/php5/Makefile.ext26
-rw-r--r--textproc/php5-simplexml/files/patch-config.m443
2 files changed, 54 insertions, 15 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index b03a457377c7..9edf926ad540 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -126,7 +126,7 @@ CONFIGURE_ARGS+=--enable-hash \
.endif
.if ${PHP_MODNAME} == "iconv"
-CONFIGURE_ARGS+=--with-iconv
+CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
USES+= iconv:translit
.endif
@@ -206,7 +206,10 @@ MYSQLND_DESC= Use MySQL Native Driver
.endif
.if ${PHP_MODNAME} == "odbc"
-CONFIGURE_ARGS+=--enable-odbc
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
+
+CONFIGURE_ARGS+=--enable-odbc \
+ --with-unixODBC=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "openssl"
@@ -255,6 +258,8 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
+CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
USE_PHP= pdo
USE_PHP_BUILD= yes
@@ -325,9 +330,9 @@ CONFIGURE_ARGS+=--enable-shmop
.if ${PHP_MODNAME} == "simplexml"
CONFIGURE_ARGS+=--enable-simplexml \
+ --with-pcre-dir=${LOCALBASE} \
--with-libxml-dir=${LOCALBASE}
-CFLAGS+= -I${LOCALBASE}/include
USES+= pkgconfig
USE_GNOME= libxml2
.endif
@@ -419,9 +424,10 @@ USE_PHP_BUILD= yes
.if ${PHP_MODNAME} == "xmlrpc"
CONFIGURE_ARGS+=--with-xmlrpc \
- --with-libxml-dir=${LOCALBASE}
+ --with-libxml-dir=${LOCALBASE} \
+ --with-iconv-dir=${LOCALBASE}
-USES+= iconv
+USES+= iconv::translit
USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc
@@ -549,11 +555,6 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
-.if ${PHP_MODNAME} == "odbc"
-LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
-CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
-.endif
-
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
@@ -562,11 +563,6 @@ LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif
.endif
-.if ${PHP_MODNAME} == "pdo_odbc"
-LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
-CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
-.endif
-
.if ${PHP_MODNAME} == "pdo_mysql"
. if ${PORT_OPTIONS:MMYSQLND}
CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
diff --git a/textproc/php5-simplexml/files/patch-config.m4 b/textproc/php5-simplexml/files/patch-config.m4
new file mode 100644
index 000000000000..4eeef697dc87
--- /dev/null
+++ b/textproc/php5-simplexml/files/patch-config.m4
@@ -0,0 +1,43 @@
+--- config.m4.orig 2014-05-14 10:14:22.929420181 +0000
++++ config.m4 2014-05-14 10:15:36.967414693 +0000
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(simplexml, whether to enable SimpleXML support,
+ [ --disable-simplexml Disable SimpleXML support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir SimpleXML: pcre install prefix], no, no)
++
+ if test -z "$PHP_LIBXML_DIR"; then
+ PHP_ARG_WITH(libxml-dir, libxml2 install dir,
+ [ --with-libxml-dir=DIR SimpleXML: libxml2 install prefix], no, no)
+@@ -11,6 +14,30 @@
+
+ if test "$PHP_SIMPLEXML" != "no"; then
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$PHP_LIBXML" = "no"; then
+ AC_MSG_ERROR([SimpleXML extension requires LIBXML extension, add --enable-libxml])
+ fi