aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--irc/party/Makefile4
-rw-r--r--net/mars_nwe/Makefile8
-rw-r--r--net/msend/Makefile8
-rw-r--r--net/poptop/Makefile8
-rw-r--r--net/rmsg/Makefile8
-rw-r--r--security/pam_alreadyloggedin/Makefile4
-rw-r--r--security/samhain/Makefile2
-rw-r--r--sysutils/p5-Sys-Utmp/Makefile8
-rw-r--r--x11/rxvt-devel/Makefile4
9 files changed, 49 insertions, 5 deletions
diff --git a/irc/party/Makefile b/irc/party/Makefile
index 9213b91ef3ac..661e2079b11c 100644
--- a/irc/party/Makefile
+++ b/irc/party/Makefile
@@ -18,6 +18,10 @@ MAN1= party.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
do-install:
${INSTALL_SCRIPT} -g nobody -o nobody -m 4711 ${WRKSRC}/party ${PREFIX}/bin
${MKDIR} ${PREFIX}/lib/party
diff --git a/net/mars_nwe/Makefile b/net/mars_nwe/Makefile
index a6fd2b3cfb9c..741e8be7085d 100644
--- a/net/mars_nwe/Makefile
+++ b/net/mars_nwe/Makefile
@@ -22,6 +22,12 @@ WRKSRC= ${WRKDIR}/mars_nwe
PLIST= ${WRKDIR}/PLIST.DYN
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
do-install:
@(cd ${WRKSRC} && ./mk.li install)
@${INSTALL_DATA} ${WRKSRC}/examples/nw.ini ${PREFIX}/etc/nwserv.conf.example
@@ -45,4 +51,4 @@ post-install:
.endif
@${ECHO_MSG} "Look in ${DOCSDIR} for documentation."
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/msend/Makefile b/net/msend/Makefile
index 08a9533c5ecd..f195d6eaef91 100644
--- a/net/msend/Makefile
+++ b/net/msend/Makefile
@@ -20,4 +20,10 @@ CFLAGS+= -DUSE_READLINE
MAN1= msend.1
MAN8= mesgd.8
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index 929e3cdc5e8e..92271dc27afa 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -39,4 +39,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/samples/pptpd.conf \
${PREFIX}/etc/pptpd.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/rmsg/Makefile b/net/rmsg/Makefile
index fa60cc60b5e8..7d2746e1469c 100644
--- a/net/rmsg/Makefile
+++ b/net/rmsg/Makefile
@@ -17,4 +17,10 @@ WRKSRC= ${WRKDIR}/rmsg
MAN1= rmsg.1
MAN8= rmsgd.8
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/pam_alreadyloggedin/Makefile b/security/pam_alreadyloggedin/Makefile
index d4beedcd0532..26d47f032142 100644
--- a/security/pam_alreadyloggedin/Makefile
+++ b/security/pam_alreadyloggedin/Makefile
@@ -20,6 +20,10 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if defined(NOPROFILE)
PLIST_SUB+= PROFILE="@comment "
.else
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index e2c09aa24ba2..b737bb3a9138 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -36,6 +36,8 @@ CFLAGS+= -fPIC
.if ${ARCH} == "amd64" && ${OSVERSION} >= 800000
BROKEN= does not compile
+.elif ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
.endif
.if defined(WITH_GPG)
diff --git a/sysutils/p5-Sys-Utmp/Makefile b/sysutils/p5-Sys-Utmp/Makefile
index 11ff5b9c70a4..a0ac69cb3a77 100644
--- a/sysutils/p5-Sys-Utmp/Makefile
+++ b/sysutils/p5-Sys-Utmp/Makefile
@@ -21,4 +21,10 @@ MAN3= Sys::Utmp.3 Sys::Utmp::Utent.3
post-patch:
@${REINPLACE_CMD} -e '254 s,strcpy,strncpy,' ${WRKSRC}/Utmp.xs
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/rxvt-devel/Makefile b/x11/rxvt-devel/Makefile
index abd9da67ce3b..3e61c83b1906 100644
--- a/x11/rxvt-devel/Makefile
+++ b/x11/rxvt-devel/Makefile
@@ -48,6 +48,10 @@ MAN1= rxvt.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
# enable 256 color
.if defined(WITH_256_COLOR)
CONFIGURE_ARGS+= --enable-256-color