aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/tcloo/Makefile33
-rw-r--r--devel/tcloo/distinfo2
-rw-r--r--devel/tcloo/pkg-descr7
-rw-r--r--devel/tcloo/pkg-plist6
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 333dc13c354c..7760aa4584fa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4292,6 +4292,7 @@
SUBDIR += tclgetopts
SUBDIR += tcllib
SUBDIR += tclmore
+ SUBDIR += tcloo
SUBDIR += tclreadline
SUBDIR += tclthread
SUBDIR += tcltls
diff --git a/devel/tcloo/Makefile b/devel/tcloo/Makefile
new file mode 100644
index 000000000000..aae17f5e2f74
--- /dev/null
+++ b/devel/tcloo/Makefile
@@ -0,0 +1,33 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= tcloo
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= SF/tcl/TclOO%20Package/${PORTVERSION}/
+DISTNAME= TclOO${PORTVERSION}
+
+MAINTAINER= tcltk@FreeBSD.org
+COMMENT= Implementation of TclOO for Tcl 8.5
+
+USE_TCL= 85
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
+ --exec-prefix=${PREFIX}
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MANN= class.n \
+ copy.n \
+ define.n \
+ my.n \
+ next.n \
+ object.n \
+ ooInfo.n \
+ self.n
+MAN3= Class.3 \
+ Method.3 \
+ OOInitStubs.3
+
+.include <bsd.port.mk>
diff --git a/devel/tcloo/distinfo b/devel/tcloo/distinfo
new file mode 100644
index 000000000000..ae7f1f029185
--- /dev/null
+++ b/devel/tcloo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (TclOO1.0.tar.gz) = e64d69b9f7f63476757efbcab72931b2b3ee3fec2984500df9f30c026907454d
+SIZE (TclOO1.0.tar.gz) = 230724
diff --git a/devel/tcloo/pkg-descr b/devel/tcloo/pkg-descr
new file mode 100644
index 000000000000..638d3cbe638e
--- /dev/null
+++ b/devel/tcloo/pkg-descr
@@ -0,0 +1,7 @@
+The TclOO Package is an implementation of TclOO for Tcl 8.5. It allows users to
+write code against TclOO without using Tcl 8.6, and originally started out as a
+way to progress implementation of TclOO without being tightly bound to the Tcl
+core. The implementation in Tcl 8.6 was later developed from this package's
+source.
+
+WWW: http://core.tcl.tk/tcloo/
diff --git a/devel/tcloo/pkg-plist b/devel/tcloo/pkg-plist
new file mode 100644
index 000000000000..a9edb9f2e3d7
--- /dev/null
+++ b/devel/tcloo/pkg-plist
@@ -0,0 +1,6 @@
+lib/TclOO%%PORTVERSION%%/libTclOO.so.1
+lib/TclOO%%PORTVERSION%%/pkgIndex.tcl
+lib/TclOO%%PORTVERSION%%/tclooConfig.sh
+lib/TclOO%%PORTVERSION%%/libTclOOstub.a
+include/tclOO.h
+include/tclOODecls.h