aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/jacode.pl/Makefile32
-rw-r--r--japanese/jacode.pl/distinfo2
-rw-r--r--japanese/jacode.pl/pkg-descr17
4 files changed, 52 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 3031b9613c16..b2ed47a72359 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -118,6 +118,7 @@
SUBDIR += ipadic
SUBDIR += ircII
SUBDIR += ja6
+ SUBDIR += jacode.pl
SUBDIR += jadetex-ptex
SUBDIR += japana
SUBDIR += japaneseAFM
diff --git a/japanese/jacode.pl/Makefile b/japanese/jacode.pl/Makefile
new file mode 100644
index 000000000000..f8439a1e148f
--- /dev/null
+++ b/japanese/jacode.pl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: jacode.pl
+# Date created: 2011-05-11
+# Whom: Takefu
+#
+# $FreeBSD$
+#
+
+PORTNAME= jacode.pl
+PORTVERSION= 2.13.4.9
+CATEGORIES= japanese perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IN/INA/${PORTNAME:S|.pl||}
+DISTNAME= ${PORTNAME:S|.pl||}-${PORTVERSION}
+
+MAINTAINER= takefu@airport.fm
+COMMENT= Perl library for Japanese character code conversion
+
+USE_PERL5_RUN= yes
+PLIST_FILES= ${SITE_PERL_REL}/${PORTNAME}
+NO_BUILD= yes
+
+LICENSE= GPLv1 ART10
+LICENSE_COMB= dual
+
+pre-install:
+ @cd ${WRKSRC}; ${PERL} ${WRKSRC}/test.pl
+
+do-install:
+ @${MKDIR} ${PREFIX}/${SITE_PERL_REL}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME} ${PREFIX}/${SITE_PERL_REL}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/japanese/jacode.pl/distinfo b/japanese/jacode.pl/distinfo
new file mode 100644
index 000000000000..0f781bf24cfa
--- /dev/null
+++ b/japanese/jacode.pl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jacode-2.13.4.9.tar.gz) = 6a53976fbc7f2abcba6dbba6203366912a9a9b297548cc22f4a5ed12fa99c08c
+SIZE (jacode-2.13.4.9.tar.gz) = 285542
diff --git a/japanese/jacode.pl/pkg-descr b/japanese/jacode.pl/pkg-descr
new file mode 100644
index 000000000000..3de9c6b2c6ca
--- /dev/null
+++ b/japanese/jacode.pl/pkg-descr
@@ -0,0 +1,17 @@
+jacode.pl - Perl library for Japanese character code conversion
+
+This software has upper compatibility to jcode.pl.
+
+* jcode.pl upper compatible
+* Perl4 script
+* Acts as a wrapper to Encode::from_to
+* Support HALFWIDTH KATAKANA
+* Support UTF-8 by cp932 to Unicode table
+ http://unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
+ http://support.microsoft.com/kb/170559/ja
+ (JIS X 0221:2007 BASIC JAPANESE and COMMON JAPANESE)
+* Hidden UTF8 flag
+* No Object oriented
+* Possible to re-use past code and how to
+
+WWW: http://search.cpan.org/dist/jacode/