aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-apetag/Makefile21
-rw-r--r--audio/py-apetag/distinfo3
-rw-r--r--audio/py-apetag/pkg-descr3
-rw-r--r--audio/py-apetag/pkg-plist3
5 files changed, 31 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 4168376868bd..35fd2e059699 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -486,6 +486,7 @@
SUBDIR += prokyon3
SUBDIR += pulseaudio
SUBDIR += py-ao
+ SUBDIR += py-apetag
SUBDIR += py-cddb
SUBDIR += py-eyed3
SUBDIR += py-flac
diff --git a/audio/py-apetag/Makefile b/audio/py-apetag/Makefile
new file mode 100644
index 000000000000..7d752baa647b
--- /dev/null
+++ b/audio/py-apetag/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: py-apetag
+# Date created: February 10, 2007
+# Whom: Chao Shin <quakelee@cn.freebsd.org>
+#
+# $FreeBSD$
+
+PORTNAME= apetag
+PORTVERSION= 1.0
+CATEGORIES= audio python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pylibape
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py-ApeTag-${PORTVERSION}
+
+MAINTAINER= quakelee@cn.freebsd.org
+COMMENT= Library for APE Tag written in Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/audio/py-apetag/distinfo b/audio/py-apetag/distinfo
new file mode 100644
index 000000000000..3d729d02a82f
--- /dev/null
+++ b/audio/py-apetag/distinfo
@@ -0,0 +1,3 @@
+MD5 (py-ApeTag-1.0.tar.gz) = 29e58765e71da222d6a6205433a12873
+SHA256 (py-ApeTag-1.0.tar.gz) = 96b146c17ab822bd6bb07d50927cb34dc0807f169f2c73b1ea7ea1c462e9db38
+SIZE (py-ApeTag-1.0.tar.gz) = 15078
diff --git a/audio/py-apetag/pkg-descr b/audio/py-apetag/pkg-descr
new file mode 100644
index 000000000000..c402b8832636
--- /dev/null
+++ b/audio/py-apetag/pkg-descr
@@ -0,0 +1,3 @@
+A pure Python library for manipulating APEv2 and ID3v1 tags.
+
+WWW: http://sourceforge.net/projects/pylibape/
diff --git a/audio/py-apetag/pkg-plist b/audio/py-apetag/pkg-plist
new file mode 100644
index 000000000000..bfb88b5f2c88
--- /dev/null
+++ b/audio/py-apetag/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/ApeTag.py
+%%PYTHON_SITELIBDIR%%/ApeTag.pyc
+%%PYTHON_SITELIBDIR%%/ApeTag.pyo