aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/nyh-hoc/Makefile21
-rw-r--r--math/nyh-hoc/distinfo3
-rw-r--r--math/nyh-hoc/pkg-descr14
4 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7468ef19ff71..348bf1c17355 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -167,6 +167,7 @@
SUBDIR += nsc2ke
SUBDIR += ntl
SUBDIR += numdiff
+ SUBDIR += nyh-hoc
SUBDIR += ocaml-ocamlgraph
SUBDIR += octave
SUBDIR += octave-devel
diff --git a/math/nyh-hoc/Makefile b/math/nyh-hoc/Makefile
new file mode 100644
index 000000000000..378dd568a9f7
--- /dev/null
+++ b/math/nyh-hoc/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hoc
+# Date created: 14 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hoc
+PORTVERSION= 9.1.2
+CATEGORIES= math
+MASTER_SITES= http://nadav.harel.org.il/homepage/hoc/ CENKES
+PKGNAMEPREFIX= nyh-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= High Order Calculator
+
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/math/nyh-hoc/distinfo b/math/nyh-hoc/distinfo
new file mode 100644
index 000000000000..8c2858bea11f
--- /dev/null
+++ b/math/nyh-hoc/distinfo
@@ -0,0 +1,3 @@
+MD5 (hoc-9.1.2.tgz) = bbd4a953d71f08d0071f9df93adcbd5e
+SHA256 (hoc-9.1.2.tgz) = bba14f7cc28218eeb1f5d506df6b0868df438cd12ba86805ec366ccaed854416
+SIZE (hoc-9.1.2.tgz) = 60819
diff --git a/math/nyh-hoc/pkg-descr b/math/nyh-hoc/pkg-descr
new file mode 100644
index 000000000000..b49f755be868
--- /dev/null
+++ b/math/nyh-hoc/pkg-descr
@@ -0,0 +1,14 @@
+Hoc, the High Order Calculator, is an interpreted language for
+floating-point calculations. Its most basic use is as a powerful and
+convenient calculator, interactively evaluating expressions such as
+1+2*sin(0.7). But hoc is no ordinary calculator: It also lets you
+assign values to variables, define your own functions, and use loops,
+conditionals, and everything else you'd expect in a programming
+language.
+
+Hoc was developed by Brian Kernighan and Rob Pike, and introduced in
+their 1984 book The Unix Programming Environment. This version has been
+extended and improved by Nadav Y. Har'El.
+
+WWW: http://nadav.harel.org.il/homepage/hoc/
+Author: Nadav Y. Har'El <nadav@harel.org.il>