aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--accessibility/at-spi2-atk/Makefile4
-rw-r--r--accessibility/at-spi2-core/Makefile4
-rw-r--r--accessibility/atk/Makefile4
-rw-r--r--accessibility/atkmm/Makefile4
-rw-r--r--accessibility/py-papi/Makefile8
-rw-r--r--astro/boinc-astropulse/Makefile2
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile2
-rw-r--r--astro/cfitsio/Makefile4
-rw-r--r--astro/gpsd/Makefile3
9 files changed, 15 insertions, 20 deletions
diff --git a/accessibility/at-spi2-atk/Makefile b/accessibility/at-spi2-atk/Makefile
index 3bd292f72607..ca984131a732 100644
--- a/accessibility/at-spi2-atk/Makefile
+++ b/accessibility/at-spi2-atk/Makefile
@@ -19,10 +19,10 @@ RUN_DEPENDS= at-spi2-core>=2.1.4:${PORTSDIR}/accessibility/at-spi2-core
PORTSCOUT= limitw:1,even
+USES= pkgconfig pathfix
USE_XZ= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomehier intlhack glib20 atk
-USE_PKGCONFIG= build
+USE_GNOME= gnomehier intlhack glib20 atk
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/accessibility/at-spi2-core/Makefile b/accessibility/at-spi2-core/Makefile
index d58997e9082b..20f733912997 100644
--- a/accessibility/at-spi2-core/Makefile
+++ b/accessibility/at-spi2-core/Makefile
@@ -18,11 +18,11 @@ LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
PORTSCOUT= limitw:1,even
+USES= pathfix pkgconfig
USE_XZ= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomehier glib20 intlhack
-USE_PKGCONFIG= build
+USE_GNOME= gnomehier glib20 intlhack
USE_XORG= x11 xi xtst xext
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/accessibility/atk/Makefile b/accessibility/atk/Makefile
index bdecb6bfa26f..10a0b104c5a7 100644
--- a/accessibility/atk/Makefile
+++ b/accessibility/atk/Makefile
@@ -18,12 +18,12 @@ USE_XZ= yes
BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+USES= pathfix pkgconfig
USE_GETTEXT= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehier gnomehack glib20 ltverhack referencehack
-USE_PKGCONFIG= build
+USE_GNOME= gnomehier glib20 ltverhack referencehack
CONFIGURE_ARGS= --enable-static \
--with-html-dir=${PREFIX}/share/doc
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/accessibility/atkmm/Makefile b/accessibility/atkmm/Makefile
index 0ee57c149d40..a6f0db8a03c4 100644
--- a/accessibility/atkmm/Makefile
+++ b/accessibility/atkmm/Makefile
@@ -10,12 +10,12 @@ MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= C++ wrapper for ATK API library
+USES= pathfix pkgconfig
USE_XZ= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-USE_GNOME= gnomehack atk glibmm
-USE_PKGCONFIG= build
+USE_GNOME= atk glibmm
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/accessibility/py-papi/Makefile b/accessibility/py-papi/Makefile
index 4032c768ce1b..700a9f780847 100644
--- a/accessibility/py-papi/Makefile
+++ b/accessibility/py-papi/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-papi
-# Date created: 2006-12-19
-# Whom: Marcus von Appen
-#
+# Created by: Marcus von Appen
# $FreeBSD$
-#
PORTNAME= papi
PORTVERSION= 0.0.9
@@ -14,8 +10,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= mva@FreeBSD.org
COMMENT= ATK accessibility wrapper for python
+USES= pkgconfig
USE_GNOME= atk
-USE_PKGCONFIG= build
USE_PYTHON= yes
USE_PYDISTUTILS=yes
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index a1c76fd87141..c511d6341120 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -19,11 +19,11 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
+USES= pkgconfig
USE_XZ= yes
USE_AUTOTOOLS= autoconf:env automake:env libtool
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_PKGCONFIG= build
WRKSRC= ${WRKDIR}/${DISTNAME}/client
CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include \
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index 690ad3a9e5d1..b58bd4a916bb 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -18,11 +18,11 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
+USES= pkgconfig
USE_XZ= yes
USE_AUTOTOOLS= autoconf:env automake:env
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_PKGCONFIG= build
USE_GCC= any
CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include \
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 4a03a8aaee60..5cc746526437 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -25,8 +25,8 @@ CONFIGURE_ARGS= ac_cv_prog_FC="f2c"
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
-WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= pkgconfig
+RKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= *
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index 400d23884ae4..3d968d3726a2 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -13,8 +13,7 @@ COMMENT= Daemon that monitors one or more GPSes attached to a host computer
BUILD_DEPENDS= docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl \
xsltproc:${PORTSDIR}/textproc/libxslt
-USES= pathfix
-USE_PKGCONFIG= build
+USES= pathfix pkgconfig
USE_SCONS= yes
USE_RC_SUBR= gpsd
USE_PYTHON= yes