aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--news/p5-Gateway/Makefile6
-rw-r--r--news/p5-Gateway/pkg-plist21
-rw-r--r--security/rid/Makefile10
-rw-r--r--security/rid/pkg-plist6
-rw-r--r--security/sslwrap/Makefile7
-rw-r--r--security/sslwrap/pkg-plist6
6 files changed, 30 insertions, 26 deletions
diff --git a/news/p5-Gateway/Makefile b/news/p5-Gateway/Makefile
index d2e91f66cb20..5ec2eaa75f86 100644
--- a/news/p5-Gateway/Makefile
+++ b/news/p5-Gateway/Makefile
@@ -23,10 +23,10 @@ PERL_CONFIGURE= yes
MAN3= News::Gateway.3
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/Gateway
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${PREFIX} ${EXAMPLESDIR}
.for file in listgate listgate.m4 listgate.readme raccmod raccpost racrmod
- ${INSTALL_DATA} ${WRKSRC}/examples/${file} ${PREFIX}/share/examples/Gateway
+ ${INSTALL_DATA} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
.endfor
.endif
diff --git a/news/p5-Gateway/pkg-plist b/news/p5-Gateway/pkg-plist
index bb8b15d85c12..58625c907cee 100644
--- a/news/p5-Gateway/pkg-plist
+++ b/news/p5-Gateway/pkg-plist
@@ -1,6 +1,5 @@
%%SITE_PERL%%/News/Gateway.pm
%%SITE_PERL%%/News/Gateway.pod
-@dirrmtry %%SITE_PERL%%/News
%%SITE_PERL%%/auto/News/Gateway/anykeyword.al
%%SITE_PERL%%/auto/News/Gateway/bodyheaders.al
%%SITE_PERL%%/auto/News/Gateway/cleanbody.al
@@ -20,14 +19,16 @@
%%SITE_PERL%%/auto/News/Gateway/post.al
%%SITE_PERL%%/auto/News/Gateway/previoushop.al
%%SITE_PERL%%/auto/News/Gateway/whitelist.al
-@dirrmtry %%SITE_PERL%%/auto/News/Gateway
-@dirrmtry %%SITE_PERL%%/auto/News
%%SITE_PERL%%/%%PERL_ARCH%%/auto/News/Gateway/.packlist
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/listgate
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/listgate.m4
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/listgate.readme
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/raccmod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/raccpost
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/racrmod
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/News/Gateway
-share/examples/Gateway/listgate
-share/examples/Gateway/listgate.m4
-share/examples/Gateway/listgate.readme
-share/examples/Gateway/raccmod
-share/examples/Gateway/raccpost
-share/examples/Gateway/racrmod
-@dirrm share/examples/Gateway
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/News
+@dirrm %%SITE_PERL%%/auto/News/Gateway
+@dirrm %%SITE_PERL%%/auto/News
+@dirrm %%SITE_PERL%%/News
diff --git a/security/rid/Makefile b/security/rid/Makefile
index 2aedbb3d6737..f0b9ec7303c5 100644
--- a/security/rid/Makefile
+++ b/security/rid/Makefile
@@ -18,16 +18,18 @@ COMMENT= Configurable remote distributed denial of service tool detector
ALL_TARGET= rid
+DOCS= README
+
pre-configure:
- @${REINPLACE_CMD} -e 's:config.txt:${PREFIX}/etc/rid.conf:g' \
+ @${REINPLACE_CMD} -e 's:config.txt:${PREFIX}/etc/rid.conf.sample:g' \
${WRKSRC}/config.h
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/rid ${PREFIX}/sbin
- @${INSTALL_DATA} ${WRKSRC}/config.txt ${PREFIX}/etc/rid.conf
+ @${INSTALL_DATA} ${WRKSRC}/config.txt ${PREFIX}/etc/rid.conf.sample
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/rid
- @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/rid
+ ${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/security/rid/pkg-plist b/security/rid/pkg-plist
index 14b8c0f2731b..5da7a3f59df0 100644
--- a/security/rid/pkg-plist
+++ b/security/rid/pkg-plist
@@ -1,5 +1,5 @@
@comment $FreeBSD$
sbin/rid
-etc/rid.conf
-share/doc/rid/README
-@dirrm share/doc/rid
+etc/rid.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/security/sslwrap/Makefile b/security/sslwrap/Makefile
index c860ce2e5a1f..ecef0aa4bbed 100644
--- a/security/sslwrap/Makefile
+++ b/security/sslwrap/Makefile
@@ -19,6 +19,8 @@ USE_OPENSSL= YES
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}
+DOCS= README docs.html
+
post-patch:
${REINPLACE_CMD} -e \
's/SSL_OP_NON_EXPORT_FIRST/SSL_OP_CIPHER_SERVER_PREFERENCE/g' \
@@ -30,9 +32,8 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sslwrap ${PREFIX}/bin/sslwrap
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/sslwrap
- ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/docs.html \
- ${PREFIX}/share/doc/sslwrap
+ ${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/security/sslwrap/pkg-plist b/security/sslwrap/pkg-plist
index 5c59136ab67d..a0efe95be4ce 100644
--- a/security/sslwrap/pkg-plist
+++ b/security/sslwrap/pkg-plist
@@ -1,4 +1,4 @@
bin/sslwrap
-share/doc/sslwrap/README
-share/doc/sslwrap/docs.html
-@dirrm share/doc/sslwrap
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/docs.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%