aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--news/rkive/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/news/rkive/Makefile b/news/rkive/Makefile
index b749ccc6a181..b1b55d24f75e 100644
--- a/news/rkive/Makefile
+++ b/news/rkive/Makefile
@@ -19,9 +19,18 @@ NO_CDROM= "Don't make money from it"
MAN1= rkive.1 article.1 ckconfig.1
MAN5= rkive.5
MANCOMPRESSED= yes
+USE_REINPLACE= yes
pre-patch:
@${CP} ${WRKSRC}/Makefile.dst ${WRKSRC}/Makefile
@${CP} ${WRKSRC}/rkive.h.dst ${WRKSRC}/rkive.h
+post-patch:
+ ${REINPLACE_CMD} -e "s,^int fprintf();,," ${WRKSRC}/header.c \
+ ${WRKSRC}/rkive.h ${WRKSRC}/version.c ${WRKSRC}/efopen.c
+ ${REINPLACE_CMD} -e "s,^int sscanf();,," ${WRKSRC}/setup.c \
+ ${WRKSRC}/record_arc.c
+ ${REINPLACE_CMD} -e "s,int mkdir();,," ${WRKSRC}/makedir.c
+ ${REINPLACE_CMD} -e "s,int chmod();,," ${WRKSRC}/rkive.c
+
.include <bsd.port.mk>