aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES9
-rw-r--r--Mk/bsd.qt.mk4
-rw-r--r--UPDATING8
-rw-r--r--devel/qt4-linguist/Makefile4
-rw-r--r--devel/qt4-linguist/files/patch-tools_linguist_linguist.pro10
-rw-r--r--devel/qt4-linguist/pkg-plist6
-rw-r--r--devel/qt4-linguisttools/Makefile47
-rw-r--r--devel/qt4-linguisttools/files/patch-tools_linguist_lrelease_lrelease.pro11
-rw-r--r--devel/qt4-linguisttools/files/patch-tools_linguist_lrelease_main.cpp10
-rw-r--r--devel/qt4-linguisttools/pkg-plist6
-rw-r--r--devel/qt4/Makefile3
-rw-r--r--misc/qt4-l10n/Makefile3
12 files changed, 109 insertions, 12 deletions
diff --git a/CHANGES b/CHANGES
index cadfde64226e..79208598a93a 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,15 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20150224:
+ AUTHOR: makc@FreeBSD.org
+
+ New USE_QT4 component has been introduced to reduce buildtime
+ dependencies for Qt 4 ports that use localization support. Instead
+ of USE_QT4=linguist you should now use USE_QT4=linguisttools_build.
+ Conversion of existing ports may require USE_QT4 adjustment for
+ missing components.
+
20141217:
AFFECTS: users of lang/perl5.*
AUTHOR: mat@FreeBSD.org
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index cc467e404709..fab18781d33e 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -285,7 +285,7 @@ PLIST_SUB+= QT_${dir}DIR="${QT_${dir}DIR_REL}"
Qt_Post_Include= bsd.qt.mk
_USE_QT_ALL= assistant clucene dbus declarative designer gui help \
- imageformats linguist multimedia network opengl pixeltool \
+ imageformats linguist linguisttools multimedia network opengl pixeltool \
qdbusviewer qmake script scripttools sql sql-ibase sql-mysql \
sql-odbc sql-pgsql sql-sqlite2 sql-sqlite3 svg testlib webkit \
xml xmlpatterns
@@ -296,7 +296,7 @@ _USE_QT4_ONLY= accessible assistant-adp assistantclient codecs-cn codecs-jp \
phonon-gst porting qdoc3 qmlviewer qt3support qtconfig \
qtestlib qvfb rcc uic uic3 xmlpatterns-tool
-_USE_QT5_ONLY= buildtools concurrent core graphicaleffects linguisttools \
+_USE_QT5_ONLY= buildtools concurrent core graphicaleffects \
paths printsupport qdbus qdoc qev qml quick \
quickcontrols serialport uitools widgets x11extras
diff --git a/UPDATING b/UPDATING
index 5a5352a74b52..854e1fcf0c0e 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,14 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20150224:
+ AFFECTS: Users of devel/qt4-linguist
+ AUTHOR: makc@FreeBSD.org
+
+ Linguist tools have been moved from qt4-linguist port to new
+ devel/qt4-linguisttools port. Deinstall qt4-linguist before
+ upgrading.
+
+20150224:
AFFECTS: Users of lang/ruby19
lang/ruby19 has reached its end-of-life and has been removed. The
diff --git a/devel/qt4-linguist/Makefile b/devel/qt4-linguist/Makefile
index a18a6c5025fb..8b56ad01a02e 100644
--- a/devel/qt4-linguist/Makefile
+++ b/devel/qt4-linguist/Makefile
@@ -3,7 +3,7 @@
PORTNAME= linguist
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
PKGNAMEPREFIX= qt4-
@@ -11,7 +11,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 4 localization tools
USE_QT4= qmake_build designer_build moc_build rcc_build uic_build \
- assistant_run gui network xml
+ assistant_run gui linguisttools_run network xml
QT_DIST= yes
HAS_CONFIGURE= yes
diff --git a/devel/qt4-linguist/files/patch-tools_linguist_linguist.pro b/devel/qt4-linguist/files/patch-tools_linguist_linguist.pro
new file mode 100644
index 000000000000..384d95cb2a33
--- /dev/null
+++ b/devel/qt4-linguist/files/patch-tools_linguist_linguist.pro
@@ -0,0 +1,10 @@
+--- tools/linguist/linguist.pro.orig 2015-02-23 21:20:45 UTC
++++ tools/linguist/linguist.pro
+@@ -1,6 +1,2 @@
+ TEMPLATE = subdirs
+-SUBDIRS = \
+- lrelease \
+- lupdate \
+- lconvert
+-!no-png:!contains(QT_CONFIG, no-gui):SUBDIRS += linguist
++SUBDIRS = linguist
diff --git a/devel/qt4-linguist/pkg-plist b/devel/qt4-linguist/pkg-plist
index 367690727e6a..1aecb90d39b6 100644
--- a/devel/qt4-linguist/pkg-plist
+++ b/devel/qt4-linguist/pkg-plist
@@ -1,11 +1,5 @@
-%%QT_BINDIR%%/lconvert
-%%DEBUG%%%%QT_BINDIR%%/lconvert.debug
%%QT_BINDIR%%/linguist-qt4
%%DEBUG%%%%QT_BINDIR%%/linguist-qt4.debug
-%%QT_BINDIR%%/lrelease-qt4
-%%DEBUG%%%%QT_BINDIR%%/lrelease-qt4.debug
-%%QT_BINDIR%%/lupdate-qt4
-%%DEBUG%%%%QT_BINDIR%%/lupdate-qt4.debug
share/pixmaps/linguist-qt4.png
%%QT_DATADIR%%/phrasebooks/danish.qph
%%QT_DATADIR%%/phrasebooks/dutch.qph
diff --git a/devel/qt4-linguisttools/Makefile b/devel/qt4-linguisttools/Makefile
new file mode 100644
index 000000000000..6783f9c4b7b0
--- /dev/null
+++ b/devel/qt4-linguisttools/Makefile
@@ -0,0 +1,47 @@
+# $FreeBSD$
+
+PORTNAME= linguisttools
+DISTVERSION= ${QT4_VERSION}
+CATEGORIES= devel
+PKGNAMEPREFIX= qt4-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt 4 localization tools
+
+USE_QT4= qmake_build xml
+QT_DIST= yes
+
+HAS_CONFIGURE= yes
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
+ PATH=${WRKSRC}/bin:$$PATH
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
+ src/activeqt src/dbus src/multimedia src/network src/opengl \
+ src/openvg src/phonon src/qt3support src/s60installs \
+ src/s60main src/script src/scripttools src/sql src/svg \
+ src/testlib src/tools src/winmain src/xmlpatterns \
+ src/3rdparty/clucene src/3rdparty/freetype \
+ src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
+ src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
+BUILD_WRKSRC= ${WRKSRC}/tools/linguist
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+pre-configure:
+ ${REINPLACE_CMD} -E -e 's|^TARGET[[:blank:]]*=[[:blank:]]*([a-z]+)|TARGET=\1${_QT_BINSUFX}|g' \
+ ${BUILD_WRKSRC}/linguist.pro ${BUILD_WRKSRC}/linguist/linguist.pro \
+ ${BUILD_WRKSRC}/lrelease/lrelease.pro ${BUILD_WRKSRC}/lupdate/lupdate.pro
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${QMAKE} ${WRKSRC}/bin/qmake
+
+post-patch:
+ @${REINPLACE_CMD} -e '/SUBDIRS.*linguist/ d' \
+ ${WRKSRC}/tools/linguist/linguist.pro
+
+.include <bsd.port.mk>
diff --git a/devel/qt4-linguisttools/files/patch-tools_linguist_lrelease_lrelease.pro b/devel/qt4-linguisttools/files/patch-tools_linguist_lrelease_lrelease.pro
new file mode 100644
index 000000000000..6ca65ec6e407
--- /dev/null
+++ b/devel/qt4-linguisttools/files/patch-tools_linguist_lrelease_lrelease.pro
@@ -0,0 +1,11 @@
+--- tools/linguist/lrelease/lrelease.pro.orig 2015-02-23 21:14:17 UTC
++++ tools/linguist/lrelease/lrelease.pro
+@@ -2,6 +2,8 @@ TEMPLATE = app
+ TARGET = lrelease
+ DESTDIR = ../../../bin
+
++QT -= gui
++
+ DEFINES += QT_NO_CAST_FROM_ASCII QT_NO_CAST_TO_ASCII
+ SOURCES += main.cpp
+
diff --git a/devel/qt4-linguisttools/files/patch-tools_linguist_lrelease_main.cpp b/devel/qt4-linguisttools/files/patch-tools_linguist_lrelease_main.cpp
new file mode 100644
index 000000000000..42e6ff99f840
--- /dev/null
+++ b/devel/qt4-linguisttools/files/patch-tools_linguist_lrelease_main.cpp
@@ -0,0 +1,10 @@
+--- tools/linguist/lrelease/main.cpp.orig 2014-04-10 18:37:13 UTC
++++ tools/linguist/lrelease/main.cpp
+@@ -47,6 +47,7 @@
+ #ifndef QT_BOOTSTRAPPED
+ #include <QtCore/QCoreApplication>
+ #include <QtCore/QTranslator>
++#include <QtCore/QLibraryInfo>
+ #endif
+ #include <QtCore/QDebug>
+ #include <QtCore/QDir>
diff --git a/devel/qt4-linguisttools/pkg-plist b/devel/qt4-linguisttools/pkg-plist
new file mode 100644
index 000000000000..ad92b0474b19
--- /dev/null
+++ b/devel/qt4-linguisttools/pkg-plist
@@ -0,0 +1,6 @@
+%%QT_BINDIR%%/lconvert
+%%DEBUG%%%%QT_BINDIR%%/lconvert.debug
+%%QT_BINDIR%%/lrelease-qt4
+%%DEBUG%%%%QT_BINDIR%%/lrelease-qt4.debug
+%%QT_BINDIR%%/lupdate-qt4
+%%DEBUG%%%%QT_BINDIR%%/lupdate-qt4.debug
diff --git a/devel/qt4/Makefile b/devel/qt4/Makefile
index cb15940e3519..a676e04d189b 100644
--- a/devel/qt4/Makefile
+++ b/devel/qt4/Makefile
@@ -40,7 +40,8 @@ SQL_PLUGINS_USE=sql-ibase sql-mysql sql-odbc sql-pgsql sql-sqlite2 \
sql-sqlite3
TOOLS_DESC= Install Qt tools (qmake, moc, etc.)
-TOOLS_USE= assistant help-tools linguist makeqpf moc pixeltool \
+TOOLS_USE= assistant help-tools linguist linguisttools makeqpf \
+ moc pixeltool \
porting qdbusviewer qdoc3 qmake qmlviewer qtconfig \
qvfb rcc uic uic3 xmlpatterns-tool
diff --git a/misc/qt4-l10n/Makefile b/misc/qt4-l10n/Makefile
index fedb8cb4df77..082ee0176845 100644
--- a/misc/qt4-l10n/Makefile
+++ b/misc/qt4-l10n/Makefile
@@ -2,13 +2,14 @@
PORTNAME= l10n
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES= misc
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt localized messages
-USE_QT4= linguist_build
+USE_QT4= linguisttools_build
QT_DIST= yes
EXTRACT_AFTER_ARGS+= --include '${DISTNAME}/src/corelib' \