aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/py-omniorb/files/patch-omniidl_be-dir.mk19
-rw-r--r--devel/py-omniorb/files/patch-python-dir.mk19
2 files changed, 38 insertions, 0 deletions
diff --git a/devel/py-omniorb/files/patch-omniidl_be-dir.mk b/devel/py-omniorb/files/patch-omniidl_be-dir.mk
new file mode 100644
index 000000000000..11ff45e961fd
--- /dev/null
+++ b/devel/py-omniorb/files/patch-omniidl_be-dir.mk
@@ -0,0 +1,19 @@
+--- omniidl_be/dir.mk.orig Wed Feb 8 23:42:52 2006
++++ omniidl_be/dir.mk Wed Feb 8 23:43:03 2006
+@@ -13,8 +13,6 @@
+ for file in $^; do \
+ $(ExportFileToDir) \
+ done; \
+- cd $(PYLIBDIR); \
+- $(PYTHON) -c "import compileall; compileall.compile_dir('.')"; \
+ )
+
+ ifdef INSTALLTARGET
+@@ -23,7 +21,5 @@
+ for file in $^; do \
+ $(ExportFileToDir) \
+ done; \
+- cd $(INSTALLPYLIBDIR); \
+- $(PYTHON) -c "import compileall; compileall.compile_dir('.')"; \
+ )
+ endif
diff --git a/devel/py-omniorb/files/patch-python-dir.mk b/devel/py-omniorb/files/patch-python-dir.mk
new file mode 100644
index 000000000000..a5f55572c35b
--- /dev/null
+++ b/devel/py-omniorb/files/patch-python-dir.mk
@@ -0,0 +1,19 @@
+--- python/dir.mk.orig Wed Feb 8 23:42:23 2006
++++ python/dir.mk Wed Feb 8 23:42:44 2006
+@@ -24,7 +24,7 @@
+ $(ExportFileToDir) \
+ done; \
+ cd $(PYLIBDIR); \
+- $(PYTHON) -c "import compileall; compileall.compile_dir('.')"; \
++ $(PYTHON) -c "import compileall; compileall.compile_dir('.',0)"; \
+ )
+
+ ifdef INSTALLTARGET
+@@ -34,6 +34,6 @@
+ $(ExportFileToDir) \
+ done; \
+ cd $(INSTALLPYLIBDIR); \
+- $(PYTHON) -c "import compileall; compileall.compile_dir('.')"; \
++ $(PYTHON) -c "import compileall; compileall.compile_dir('.',0)"; \
+ )
+ endif