aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/iconv.mk2
-rw-r--r--audio/deadbeef/Makefile2
-rw-r--r--audio/deadbeef/files/patch-junklib.c10
-rw-r--r--comms/hidapi/Makefile8
-rw-r--r--comms/hidapi/files/patch-configure.ac15
-rw-r--r--comms/hidapi/files/patch-libusb-hid.c19
-rw-r--r--converters/libiconv/Makefile2
-rw-r--r--converters/libiconv/files/patch-lib-iconv.c11
-rw-r--r--deskutils/fbreader/Makefile12
-rw-r--r--deskutils/ljclive/Makefile10
-rw-r--r--deskutils/owncloudclient/Makefile3
-rw-r--r--deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake13
-rw-r--r--devel/aegis/Makefile2
-rw-r--r--devel/libexplain/Makefile15
-rw-r--r--devel/sdl20/Makefile8
-rw-r--r--emulators/vmw/Makefile7
-rw-r--r--emulators/vmw/files/patch-vmshf.c17
-rw-r--r--irc/scrollz/Makefile8
-rw-r--r--japanese/chasen-base/Makefile7
-rw-r--r--japanese/eb/Makefile13
-rw-r--r--japanese/eb/files/patch-m4-gettext-m441
-rw-r--r--japanese/eblook/Makefile14
-rw-r--r--java/jikes/Makefile3
-rw-r--r--multimedia/transcode/Makefile2
-rw-r--r--net-mgmt/icinga-classicweb/Makefile1
-rw-r--r--net-mgmt/icinga-core/Makefile.common4
-rw-r--r--net-mgmt/netxms/Makefile5
-rw-r--r--net-p2p/transmission-cli/Makefile8
-rw-r--r--net/asterisk11/Makefile2
-rw-r--r--net/c3270/Makefile2
-rw-r--r--net/samba4/Makefile2
-rw-r--r--net/samba41/Makefile2
-rw-r--r--net/samba42/Makefile2
-rw-r--r--www/htmlcxx/Makefile8
-rw-r--r--www/httrack/Makefile3
-rw-r--r--www/xapian-omega/Makefile2
-rw-r--r--x11-wm/jwm/Makefile8
-rw-r--r--x11/mrxvt-devel/Makefile16
-rw-r--r--x11/mrxvt/Makefile25
-rw-r--r--x11/x3270/Makefile2
40 files changed, 237 insertions, 99 deletions
diff --git a/Mk/Uses/iconv.mk b/Mk/Uses/iconv.mk
index a0abf940122b..1e1a0363d58d 100644
--- a/Mk/Uses/iconv.mk
+++ b/Mk/Uses/iconv.mk
@@ -44,7 +44,7 @@ ICONV_LIB_PATH= /usr/lib/libc.so
.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && (${OSVERSION} < 1001514 \
|| (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100069))) \
|| exists(${LOCALBASE}/include/iconv.h)
-BUILD_DEPENDS+= libiconv>=1.14_8:${PORTSDIR}/converters/libiconv
+BUILD_DEPENDS+= libiconv>=1.14_9:${PORTSDIR}/converters/libiconv
CPPFLAGS+= -DLIBICONV_PLUG
CFLAGS+= -DLIBICONV_PLUG
CXXFLAGS+= -DLIBICONV_PLUG
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index 766f2c8f04a1..808c15e64bd7 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -3,7 +3,7 @@
PORTNAME= deadbeef
PORTVERSION= 0.6.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/
diff --git a/audio/deadbeef/files/patch-junklib.c b/audio/deadbeef/files/patch-junklib.c
new file mode 100644
index 000000000000..d2b4e205855b
--- /dev/null
+++ b/audio/deadbeef/files/patch-junklib.c
@@ -0,0 +1,10 @@
+--- junklib.c.orig 2014-07-31 19:03:51 UTC
++++ junklib.c
+@@ -32,7 +32,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #if HAVE_ICONV
+- #define LIBICONV_PLUG
+ #include <iconv.h>
+ #elif HAVE_ICU
+ #warning icu
diff --git a/comms/hidapi/Makefile b/comms/hidapi/Makefile
index b02f8141712e..29012fee3c82 100644
--- a/comms/hidapi/Makefile
+++ b/comms/hidapi/Makefile
@@ -15,10 +15,16 @@ LICENSE_COMB= dual
USE_GITHUB= yes
GH_ACCOUNT= signal11
-USES= autoreconf iconv:wchar_t libtool
+USES= autoreconf gettext-tools iconv:wchar_t libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
PORTDOCS= *
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+
+pre-configure:
+ @${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
+
.include <bsd.port.mk>
diff --git a/comms/hidapi/files/patch-configure.ac b/comms/hidapi/files/patch-configure.ac
index 23416d36d6cc..6137573b4ca6 100644
--- a/comms/hidapi/files/patch-configure.ac
+++ b/comms/hidapi/files/patch-configure.ac
@@ -1,11 +1,18 @@
---- configure.ac.orig
+--- configure.ac.orig 2013-10-06 22:43:37 UTC
+++ configure.ac
-@@ -94,6 +94,8 @@
- LIBS="${LIBS}"
+@@ -89,11 +89,11 @@ case $host in
+ os="freebsd"
+ threads="pthreads"
+
+- CFLAGS="$CFLAGS -I/usr/local/include"
+- LDFLAGS="$LDFLAGS -L/usr/local/lib"
+- LIBS="${LIBS}"
AC_CHECK_LIB([usb], [libusb_init], [LIBS_LIBUSB_PRIVATE="${LIBS_LIBUSB_PRIVATE} -lusb"], [hidapi_lib_error libusb])
- AC_CHECK_LIB([iconv], [iconv_open], [LIBS_LIBUSB_PRIVATE="${LIBS_LIBUSB_PRIVATE} -liconv"], [hidapi_lib_error libiconv])
+- AC_CHECK_LIB([iconv], [iconv_open], [LIBS_LIBUSB_PRIVATE="${LIBS_LIBUSB_PRIVATE} -liconv"], [hidapi_lib_error libiconv])
+ AC_CHECK_DECLS([libusb_get_string_descriptor], [], [], [[#include <libusb.h>]])
+ AC_CHECK_DECLS([libusb_handle_events_completed], [], [], [[#include <libusb.h>]])
++ AM_ICONV
++ LIBS_LIBUSB_PRIVATE="${LIBS_LIBUSB_PRIVATE} ${LTLIBICONV}"
echo libs_priv: $LIBS_LIBUSB_PRIVATE
;;
*-mingw*)
diff --git a/comms/hidapi/files/patch-libusb-hid.c b/comms/hidapi/files/patch-libusb-hid.c
index 96d0cd651584..446a1f34a649 100644
--- a/comms/hidapi/files/patch-libusb-hid.c
+++ b/comms/hidapi/files/patch-libusb-hid.c
@@ -1,4 +1,4 @@
---- libusb/hid.c.orig
+--- libusb/hid.c.orig 2013-10-06 22:43:37 UTC
+++ libusb/hid.c
@@ -25,6 +25,8 @@
@@ -9,7 +9,7 @@
/* C */
#include <stdio.h>
#include <string.h>
-@@ -250,7 +252,7 @@
+@@ -250,7 +252,7 @@ static int get_usage(uint8_t *report_des
}
#endif /* INVASIVE_GET_USAGE */
@@ -18,7 +18,20 @@
/* The FreeBSD version of libusb doesn't have this funciton. In mainline
libusb, it's inlined in libusb.h. This function will bear a striking
resemblence to that one, because there's about one way to code it.
-@@ -757,7 +757,11 @@
+@@ -333,11 +335,7 @@ static wchar_t *get_usb_string(libusb_de
+ size_t inbytes;
+ size_t outbytes;
+ size_t res;
+-#ifdef __FreeBSD__
+- const char *inptr;
+-#else
+- char *inptr;
+-#endif
++ ICONV_CONST char *inptr;
+ char *outptr;
+
+ /* Determine which language to use. */
+@@ -757,7 +755,11 @@ static void *read_thread(void *param)
libusb_cancel_transfer(dev->transfer);
while (!dev->cancelled)
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index ac6c4baf32c4..8851b616999b 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libiconv
PORTVERSION= 1.14
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= converters devel
MASTER_SITES= GNU
diff --git a/converters/libiconv/files/patch-lib-iconv.c b/converters/libiconv/files/patch-lib-iconv.c
deleted file mode 100644
index a5f0e8578d60..000000000000
--- a/converters/libiconv/files/patch-lib-iconv.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/iconv.c.orig
-+++ lib/iconv.c
-@@ -598,7 +598,7 @@
- It wants to define the symbols 'iconv_open', 'iconv', 'iconv_close'. */
- #define strong_alias(name, aliasname) _strong_alias(name, aliasname)
- #define _strong_alias(name, aliasname) \
-- extern __typeof (name) aliasname __attribute__ ((alias (#name)));
-+ extern LIBICONV_DLL_EXPORTED __typeof (name) aliasname __attribute__ ((alias (#name)));
- #undef iconv_open
- #undef iconv
- #undef iconv_close
diff --git a/deskutils/fbreader/Makefile b/deskutils/fbreader/Makefile
index ec47b45fda25..a64b26048566 100644
--- a/deskutils/fbreader/Makefile
+++ b/deskutils/fbreader/Makefile
@@ -4,7 +4,7 @@
PORTNAME= fbreader
PORTVERSION= 0.99.6
DISTVERSIONSUFFIX= -freebsdport
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MAINTAINER= ports@FreeBSD.org
@@ -53,8 +53,7 @@ QT4_LDFLAGS= -L${QT_LIBDIR}
QT4_MAKE_ENV= UI_TYPE=qt4
post-patch:
- @${REINPLACE_CMD} -e '/^CFLAGS/s,-pipe.*$$,${CFLAGS} -DLIBICONV_PLUG,' \
- -e '/^CC/d;/^LD/d;/QTINCLUDE/s,-I.*$$,-I${QT_INCDIR},' \
+ @${REINPLACE_CMD} -e '/^CC/d;/^LD/d;/QTINCLUDE/s,-I.*$$,-I${QT_INCDIR},' \
${WRKSRC}/makefiles/arch/desktop.mk
@${REINPLACE_CMD} -e 's,-O3,,;s,-ldl,${ICONV_LIB},' \
${WRKSRC}/makefiles/config.mk ${WRKSRC}/zlibrary/core/Makefile
@@ -64,4 +63,11 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} \
-e 's,make ,gmake ,'
+pre-configure:
+# This cannot be done in post-patch because build dependencies are installed
+# after patching and they can pull in libiconv which can affect CFLAGS in
+# Mk/Uses/iconv.mk.
+ @${REINPLACE_CMD} 's|^CFLAGS =.*$$|CFLAGS = ${CFLAGS}|' \
+ ${WRKSRC}/makefiles/arch/desktop.mk
+
.include <bsd.port.mk>
diff --git a/deskutils/ljclive/Makefile b/deskutils/ljclive/Makefile
index 7c04943dcea5..43c03c62fad8 100644
--- a/deskutils/ljclive/Makefile
+++ b/deskutils/ljclive/Makefile
@@ -13,12 +13,10 @@ COMMENT= Command line client for posting LiveJournal entries
USES= iconv
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ac_cv_search_iconv=${ICONV_LIB}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFLICTS= *clive-[1-9]*
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} 's/iconv "iconv/"iconv/' ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/owncloudclient/Makefile b/deskutils/owncloudclient/Makefile
index 4034450697df..81092faeee99 100644
--- a/deskutils/owncloudclient/Makefile
+++ b/deskutils/owncloudclient/Makefile
@@ -3,6 +3,7 @@
PORTNAME= owncloudclient
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://download.owncloud.com/desktop/stable/
@@ -14,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libinotify.so:${PORTSDIR}/devel/libinotify \
libqt5keychain.so:${PORTSDIR}/security/qtkeychain-qt5
-USES= cmake:outsource compiler:c++11-lib gmake pkgconfig tar:xz
+USES= cmake:outsource compiler:c++11-lib gmake iconv pkgconfig tar:xz
USE_QT5= buildtools_build concurrent core dbus gui linguist_build network \
qmake_build webkit xml
USE_OPENSSL= yes
diff --git a/deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake b/deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake
new file mode 100644
index 000000000000..637a6c609880
--- /dev/null
+++ b/deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake
@@ -0,0 +1,13 @@
+--- cmake/modules/FindIconv.cmake.orig 2015-07-09 17:51:37 UTC
++++ cmake/modules/FindIconv.cmake
+@@ -36,9 +36,7 @@ find_library(ICONV_LIBRARY
+ )
+
+ if (ICONV_LIBRARY)
+- get_filename_component(_ICONV_NAME ${ICONV_LIBRARY} NAME)
+- get_filename_component(_ICONV_PATH ${ICONV_LIBRARY} PATH)
+- check_library_exists(${_ICONV_NAME} iconv ${_ICONV_PATH} HAVE_ICONV)
++ set(HAVE_ICONV TRUE)
+ else()
+ check_function_exists(iconv HAVE_ICONV)
+ endif()
diff --git a/devel/aegis/Makefile b/devel/aegis/Makefile
index 68f52482ad90..c2825b8a8316 100644
--- a/devel/aegis/Makefile
+++ b/devel/aegis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aegis
PORTVERSION= 4.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF
DISTVERSIONSUFFIX= .D510
diff --git a/devel/libexplain/Makefile b/devel/libexplain/Makefile
index d682059e4362..ff7ffb70ba94 100644
--- a/devel/libexplain/Makefile
+++ b/devel/libexplain/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libexplain
PORTVERSION= 1.3.${PATCHLEVEL}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION:R}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
-USES= bison gettext ghostscript:build gmake libtool:build
+USES= bison gettext ghostscript:build gmake iconv libtool:build
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_linux_kd_h=no
USE_LDCONFIG= yes
@@ -29,6 +29,15 @@ PATCHLEVEL= D012
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv=no
+.else
+CONFIGURE_ARGS+=ac_cv_func_iconv_open=yes ac_cv_func_iconv_close=yes \
+ ac_cv_lib_iconv_iconv=yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|$$(libdir)/pkgconfig|$$(libdir)/../libdata/pkgconfig|g ; \
@@ -37,4 +46,4 @@ post-patch:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libexplain.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/sdl20/Makefile b/devel/sdl20/Makefile
index 1a5b6f85861e..c1aa6e49138c 100644
--- a/devel/sdl20/Makefile
+++ b/devel/sdl20/Makefile
@@ -186,6 +186,12 @@ CONFIGURE_ARGS+= --disable-video-x11 \
--disable-video-x11-vm
.endif
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ARGS+= ac_cv_lib_iconv_iconv_open=yes ac_cv_func_iconv=yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/ CheckInputEvents$$/d' \
-e 's/-liconv/${ICONV_LIB}/g' ${WRKSRC}/configure
@@ -193,4 +199,4 @@ post-patch:
@${REINPLACE_CMD} 's/_m_prefetch/__builtin_prefetch/' \
${WRKSRC}/configure ${WRKSRC}/src/video/SDL_blit_A.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/vmw/Makefile b/emulators/vmw/Makefile
index 37f6e738cf05..456f44b77b99 100644
--- a/emulators/vmw/Makefile
+++ b/emulators/vmw/Makefile
@@ -2,6 +2,7 @@
PORTNAME= vmw
PORTVERSION= 060510
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://sites.google.com/site/chitchatvmback/storage/
@@ -33,7 +34,7 @@ PLIST_FILES+= sbin/${i}
.if !exists(/usr/lib32/libc.so)
IGNORE= please install lib32
.endif
-.if ${OSVERSION} < 1000000
+.if !empty(ICONV_LIB)
IGNORE= needs 32bit libiconv
.endif
CFLAGS+= -m32
@@ -42,9 +43,11 @@ LDFLAGS+= -m32 -B/usr/lib32 -L/usr/lib32
LD= ${CC}
.endif
-.if ${OSVERSION} > 1000000
+.if empty(ICONV_LIB)
FTPLIB=
MAKE_ENV+= FTPLIB="${FTPLIB}"
+.else
+CFLAGS+= -I${LOCALBASE}/include
.endif
do-install:
diff --git a/emulators/vmw/files/patch-vmshf.c b/emulators/vmw/files/patch-vmshf.c
new file mode 100644
index 000000000000..02c81403f8e4
--- /dev/null
+++ b/emulators/vmw/files/patch-vmshf.c
@@ -0,0 +1,17 @@
+--- vmshf.c.orig 2006-05-10 04:36:12 UTC
++++ vmshf.c
+@@ -306,14 +306,7 @@ static uint32_t LocalToUtf8(char *dst, c
+ unix systems with iconv.h
+ -- use iconv() for code conversion
+ */
+-#ifdef __FreeBSD__
+-#include <sys/types.h>
+-#include <sys/iconv.h>
+-typedef size_t iconv_t;
+-#else /* __FreeBSD__ */
+ #include <iconv.h>
+-#endif /* __FreeBSD__ */
+-
+ #include <langinfo.h>
+ #include <locale.h>
+ #include <strings.h>
diff --git a/irc/scrollz/Makefile b/irc/scrollz/Makefile
index d5dd8a2590b6..f120c7ef04d5 100644
--- a/irc/scrollz/Makefile
+++ b/irc/scrollz/Makefile
@@ -31,6 +31,12 @@ GNUTLS_CONFIGURE_ON= --with-ssl
OPENSSL_USE= OPENSSL=yes
OPENSSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ENV+=ac_cv_func_iconv_open=yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
@@ -46,4 +52,4 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${i}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/chasen-base/Makefile b/japanese/chasen-base/Makefile
index e70efcd25ec3..8f87fde0f5cb 100644
--- a/japanese/chasen-base/Makefile
+++ b/japanese/chasen-base/Makefile
@@ -3,7 +3,7 @@
PORTNAME= chasen
PORTVERSION= 2.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= japanese textproc
MASTER_SITES= SOURCEFORGE_JP/chasen-legacy/56305
PKGNAMESUFFIX= -base
@@ -21,6 +21,11 @@ INSTALL_TARGET= install-strip
OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's/iconv ()/libiconv ()/' \
+ -e 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
+
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/chasen/dic
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index f1470c53462f..debbb3f59e2b 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eb
PORTVERSION= 4.4.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/ \
ftp://ftp.sra.co.jp/pub/misc/eb/old/eb-${PORTVERSION:C/^([0-9]+)\.([0-9]+).*/\1.\2/}/
@@ -66,7 +66,9 @@ PORTDOCS= eb-01.html eb-02.html eb-03.html eb-04.html eb-05.html eb-06.html \
USES= autoreconf iconv libtool perl5 tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-pkgdocdir=${DOCSDIR}
+CONFIGURE_ARGS= --with-pkgdocdir=${DOCSDIR} \
+ --with-iconv-includes=${ICONV_PREFIX}/include \
+ --with-iconv-libraries=${ICONV_PREFIX}/lib
CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
OPTIONS_DEFINE= DOCS NLS
@@ -76,11 +78,8 @@ APPENDIXDIR= ${DATADIR}/appendix
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-NLS_CONFIGURE_ON= \
- --with-gettext-includes=${LOCALBASE}/include \
- --with-gettext-libraries=${LOCALBASE}/lib \
- --with-iconv-includes=${ICONV_PREFIX}/include \
- --with-iconv-libraries=${ICONV_PREFIX}/lib
+NLS_CONFIGURE_ON= --with-gettext-includes=${LOCALBASE}/include \
+ --with-gettext-libraries=${LOCALBASE}/lib
NLS_CONFIGURE_OFF= --disable-nls
post-extract:
diff --git a/japanese/eb/files/patch-m4-gettext-m4 b/japanese/eb/files/patch-m4-gettext-m4
index ae2a9bcab759..0d60c52efa5c 100644
--- a/japanese/eb/files/patch-m4-gettext-m4
+++ b/japanese/eb/files/patch-m4-gettext-m4
@@ -1,9 +1,10 @@
---- m4/gettext.m4.orig 2010-01-03 21:26:04.000000000 +0900
-+++ m4/gettext.m4 2014-04-03 10:20:12.000000000 +0900
-@@ -87,13 +87,19 @@
+--- m4/gettext.m4.orig 2010-01-03 12:26:04 UTC
++++ m4/gettext.m4
+@@ -86,14 +86,17 @@ AC_DEFUN([eb_GNU_GETTEXT], [dnl
+ save_CPPFLAGS=$CPPFLAGS
save_LIBS=$LIBS
CPPFLAGS="$save_CPPFLAGS $iconv_includes"
- LIBS="$save_LIBS $iconv_libraries"
+- LIBS="$save_LIBS $iconv_libraries"
- AC_CHECK_LIB(iconv, iconv_open,
- [ICONVLIBS="$iconv_libraries -liconv"; LIBS="$LIBS -liconv"])
- AC_CHECK_FUNCS(iconv_open locale_charset)
@@ -11,23 +12,21 @@
- if test $ac_cv_func_iconv_open != no; then
- ICONVINCS="$iconv_includes"
- fi
-+ initial_LIBS="$LIBS"
-+ AC_SEARCH_LIBS([iconv_open],
-+ [iconv],
-+ [AS_IF([test "$LIBS" = "$initial_LIBS"],
-+ [AC_CHECK_HEADERS([iconv.h])
-+ AC_CHECK_FUNCS([iconv_open])
-+ ICONVLIBS="$iconv_libraries"
-+ ICONVINCS="$iconv_includes"],
-+ [AC_CHECK_LIB([charset], [locale_charset])
-+ AC_CHECK_HEADERS([iconv.h libcharset.h])
-+ AC_CHECK_FUNCS([iconv_open locale_charset])
-+ ICONVLIBS="$iconv_libraries -lcharset -liconv"
-+ ICONVINCS="$iconv_includes"])])
++ AC_CHECK_HEADER([iconv.h],
++ [AC_DEFINE([HAVE_ICONV_H],[1],[Have iconv.h])
++ for l in '' -liconv; do
++ LIBS="$save_LIBS $iconv_libraries $l"
++ AC_LINK_IFELSE(
++ AC_LANG_PROGRAM([#include <iconv.h>],[iconv_open("","")]),
++ [AC_DEFINE([HAVE_ICONV_OPEN],[1],[Have iconv_open(3)])
++ ICONVINCS="$iconv_includes"
++ ICONVLIBS="$iconv_libraries $l"
++ break],[])
++ done],[])
CPPFLAGS=$save_CPPFLAGS
LIBS=$save_LIBS
AC_SUBST(ICONVINCS)
-@@ -113,10 +119,10 @@
+@@ -113,10 +116,10 @@ AC_DEFUN([eb_GNU_GETTEXT], [dnl
save_LIBS=$LIBS
dnl *
@@ -41,7 +40,7 @@
AC_LINK_IFELSE([
#include <stdio.h>
#ifdef ENABLE_NLS
-@@ -143,8 +149,8 @@
+@@ -143,8 +146,8 @@ main()
try_nls=yes, try_nls=no)
if test "$try_nls" = yes; then
@@ -52,7 +51,7 @@
fi
dnl *
-@@ -222,11 +228,11 @@
+@@ -222,11 +225,11 @@ main()
fi
dnl *
@@ -67,7 +66,7 @@
AC_LINK_IFELSE([
#include <stdio.h>
#ifdef ENABLE_NLS
-@@ -253,8 +259,8 @@
+@@ -253,8 +256,8 @@ main()
try_nls=yes, try_nls=no)
if test "$try_nls" = yes; then
diff --git a/japanese/eblook/Makefile b/japanese/eblook/Makefile
index 27d540bff6ff..e22c667a808e 100644
--- a/japanese/eblook/Makefile
+++ b/japanese/eblook/Makefile
@@ -16,10 +16,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libeb.so:${PORTSDIR}/japanese/eb
USES= iconv
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-eb-conf=${PREFIX}/etc/eb.conf
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-eb-conf=${PREFIX}/etc/eb.conf
CPPFLAGS+= -I${ICONV_PREFIX}/include
-LDFLAGS+= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
+LIBS+= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
INFO= eblook
PLIST_FILES= bin/eblook
@@ -27,10 +27,14 @@ PORTDOCS= AUTHORS COPYING ChangeLog NEWS README
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_func_iconv=yes
+.endif
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/java/jikes/Makefile b/java/jikes/Makefile
index 569ec45fd216..36069011e65a 100644
--- a/java/jikes/Makefile
+++ b/java/jikes/Makefile
@@ -12,7 +12,8 @@ COMMENT= Java source to byte-code compiler made available by IBM
PLIST_SUB= PORTVERSION=${PORTVERSION}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= ac_cv_search_libiconv_open=no
+CONFIGURE_ARGS= ac_cv_search_iconv=${ICONV_LIB} \
+ ac_cv_search_libiconv_open=no
USES= iconv gmake tar:bzip2
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 9fbea2e35658..38a44fa337a7 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -3,7 +3,7 @@
PORTNAME= transcode
PORTVERSION= 1.1.7
-PORTREVISION= 23
+PORTREVISION= 24
CATEGORIES= multimedia
MASTER_SITES= http://cdn.bitbucket.org/france/transcode-tcforge/downloads/
diff --git a/net-mgmt/icinga-classicweb/Makefile b/net-mgmt/icinga-classicweb/Makefile
index 19045c5469f9..221839fc257a 100644
--- a/net-mgmt/icinga-classicweb/Makefile
+++ b/net-mgmt/icinga-classicweb/Makefile
@@ -1,6 +1,7 @@
# $FreeBSD$
PORTNAME= icinga-classicweb
+PORTREVISION= 1
DISTNAME= icinga-${PORTVERSION}
MAINTAINER= lme@FreeBSD.org
diff --git a/net-mgmt/icinga-core/Makefile.common b/net-mgmt/icinga-core/Makefile.common
index 7ea6a25d67c1..f3fe41b4ee2b 100644
--- a/net-mgmt/icinga-core/Makefile.common
+++ b/net-mgmt/icinga-core/Makefile.common
@@ -9,7 +9,7 @@ MAINTAINER= lme@FreeBSD.org
LICENSE= GPLv2
LIB_DEPENDS+= libltdl.so:${PORTSDIR}/devel/libltdl
-USES= cpe gmake iconv perl5
+USES= cpe gmake perl5
GNU_CONFIGURE= yes
@@ -47,6 +47,7 @@ CONFIGURE_ARGS= --with-command-user=${ICINGAUSER} \
--with-httpd-conf=${EXAMPLESDIR}/apache2 \
--enable-event-broker \
--enable-nanosleep \
+ ac_cv_lib_iconv_main=no
CONFIGURE_ENV= PERL=${PERL} \
HOME=${WRKDIR} # prevent creation of .rnd file
@@ -67,4 +68,3 @@ SUB_FILES= pkg-message
# XXX: Don't remove PREFIX from SUB_LIST here.
SUB_LIST= PREFIX=${PREFIX} \
${PLIST_SUB}
-
diff --git a/net-mgmt/netxms/Makefile b/net-mgmt/netxms/Makefile
index a4b30f67412d..63f780ad9416 100644
--- a/net-mgmt/netxms/Makefile
+++ b/net-mgmt/netxms/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netxms
PORTVERSION= 1.2.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://www.netxms.org/download/ \
http://www.netxms.org/download/archive/
@@ -78,6 +78,9 @@ USE_RC_SUBR+= nxagentd
USE_RC_SUBR+= nxagentd
.endif
+post-patch:
+ @${REINPLACE_CMD} 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
+
post-install:
.if ${PORT_OPTIONS:MSERVER}
.if !exists(${STAGEDIR}${PREFIX}/etc/netxmsd.conf.sample)
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index fad3e6555cc9..a7d32ae2d325 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -73,6 +73,12 @@ EXTRA_PATCHES= ${PATCHDIR}/disable-web
DOCS= AUTHORS NEWS README
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_func_iconv_open=yes
+.endif
+
general-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
@@ -109,4 +115,4 @@ general-install:
post-install: general-install
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/asterisk11/Makefile b/net/asterisk11/Makefile
index a3203d19e6f0..71884abae31f 100644
--- a/net/asterisk11/Makefile
+++ b/net/asterisk11/Makefile
@@ -2,6 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 11.20.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/%SUBDIR%/:main,g729
MASTER_SITE_SUBDIR= asterisk/:main \
@@ -221,6 +222,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
+ @${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
.if ${PORT_OPTIONS:MSYSINFO}
@${REINPLACE_CMD} -e 's/%%LIBSYSINFO%%/-lsysinfo/' ${WRKSRC}/main/Makefile
.else
diff --git a/net/c3270/Makefile b/net/c3270/Makefile
index 2a670bf22f43..cf5263dcc686 100644
--- a/net/c3270/Makefile
+++ b/net/c3270/Makefile
@@ -15,7 +15,7 @@ COMMENT= Full-screen curses-based remote login to IBM mainframes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([0-9]\.[0-9])(\..*)/\1/}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= ac_cv_search_libiconv=no
+CONFIGURE_ARGS= ac_cv_search_libiconv=${ICONV_LIB}
USES= iconv readline gmake
USE_OPENSSL= yes
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index 6905177e206b..5826741fdb57 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= ${SAMBA4_BASENAME}4
PORTVERSION?= ${SAMBA4_VERSION}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net
MASTER_SITES= SAMBA/samba/stable SAMBA/samba/rc
DISTNAME= ${SAMBA4_DISTNAME}
diff --git a/net/samba41/Makefile b/net/samba41/Makefile
index 1806e0eb3627..1cb652a499cf 100644
--- a/net/samba41/Makefile
+++ b/net/samba41/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= ${SAMBA4_BASENAME}41
PORTVERSION?= ${SAMBA4_VERSION}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net
MASTER_SITES= SAMBA/samba/stable SAMBA/samba/rc
DISTNAME= ${SAMBA4_DISTNAME}
diff --git a/net/samba42/Makefile b/net/samba42/Makefile
index c6822460ce40..3c3d8a545e0e 100644
--- a/net/samba42/Makefile
+++ b/net/samba42/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= ${SAMBA4_BASENAME}42
PORTVERSION?= ${SAMBA4_VERSION}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net
MASTER_SITES= SAMBA/samba/stable SAMBA/samba/rc
DISTNAME= ${SAMBA4_DISTNAME}
diff --git a/www/htmlcxx/Makefile b/www/htmlcxx/Makefile
index adbec6a39fe5..efc7acd16792 100644
--- a/www/htmlcxx/Makefile
+++ b/www/htmlcxx/Makefile
@@ -23,7 +23,13 @@ MAKE_JOBS_UNSAFE=yes
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=yes
+.endif
+
post-patch:
@${REINPLACE_CMD} 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/httrack/Makefile b/www/httrack/Makefile
index 0cc17e526a3f..6a1e5c7daad1 100644
--- a/www/httrack/Makefile
+++ b/www/httrack/Makefile
@@ -39,10 +39,11 @@ ICONS_VARS= INSTALLS_ICONS=yes
.if empty(ICONV_LIB)
CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv=no
+.else
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv=yes
.endif
post-patch:
- @${REINPLACE_CMD} -e '/DEFAULT_CFLAGS=/ s|-O -g3 ||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/ install-data-hook/d' ${WRKSRC}/html/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' ${WRKSRC}/html/server/div/WebHTTrack*
diff --git a/www/xapian-omega/Makefile b/www/xapian-omega/Makefile
index 605684b17e25..edc198ada933 100644
--- a/www/xapian-omega/Makefile
+++ b/www/xapian-omega/Makefile
@@ -37,8 +37,8 @@ PORTEXAMPLES= omega.conf
SHEBANG_FILES= dbi2omega htdig2omega mbox2omega
+ICONV_CONFIGURE_ON= ac_cv_search_iconv=${ICONV_LIB}
ICONV_CONFIGURE_WITH= iconv
-ICONV_LDFLAGS= ${ICONV_LIB}
ICONV_USES= iconv
post-patch:
diff --git a/x11-wm/jwm/Makefile b/x11-wm/jwm/Makefile
index a8f03de5bf5b..5a9ebaa1893f 100644
--- a/x11-wm/jwm/Makefile
+++ b/x11-wm/jwm/Makefile
@@ -67,6 +67,12 @@ IGNORE= the XMU support requires XEXT
IGNORE= the XPM support requires XEXT
.endif
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv=yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/example.jwmrc
@@ -77,4 +83,4 @@ post-patch:
'/EXE/s|install|@INSTALL_PROGRAM@| ; \
/strip/s|^|#|' ${WRKSRC}/src/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/mrxvt-devel/Makefile b/x11/mrxvt-devel/Makefile
index 6f66cbc5a854..fe7418742b17 100644
--- a/x11/mrxvt-devel/Makefile
+++ b/x11/mrxvt-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mrxvt-devel
PORTVERSION= 0.5.4
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= x11
MASTER_SITES= SF/materm/mrxvt%20source/${PORTVERSION}
DISTNAME= mrxvt-${PORTVERSION}
@@ -54,6 +54,10 @@ USE_XORG+= xft
CONFIGURE_ARGS+= --enable-xft
.endif
+.if ${PORT_OPTIONS:MXFT} && ${PORT_OPTIONS:MJAPANESE}
+USES+= iconv
+.endif
+
.if ${PORT_OPTIONS:M24BITS}
CONFIGURE_ARGS+= --enable-24bits
.endif
@@ -120,6 +124,14 @@ CONFIGURE_ARGS+= --with-atab-extra=${EXTRA_ATAB_HEIGHT:M[0-9]*}
CONFIGURE_ARGS+= --with-tab-radius=${TAB_RADIUS:M[0-9]*}
.endif
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=no
+.else
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=yes
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/mrxvt ${STAGEDIR}${PREFIX}/bin
@for pixmap in ${WRKSRC}/share/pixmaps/* ; \
@@ -137,4 +149,4 @@ do-install:
${CP} ${WRKSRC}/doc/*.bz2 ${STAGEDIR}${DOCSDIR}
${BZIP2_CMD} -d ${STAGEDIR}${DOCSDIR}/*.bz2
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/mrxvt/Makefile b/x11/mrxvt/Makefile
index 189bbb58be58..dd6d987d5d6f 100644
--- a/x11/mrxvt/Makefile
+++ b/x11/mrxvt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mrxvt
PORTVERSION= 0.4.2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= x11
MASTER_SITES= SF/materm/${PORTNAME}%20source/${PORTVERSION}
@@ -16,6 +16,8 @@ CONFLICTS= mrxvt-0.5.*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-lastlog --disable-wtmp
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
USES= jpeg tar:tgz
USE_XORG= x11
@@ -25,9 +27,6 @@ JAPANESE_CONFIGURE_ON= --enable-xim --enable-cjk --with-encoding=eucj
XFT_LIB_DEPENDS= libXft.so:${PORTSDIR}/x11-fonts/libXft
XFT_CONFIGURE_ENABLE= xft
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-
PORTDOCS= TIPS \
README.greek \
README.menu \
@@ -37,11 +36,21 @@ PORTDOCS= TIPS \
mrxvt.vbs \
mrxvtset.pl
-post-patch-DOCS-off:
- @${REINPLACE_CMD} -e '/^\(install-data-am:\).*/ \
- s/install-docDATA //' ${WRKSRC}/doc/Makefile.in
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MXFT} && ${PORT_OPTIONS:MJAPANESE}
+USES+= iconv
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=no
+.else
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=yes
+.endif
post-install:
${CHMOD} 4511 ${STAGEDIR}${PREFIX}/bin/mrxvt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/x3270/Makefile b/x11/x3270/Makefile
index 07355b23161d..0c95b27e9781 100644
--- a/x11/x3270/Makefile
+++ b/x11/x3270/Makefile
@@ -23,7 +23,7 @@ USE_XORG= ice sm x11 xaw xext xmu xt
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fontdir=${FONTSDIR} \
--disable-dbcs \
- ac_cv_search_libiconv=no
+ ac_cv_search_libiconv=${ICONV_LIB}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
.if defined(WITHOUT_OPENSSL)