aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/erlang/Makefile2
-rw-r--r--lang/erlang/files/patch-lib_compiler_src_beam__utils.erl16
-rw-r--r--lang/erlang/files/patch-lib_inets_src_http__client_http.erl14
-rw-r--r--lang/erlang14/Makefile2
-rw-r--r--lang/erlang14/files/patch-lib_compiler_src_beam__utils.erl16
-rw-r--r--lang/erlang14/files/patch-lib_inets_src_http__client_http.erl14
6 files changed, 62 insertions, 2 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index f484b54277c9..ef61b99bcfa0 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r13b01
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/ \
diff --git a/lang/erlang/files/patch-lib_compiler_src_beam__utils.erl b/lang/erlang/files/patch-lib_compiler_src_beam__utils.erl
new file mode 100644
index 000000000000..fec112220d2f
--- /dev/null
+++ b/lang/erlang/files/patch-lib_compiler_src_beam__utils.erl
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- lib/compiler/src/beam_utils.erl.orig
++++ lib/compiler/src/beam_utils.erl
+@@ -650,8 +650,8 @@
+ Regs2 = x_live([Src1,Src2], Regs1),
+ Regs = live_join_label(Fail, D, Regs2),
+ live_opt(Is, Regs, D, [I|Acc]);
+-live_opt([{bs_append,Fail,Src1,_,_,_,Src2,_,Dst}=I|Is], Regs0, D, Acc) ->
+- Regs1 = x_live([Src1,Src2], x_dead([Dst], Regs0)),
++live_opt([{bs_append,Fail,Src1,_,Live,_,Src2,_,Dst}=I|Is], _Regs0, D, Acc) ->
++ Regs1 = x_dead([Dst], x_live([Src1,Src2], live_call(Live))),
+ Regs = live_join_label(Fail, D, Regs1),
+ live_opt(Is, Regs, D, [I|Acc]);
+ live_opt([{bs_private_append,Fail,Src1,_,Src2,_,Dst}=I|Is], Regs0, D, Acc) ->
diff --git a/lang/erlang/files/patch-lib_inets_src_http__client_http.erl b/lang/erlang/files/patch-lib_inets_src_http__client_http.erl
new file mode 100644
index 000000000000..2b2b435bb648
--- /dev/null
+++ b/lang/erlang/files/patch-lib_inets_src_http__client_http.erl
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- lib/inets/src/http_client/http.erl.orig
++++ lib/inets/src/http_client/http.erl
+@@ -293,6 +293,8 @@
+ case {Sync, Stream} of
+ {true, self} ->
+ {error, streaming_error};
++ {true, {self,once}} ->
++ {error, streaming_error};
+ _ ->
+ RecordHeaders = header_record(NewHeaders, #http_request_h{},
+ Host, Version),
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index f484b54277c9..ef61b99bcfa0 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r13b01
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/ \
diff --git a/lang/erlang14/files/patch-lib_compiler_src_beam__utils.erl b/lang/erlang14/files/patch-lib_compiler_src_beam__utils.erl
new file mode 100644
index 000000000000..fec112220d2f
--- /dev/null
+++ b/lang/erlang14/files/patch-lib_compiler_src_beam__utils.erl
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- lib/compiler/src/beam_utils.erl.orig
++++ lib/compiler/src/beam_utils.erl
+@@ -650,8 +650,8 @@
+ Regs2 = x_live([Src1,Src2], Regs1),
+ Regs = live_join_label(Fail, D, Regs2),
+ live_opt(Is, Regs, D, [I|Acc]);
+-live_opt([{bs_append,Fail,Src1,_,_,_,Src2,_,Dst}=I|Is], Regs0, D, Acc) ->
+- Regs1 = x_live([Src1,Src2], x_dead([Dst], Regs0)),
++live_opt([{bs_append,Fail,Src1,_,Live,_,Src2,_,Dst}=I|Is], _Regs0, D, Acc) ->
++ Regs1 = x_dead([Dst], x_live([Src1,Src2], live_call(Live))),
+ Regs = live_join_label(Fail, D, Regs1),
+ live_opt(Is, Regs, D, [I|Acc]);
+ live_opt([{bs_private_append,Fail,Src1,_,Src2,_,Dst}=I|Is], Regs0, D, Acc) ->
diff --git a/lang/erlang14/files/patch-lib_inets_src_http__client_http.erl b/lang/erlang14/files/patch-lib_inets_src_http__client_http.erl
new file mode 100644
index 000000000000..2b2b435bb648
--- /dev/null
+++ b/lang/erlang14/files/patch-lib_inets_src_http__client_http.erl
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- lib/inets/src/http_client/http.erl.orig
++++ lib/inets/src/http_client/http.erl
+@@ -293,6 +293,8 @@
+ case {Sync, Stream} of
+ {true, self} ->
+ {error, streaming_error};
++ {true, {self,once}} ->
++ {error, streaming_error};
+ _ ->
+ RecordHeaders = header_record(NewHeaders, #http_request_h{},
+ Host, Version),