aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--benchmarks/fio/Makefile2
-rw-r--r--devel/ipython/Makefile2
-rw-r--r--devel/libnfc/Makefile2
-rw-r--r--devel/py-gdata/Makefile2
-rw-r--r--devel/py-yaml/Makefile2
-rw-r--r--graphics/evas-core/Makefile2
-rw-r--r--graphics/gegl/Makefile3
-rw-r--r--graphics/graphviz/Makefile3
-rw-r--r--java/classpath/Makefile2
-rw-r--r--lang/ocaml/Makefile2
-rw-r--r--lang/tinypy/Makefile2
-rw-r--r--math/vtk6/Makefile2
-rw-r--r--news/cnews/Makefile2
13 files changed, 15 insertions, 13 deletions
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index 41846b0e47e5..4dacc2125911 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
USES= gmake tar:bzip2
-OPTIONS_DEFINE= GNUPLOT
+OPTIONS_DEFINE= GNUPLOT EXAMPLES
GNUPLOT_DESC= Support for plotting graphs
.include <bsd.port.options.mk>
diff --git a/devel/ipython/Makefile b/devel/ipython/Makefile
index ce9bdfd0771b..25f2478df1f3 100644
--- a/devel/ipython/Makefile
+++ b/devel/ipython/Makefile
@@ -20,7 +20,7 @@ USE_PYDISTUTILS=yes
USE_GCC= yes # To be removed - Needed as a work-around for numpy, see PR ports/188114
PYDISTUTILS_AUTOPLIST=yes
-OPTIONS_DEFINE= X11 HTML_NOTEBOOK ZMQ
+OPTIONS_DEFINE= X11 HTML_NOTEBOOK ZMQ EXAMPLES
OPTIONS_DEFAULT=X11 ZMQ
.if defined(PACKAGE_BUILDING)
diff --git a/devel/libnfc/Makefile b/devel/libnfc/Makefile
index 552ca5d13856..9dcb09453d4f 100644
--- a/devel/libnfc/Makefile
+++ b/devel/libnfc/Makefile
@@ -13,7 +13,7 @@ COMMENT= Near Field Communication (NFC) library
#OPTIONS_DEFINE= ACR122_PCSC ACR122_USB ACR122S ARYGON PN532_I2C PN532_SPI PN532_UART PN53X_USB
#OPTIONS_DEFAULT=ACR122_USB ACR122S ARYGON PN532_I2C PN532_SPI PN532_UART PN53X_USB
-OPTIONS_DEFINE= ACR122_PCSC ACR122_USB ACR122S ARYGON PN532_UART PN53X_USB
+OPTIONS_DEFINE= ACR122_PCSC ACR122_USB ACR122S ARYGON PN532_UART PN53X_USB EXAMPLES
OPTIONS_DEFAULT=ACR122_USB ACR122S ARYGON PN532_UART PN53X_USB
ACR122_PCSC_DESC=ACR122 driver (PC/SC)
ACR122_USB_DESC=ACR122 driver (USB)
diff --git a/devel/py-gdata/Makefile b/devel/py-gdata/Makefile
index edb83b6e3fab..1c790da27a91 100644
--- a/devel/py-gdata/Makefile
+++ b/devel/py-gdata/Makefile
@@ -16,7 +16,7 @@ PROJECTHOST= gdata-python-client
USE_PYTHON= 2
USE_PYDISTUTILS= yes
-OPTIONS_DEFINE= GMPY M2CRYPTO PYCRYPTO
+OPTIONS_DEFINE= GMPY M2CRYPTO PYCRYPTO EXAMPLES
# optional modules (see src/gdata/tlslite/utils/cryptomath.py)
GMPY_DESC= Multiprecision arithmetic
diff --git a/devel/py-yaml/Makefile b/devel/py-yaml/Makefile
index 3ee30580503d..9907f506abca 100644
--- a/devel/py-yaml/Makefile
+++ b/devel/py-yaml/Makefile
@@ -13,7 +13,7 @@ COMMENT= Python YAML parser
LICENSE= MIT
-OPTIONS_DEFINE= LIBYAML
+OPTIONS_DEFINE= LIBYAML EXAMPLES
LIBYAML_DESC= Use textproc/libyaml for faster parsing
USE_PYTHON= yes
diff --git a/graphics/evas-core/Makefile b/graphics/evas-core/Makefile
index 2870f07cd83d..44b1ce5002f7 100644
--- a/graphics/evas-core/Makefile
+++ b/graphics/evas-core/Makefile
@@ -29,7 +29,7 @@ EXAMPLESDIR= ${PREFIX}/share/examples/evas
.include "Makefile.inc"
-OPTIONS_DEFINE= EET FONTCONFIG FRIBIDI
+OPTIONS_DEFINE= EET FONTCONFIG FRIBIDI EXAMPLES
OPTIONS_DEFAULT=EET FONTCONFIG FRIBIDI
EET_DESC= EET font loader
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index b009a60f9a14..e89ed16b6c34 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -13,7 +13,8 @@ COMMENT= Graph based image processing framework
LIB_DEPENDS= libbabl-0.1.so:${PORTSDIR}/x11/babl
OPTIONS_DEFINE= CAIRO ENSCRIPT EXIV2 FFMPEG PIXBUF GRAPHVIZ JASPER JPEG \
- LUA OPENEXR OPENRAW SIMD PANGO PNG LIBRSVG2 SDL SPIRO V4L DOCS
+ LUA OPENEXR OPENRAW SIMD PANGO PNG LIBRSVG2 SDL SPIRO V4L \
+ DOCS EXAMPLES
OPTIONS_DEFAULT=CAIRO ENSCRIPT EXIV2 PIXBUF GRAPHVIZ JASPER JPEG LUA \
OPENEXR OPENRAW PANGO PNG LIBRSVG2 SDL SPIRO V4L
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index dfccea20d0dc..33964d96cb94 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -52,7 +52,8 @@ USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
OPTIONS_DEFINE= XPM DIGCOLA IPSEPCOLA ICONV NLS PANGOCAIRO LIBRSVG2 POPPLER \
ANN GTS GTK2 GDK GDK_PIXBUF GNOMEUI SMYRNA GVEDIT MING DEVIL \
- GHOSTSCRIPT PERL PHP PYTHON RUBY LUA TCL TK GUILE NVTHREADS DOCS
+ GHOSTSCRIPT PERL PHP PYTHON RUBY LUA TCL TK GUILE NVTHREADS \
+ DOCS EXAMPLES
OPTIONS_DEFAULT= XPM DIGCOLA IPSEPCOLA ICONV NLS PANGOCAIRO
NO_OPTIONS_SORT=yes
OPTIONS_SUB= yes
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index 6fb153b5bbbe..ed1da56cd2e9 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -36,7 +36,7 @@ INFO= cp-hacking cp-tools cp-vmintegration
CONFLICTS= sablevm-classpath-1.13 sablevm-classpath-1.13_[1-9]
-OPTIONS_DEFINE= CAIRO ECJ GCONF GJDOC GMP GTK2 QT4
+OPTIONS_DEFINE= CAIRO ECJ GCONF GJDOC GMP GTK2 QT4 EXAMPLES
OPTIONS_DEFAULT=GMP GJDOC GTK2
CAIRO_DESC= Use Gtk+ Cairo based Graphics2D
ECJ_DESC= Embed ECJ as com.sun.tools.javac
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 1475f4157ef7..f9a3aec75c0f 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ARGS= -verbose -prefix "${PREFIX}" \
-aspp "${CC} -c" \
-partialld "${LD} -r"
-OPTIONS_DEFINE= X11 TK THREADS DOCS
+OPTIONS_DEFINE= X11 TK THREADS DOCS EXAMPLES
OPTIONS_DEFAULT=X11 TK THREADS
TK_DESC= LablTk library (requires X11 support)
CMP_LIB_DESC= Install compiler libraries
diff --git a/lang/tinypy/Makefile b/lang/tinypy/Makefile
index 3c461b12ba11..bc44ed8d0e08 100644
--- a/lang/tinypy/Makefile
+++ b/lang/tinypy/Makefile
@@ -21,7 +21,7 @@ PYDISTUTILS_NOEGGINFO= yes
PLIST_FILES= bin/tinypy
-OPTIONS_DEFINE= PYGAME
+OPTIONS_DEFINE= PYGAME EXAMPLES
PYGAME_DESC= PyGame support (requires SDL)
.include <bsd.port.options.mk>
diff --git a/math/vtk6/Makefile b/math/vtk6/Makefile
index 6c75de01cbf0..738018b16037 100644
--- a/math/vtk6/Makefile
+++ b/math/vtk6/Makefile
@@ -45,7 +45,7 @@ VTK_WRAPS= JAVA TCLTK # PYTHON
OPTIONS_GROUP= Groups Wrapping
OPTIONS_GROUP_Groups=${VTK_GROUPS}
OPTIONS_GROUP_Wrapping=${VTK_WRAPS}
-OPTIONS_DEFINE= DESIGNER DOCS OSMESA
+OPTIONS_DEFINE= DESIGNER DOCS OSMESA EXAMPLES
OPTIONS_RADIO= Qt
OPTIONS_RADIO_Qt= QT4 QT5
Qt_DESC= Qt GUI support
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index 03e9bf55a470..84b26e43257e 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -67,7 +67,7 @@ PLIST_SUB+= NEWSARTS=${NEWSARTS:S=^${VARBASE}/==}
PLIST_SUB+= NEWSOV=${NEWSOV:S=^${VARBASE}/==}
PLIST_SUB+= NEWSCTL_FILES="${NEWSCTL_FILES}"
-OPTIONS_DEFINE= SENDMAIL
+OPTIONS_DEFINE= SENDMAIL EXAMPLES
OPTIONS_DEFAULT=PGPGPG
OPTIONS_SINGLE= VERIFY
OPTIONS_SINGLE_VERIFY= PGP2 PGPIN PGPGPG