aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/paman/Makefile33
-rw-r--r--audio/paman/distinfo2
-rw-r--r--audio/paman/pkg-descr4
4 files changed, 40 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 0106c20645d8..fe5d4c990eb1 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -343,6 +343,7 @@
SUBDIR += p5-Xmms
SUBDIR += p5-libvorbis
SUBDIR += p5-tagged
+ SUBDIR += paman
SUBDIR += pd
SUBDIR += phatbeat
SUBDIR += pimp3
diff --git a/audio/paman/Makefile b/audio/paman/Makefile
new file mode 100644
index 000000000000..2e7c6985aa61
--- /dev/null
+++ b/audio/paman/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: paman
+# Date created: 2005-03-27
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= paman
+PORTVERSION= 0.6
+CATEGORIES= audio
+MASTER_SITES= http://0pointer.de/lennart/projects/paman/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Gtk+ frontend for the polypaudio sound server
+
+LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
+ polyp-0.7.0:${PORTSDIR}/audio/polypaudio
+
+USE_GCC= 3.4
+GNU_CONFIGURE= yes
+USE_GNOME= gnomeprefix gnomehack
+USE_X_PREFIX= yes
+CONFIGURE_ARGS= --disable-lynx
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
+ LDFLAGS="${PTHREAD_LIBS}"
+
+DATADIR= share/gnome/${PORTNAME}
+
+PLIST_FILES= bin/paman \
+ %%DATADIR%%/paman.glade
+PLIST_DIRS= %%DATADIR%%
+
+.include <bsd.port.mk>
diff --git a/audio/paman/distinfo b/audio/paman/distinfo
new file mode 100644
index 000000000000..e827874eee35
--- /dev/null
+++ b/audio/paman/distinfo
@@ -0,0 +1,2 @@
+MD5 (paman-0.6.tar.gz) = ea46666ff75b49aa6153946a84be9565
+SIZE (paman-0.6.tar.gz) = 106687
diff --git a/audio/paman/pkg-descr b/audio/paman/pkg-descr
new file mode 100644
index 000000000000..e1e15fb74ca6
--- /dev/null
+++ b/audio/paman/pkg-descr
@@ -0,0 +1,4 @@
+Polypaudio Manager (paman) is a simple Gtk+ frontend for the polypaudio
+sound server.
+
+WWW: http://0pointer.de/lennart/projects/paman/
nsertions'>+24 * Reset vsevolod as maintainer due to unreponsiveness. We hope to see himlinimon2006-04-151-1/+1 * Fix plistvs2006-04-142-0/+10 * - Update to 1.9pav2006-04-095-61/+139 * - Define FFLAGS according to WITH_OPTIMIZED_FLAGS;thierry2006-04-054-13/+26 * - Update to version 1.2.1markus2006-04-036-10/+10 * Upgrade OpenFOAM to 1.3.thierry2006-04-0214-709/+751 * Chase another silent update: minor fixes in Bourne shell variables and helpthierry2006-03-302-5/+11 * - Update to version 1.2.0markus2006-03-2820-690/+1048 * Shorten long patches names, in order to fix release CD in Joliet format.thierry2006-03-2714-0/+0 * - Fix build on 4.xmnag2006-03-222-12/+8 * - Assign maintainership over to Diane Brucetmclaugh2006-03-212-4/+2 * - Chase gchemutils updatepav2006-03-211-3/+2 * - Update to 0.6.0pav2006-03-216-126/+212 * A program for doing calculation on Smith Chart, similar in functionality tothierry2006-03-205-0/+54 * Update to 1.2.1.thierry2006-03-192-5/+5 * - Update to 3.6.1garga2006-03-164-10/+8 * Upgrade to 1.2.0.thierry2006-03-152-5/+5 * Add fasthenry , a multipole-accelerated inductance analysis program.garga2006-03-1510-0/+170 * Add fastcap , a three-dimensional capacitance extraction program.garga2006-03-155-0/+113 * Bump PORTREVISION on glib12/gtk12 consumer ports to ease the upgrade path.ade2006-03-072-2/+2 * Purge the last vestiges of the (really) old autotools world order.ade2006-02-261-1/+0 * Fix `make extract' on FreeBSD-5.4 by using archivers/bsdtar.thierry2006-02-261-0/+5 * Fix MASTER_SITES and make fetchable again.tmclaugh2006-02-262-2/+4 * Chase another silent update.thierry2006-02-252-5/+5 * Conversion to a single libtool environment.ade2006-02-2333-54/+282 * Update to 1.2.6. [1]lawrance2006-02-174-8/+31 * Chase another silent update. Since this seems usual, define a DIST_SUBDIR.thierry2006-02-172-4/+5 * Correct the author information in pkg-descr for science/buddy as requested byehaupt2006-02-151-1/+2 * Change `NOT_FOR_ARCHS' with `if ARCH then BROKEN'vd2006-02-131-3/+6 * MINC (Medical Imaging NetCDF) is a medical imaging data format and anthierry2006-02-1211-0/+335 * Re-add patch-Makefile to respect CFLAGS / FFLAGS / CC & co.thierry2006-02-121-0/+26 * Chase a silent update and make fetchable again.thierry2006-02-125-108/+5 * Remove empty patch file.anholt2006-02-121-0/+0 * Mark NOT_FOR_ARCHS=sparc64, maintainer did not fix the build for 7 daysvd2006-02-091-0/+3 * Remove expired port science/glensvd2006-02-087-115/+0 * - The official download site is down, add a mirror.thierry2006-02-042-3/+13 * Fix another silent update.thierry2006-01-311-3/+3 * Repocopy math/netcdf to science/netcdf, along with cdf, hdf and hdf5.thierry2006-01-316-5/+6 * Changes to the port:vd2006-01-302-20/+20 * Oops... I mixed 3.0 and 3.1 pkg-plist and forgot to take maintainership.thierry2006-01-302-1/+6 * Common Data Format (CDF) is a conceptual data abstraction for storingthierry2006-01-29