aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/mod_auth_mysql/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/www/mod_auth_mysql/Makefile b/www/mod_auth_mysql/Makefile
index a84b84bf3d92..5abf4e954c07 100644
--- a/www/mod_auth_mysql/Makefile
+++ b/www/mod_auth_mysql/Makefile
@@ -22,6 +22,9 @@ APXS= ${LOCALBASE}/sbin/apxs
AP_PORT?= apache13
.if exists(${APXS})
+APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || echo no
+.endif
+.if exists(${APXS}) && ${APXS_WORKS} != no
AP_TARGET!= ${APXS} -q TARGET
AP_SYSCONF!= ${APXS} -q SYSCONFDIR
AP_INCLUDE!= ${APXS} -q INCLUDEDIR