aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/pmf/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/pmf/Makefile b/net/pmf/Makefile
index 108883038576..a9e240645529 100644
--- a/net/pmf/Makefile
+++ b/net/pmf/Makefile
@@ -20,6 +20,12 @@ SUB_FILES= pmfrc.default
OPTIONS_DEFINE= DOCS EXAMPLES
+.include <bsd.port.pre.mk>
+
+.if !exists(/usr/lib/libreadline.so)
+BROKEN= Does not build with modern readline from ports
+.endif
+
post-build:
@${LN} -sf .pmfrc ${WRKSRC}/examples/dot.pmfrc
@@ -34,4 +40,4 @@ do-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>