aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-IO-Socket-Multicast/Makefile25
-rw-r--r--net/p5-IO-Socket-Multicast/distinfo1
-rw-r--r--net/p5-IO-Socket-Multicast/pkg-comment1
-rw-r--r--net/p5-IO-Socket-Multicast/pkg-descr8
-rw-r--r--net/p5-IO-Socket-Multicast/pkg-plist9
6 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c905a8a41a67..22201d70584c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -346,6 +346,7 @@
SUBDIR += p5-Frontier-RPC
SUBDIR += p5-IC-Radius
SUBDIR += p5-IO-Interface
+ SUBDIR += p5-IO-Socket-Multicast
SUBDIR += p5-JUNOScript
SUBDIR += p5-Mon
SUBDIR += p5-Net
diff --git a/net/p5-IO-Socket-Multicast/Makefile b/net/p5-IO-Socket-Multicast/Makefile
new file mode 100644
index 000000000000..2072a80cc768
--- /dev/null
+++ b/net/p5-IO-Socket-Multicast/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-IO-Socket-Multicast
+# Date created: 10 Sep 2002
+# Whom: Kelly Yancey <kbyanc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Socket-Multicast
+PORTVERSION= 0.25
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kbyanc@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/IO/Interface.pm:${PORTSDIR}/net/p5-IO-Interface
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= IO::Socket::Multicast.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/p5-IO-Socket-Multicast/distinfo b/net/p5-IO-Socket-Multicast/distinfo
new file mode 100644
index 000000000000..88e16677a577
--- /dev/null
+++ b/net/p5-IO-Socket-Multicast/distinfo
@@ -0,0 +1 @@
+MD5 (IO-Socket-Multicast-0.25.tar.gz) = 57e089b7edefa291e4542e7d8f051352
diff --git a/net/p5-IO-Socket-Multicast/pkg-comment b/net/p5-IO-Socket-Multicast/pkg-comment
new file mode 100644
index 000000000000..8a57c2081950
--- /dev/null
+++ b/net/p5-IO-Socket-Multicast/pkg-comment
@@ -0,0 +1 @@
+Perl module to send and receive multicast messages
diff --git a/net/p5-IO-Socket-Multicast/pkg-descr b/net/p5-IO-Socket-Multicast/pkg-descr
new file mode 100644
index 000000000000..b0b969937c91
--- /dev/null
+++ b/net/p5-IO-Socket-Multicast/pkg-descr
@@ -0,0 +1,8 @@
+From the README:
+ The IO::Socket::Multicast module subclasses IO::Socket::INET to enable
+ you to manipulate multicast groups. With this module (and an operating
+ system that supports multicasting), you will be able to receive incoming
+ multicast transmissions and generate your own outgoing multicast
+ packets.
+
+- Kelly Yancey <kbyanc@FreeBSD.org>
diff --git a/net/p5-IO-Socket-Multicast/pkg-plist b/net/p5-IO-Socket-Multicast/pkg-plist
new file mode 100644
index 000000000000..3fb905b3f4dd
--- /dev/null
+++ b/net/p5-IO-Socket-Multicast/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO/Socket/Multicast.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Socket/Multicast/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Socket/Multicast/Multicast.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Socket/Multicast/Multicast.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO/Socket
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Socket/Multicast
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Socket
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO