aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/tcl82/Makefile3
-rw-r--r--lang/tcl83/Makefile3
-rw-r--r--lang/tcl84/Makefile3
3 files changed, 9 insertions, 0 deletions
diff --git a/lang/tcl82/Makefile b/lang/tcl82/Makefile
index 526b50ea4eb6..97079696e9ef 100644
--- a/lang/tcl82/Makefile
+++ b/lang/tcl82/Makefile
@@ -29,6 +29,9 @@ NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
USE_REINPLACE= YES
PLIST_SUB= TCL_VER=8.2 SHORT_TCL_VER=82
+# we need fpsetround
+NOT_FOR_ARCHS= amd64
+
MAN1= tclsh.1
MAN3= Access.3 AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 \
diff --git a/lang/tcl83/Makefile b/lang/tcl83/Makefile
index 0bd62be7c3f3..e7e29706b1f3 100644
--- a/lang/tcl83/Makefile
+++ b/lang/tcl83/Makefile
@@ -31,6 +31,9 @@ NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
USE_REINPLACE= YES
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=83
+# we need fpsetround
+NOT_FOR_ARCHS= amd64
+
MAN1= tclsh.1
MAN3= Access.3 AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 \
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index a556e53b38ff..d892531883b5 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -36,6 +36,9 @@ CONFIGURE_ARGS+= --enable-threads
PKGNAMESUFFIX?= -threads
.endif
+# we need fpsetround
+NOT_FOR_ARCHS= amd64
+
MAN1= tclsh.1
MAN3= Access.3 AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 \