aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/ruby20/Makefile3
-rw-r--r--lang/ruby21/Makefile3
-rw-r--r--lang/ruby22/Makefile3
3 files changed, 9 insertions, 0 deletions
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index c52167146157..b2bfbe10b87d 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -40,6 +40,9 @@ USE_OPENSSL= yes
USES= cpe execinfo tar:bzip2
WRKSRC= ${RUBY_WRKSRC}
+NOT_FOR_ARCHS= ia64
+NOT_FOR_ARCHS_REASON_ia64= does not build
+
RUBY_VER= 2.0
USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index 08ea5a42237c..15f46101d560 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -40,6 +40,9 @@ USE_OPENSSL= yes
USES= cpe execinfo tar:xz
WRKSRC= ${RUBY_WRKSRC}
+NOT_FOR_ARCHS= ia64
+NOT_FOR_ARCHS_REASON_ia64= does not build
+
RUBY_VER= 2.1
USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index f658ca28c623..4856beb4d282 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -45,6 +45,9 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
+NOT_FOR_ARCHS= ia64
+NOT_FOR_ARCHS_REASON_ia64= does not build
+
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES GMP RDOC
OPTIONS_DEFAULT= RDOC LIBEDIT
OPTIONS_SINGLE= EDIT