aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-rack-cors/Makefile20
-rw-r--r--www/rubygem-rack-cors/distinfo2
-rw-r--r--www/rubygem-rack-cors/pkg-descr5
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index cb94204446fe..c06bed25572e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1840,6 +1840,7 @@
SUBDIR += rubygem-rack-attack
SUBDIR += rubygem-rack-cache
SUBDIR += rubygem-rack-contrib
+ SUBDIR += rubygem-rack-cors
SUBDIR += rubygem-rack-mount
SUBDIR += rubygem-rack-openid
SUBDIR += rubygem-rack-protection
diff --git a/www/rubygem-rack-cors/Makefile b/www/rubygem-rack-cors/Makefile
new file mode 100644
index 000000000000..415b6a1b4329
--- /dev/null
+++ b/www/rubygem-rack-cors/Makefile
@@ -0,0 +1,20 @@
+# Created by: Michael Moll <kvedulv at kvedulv.de>
+# $FreeBSD$
+
+PORTNAME= rack-cors
+PORTVERSION= 0.2.9
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Middleware that will make Rack-based apps CORS compatible
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-rack>=0.4:${PORTSDIR}/www/rubygem-rack
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-rack-cors/distinfo b/www/rubygem-rack-cors/distinfo
new file mode 100644
index 000000000000..4b443fae6510
--- /dev/null
+++ b/www/rubygem-rack-cors/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rack-cors-0.2.9.gem) = 5a256bda2673c7bbba014587b1f93fd2e6fd80b7ac9804a0f90665add6ba087d
+SIZE (rubygem/rack-cors-0.2.9.gem) = 47104
diff --git a/www/rubygem-rack-cors/pkg-descr b/www/rubygem-rack-cors/pkg-descr
new file mode 100644
index 000000000000..612cdab33614
--- /dev/null
+++ b/www/rubygem-rack-cors/pkg-descr
@@ -0,0 +1,5 @@
+Rack::Cors provides support for Cross-Origin Resource Sharing (CORS) for
+Rack compatible web applications. The CORS spec allows web applications
+to make cross domain AJAX calls without using workarounds such as JSONP.
+
+WWW: https://github.com/cyu/rack-cors