aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/codelite/Makefile13
-rw-r--r--editors/codelite/distinfo4
-rw-r--r--editors/codelite/files/patch-CMakeLists.txt6
-rw-r--r--editors/codelite/pkg-plist39
4 files changed, 43 insertions, 19 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index 34fd0722de60..be1f536a0b0a 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= codelite
-DISTVERSION= 5.4
+DISTVERSION= 6.0.1
CATEGORIES= editors devel
MAINTAINER= gahr@FreeBSD.org
@@ -21,8 +21,7 @@ OPTIONS_SUB= yes
USE_GITHUB= yes
GH_ACCOUNT= eranif
GH_PROJECT= ${PORTNAME}
-GH_COMMIT= 41e98e5
-GH_TAGNAME= 5.4
+GH_COMMIT= 5bc3080
USE_WX= 3.0
WX_UNICODE= yes
@@ -33,6 +32,7 @@ SHEBANG_FILES= Runtime/clg++ Runtime/clgcc
CXXFLAGS+= -I${LOCALBASE}/include
CMAKE_ARGS+= -DIS_FREEBSD=1 \
+ -DENABLE_LLDB=0 \
-DPREFIX=${PREFIX}
.include <bsd.port.options.mk>
@@ -42,8 +42,8 @@ RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
.endif
.if ${PORT_OPTIONS:MCLANG}
-BUILD_DEPENDS+= ${LOCALBASE}/llvm-devel/lib/libclang.so:${PORTSDIR}/lang/clang-devel
-RUN_DEPENDS+= ${LOCALBASE}/llvm-devel/lib/libclang.so:${PORTSDIR}/lang/clang-devel
+BUILD_DEPENDS+= ${LOCALBASE}/llvm34/lib/libclang.so:${PORTSDIR}/lang/clang34
+RUN_DEPENDS+= ${LOCALBASE}/llvm34/lib/libclang.so:${PORTSDIR}/lang/clang34
CMAKE_ARGS+= -DENABLE_CLANG=1
.else
CMAKE_ARGS+= -DENABLE_CLANG=0
@@ -57,5 +57,8 @@ post-patch:
s|%%PREFIX%%|${PREFIX}|g; \
/IS_FREEBSD/s|0|1|' \
${WRKSRC}/CMakeLists.txt
+ ${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/LiteEditor/CMakeLists.txt
+ ${REINPLACE_CMD} -e 's|codelitegcc|codelite-cc|' \
+ ${WRKSRC}/Runtime/clgcc ${WRKSRC}/Runtime/clg++
.include <bsd.port.mk>
diff --git a/editors/codelite/distinfo b/editors/codelite/distinfo
index b0c123976038..a350cc5012b2 100644
--- a/editors/codelite/distinfo
+++ b/editors/codelite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (codelite-5.4.tar.gz) = 53253fd4406a455dc8389a1bacd52ee0ee5407c90c3f682e30b97f5532a4992a
-SIZE (codelite-5.4.tar.gz) = 37946071
+SHA256 (codelite-6.0.1.tar.gz) = 42bdd3ac31188905098e9fa56279429ac536d884ff7d5834d3468ae6f4fd22df
+SIZE (codelite-6.0.1.tar.gz) = 93524403
diff --git a/editors/codelite/files/patch-CMakeLists.txt b/editors/codelite/files/patch-CMakeLists.txt
index 51347115b917..9939fcaf0960 100644
--- a/editors/codelite/files/patch-CMakeLists.txt
+++ b/editors/codelite/files/patch-CMakeLists.txt
@@ -29,9 +29,9 @@
- set( CLANG_INCLUDE "${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/include" )
- set( CLANG_LIBRARY "-L${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/lib -lclang" )
- set( CLANG_BINARY "${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/lib/libclang.so")
-+ set( CLANG_INCLUDE "%%LOCALBASE%%/llvm-devel/include" )
-+ set( CLANG_LIBRARY "-L%%LOCALBASE%%/llvm-devel/lib/ -lclang" )
-+ set( CLANG_BINARY "%%LOCALBASE%%/llvm-devel/lib/libclang.so")
++ set( CLANG_INCLUDE "%%LOCALBASE%%/llvm34/include" )
++ set( CLANG_LIBRARY "-L%%LOCALBASE%%/llvm34/lib/ -lclang" )
++ set( CLANG_BINARY "%%LOCALBASE%%/llvm34/lib/libclang.so")
endif()
message( "-- clang link line ${CLANG_LIBRARY} ")
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
index 0579790ff06f..8a4e95d9ac05 100644
--- a/editors/codelite/pkg-plist
+++ b/editors/codelite/pkg-plist
@@ -1,16 +1,21 @@
-bin/codelite
-bin/codelite-make
-bin/codelite-terminal
%%CLANG%%bin/codelite-clang
bin/clg++
bin/clgcc
+bin/codelite
+bin/codelite-cc
+bin/codelite-echo
+bin/codelite-make
+bin/codelite-terminal
bin/codelite_cppcheck
bin/codelite_exec
bin/codelite_fix_files
bin/codelite_indexer
bin/codelite_kill_children
bin/codelite_xterm
-bin/codelitegcc
+lib/codelite/CodeLiteDiff.so
+man/man1/codelite-make.1.gz
+man/man1/codelite.1.gz
+man/man1/codelite_fix_files.1.gz
lib/codelite/CMakePlugin.so
lib/codelite/CallGraph.so
lib/codelite/CodeFormatter.so
@@ -62,6 +67,11 @@ lib/codelite/wxFormBuilder.so
%%DATADIR%%/codelite-icons.zip
%%DATADIR%%/config/accelerators.conf.default
%%DATADIR%%/config/build_settings.xml.default
+%%DATADIR%%/config/cfg/gtk.cfg
+%%DATADIR%%/config/cfg/posix.cfg
+%%DATADIR%%/config/cfg/qt.cfg
+%%DATADIR%%/config/cfg/std.cfg
+%%DATADIR%%/config/cfg/windows.cfg
%%DATADIR%%/config/codelite.xml.default
%%DATADIR%%/config/debuggers.xml.default
%%DATADIR%%/gdb_printers/libstdcxx/__init__.py
@@ -129,6 +139,10 @@ lib/codelite/wxFormBuilder.so
%%DATADIR%%/templates/gizmos/wxmain.project.wizard
%%DATADIR%%/templates/gizmos/wxproject-fb.project.wizard
%%DATADIR%%/templates/gizmos/wxproject.project.wizard
+%%DATADIR%%/templates/projects/CMake_Executable/CMakeLists.txt
+%%DATADIR%%/templates/projects/CMake_Executable/CMake_Executable.project
+%%DATADIR%%/templates/projects/CMake_Executable/icon.png
+%%DATADIR%%/templates/projects/CMake_Executable/main.cpp
%%DATADIR%%/templates/projects/ConsoleClang++/ConsoleClang++.project
%%DATADIR%%/templates/projects/ConsoleClang++/main.cpp
%%DATADIR%%/templates/projects/ConsoleClang/ConsoleClang.project
@@ -199,6 +213,12 @@ lib/codelite/wxFormBuilder.so
%%DATADIR%%/templates/projects/executable-wx-frame/main.cpp
%%DATADIR%%/templates/projects/executable-wx-frame/main.h
%%DATADIR%%/templates/projects/executable-wx-frame/win_resources.rc
+%%DATADIR%%/templates/projects/executable-wx-xrc/executable-wx-xrc.project
+%%DATADIR%%/templates/projects/executable-wx-xrc/gui.wxcp
+%%DATADIR%%/templates/projects/executable-wx-xrc/gui.xrc
+%%DATADIR%%/templates/projects/executable-wx-xrc/icon.png
+%%DATADIR%%/templates/projects/executable-wx-xrc/main.cpp
+%%DATADIR%%/templates/projects/executable-wx-xrc/main.h
%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/MainDialog.cpp
%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/MainDialog.h
%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/icon.png
@@ -242,7 +262,7 @@ lib/codelite/wxFormBuilder.so
%%DATADIR%%/templates/qmake/qmake.project
%%DATADIR%%/unittest++1.3.tar.gz
%%NLS%%share/locale/cs/LC_MESSAGES/codelite.mo
-%%NLS%%share/locale/cz/LC_MESSAGES/codelite.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/codelite.mo
share/applications/codelite.desktop
@dirrm lib/codelite/resources
@dirrm lib/codelite/debuggers
@@ -257,6 +277,7 @@ share/applications/codelite.desktop
@dirrm %%DATADIR%%/templates/projects/non-code-project
@dirrm %%DATADIR%%/templates/projects/executable-wxcrafter-frame
@dirrm %%DATADIR%%/templates/projects/executable-wxcrafter-dialog
+@dirrm %%DATADIR%%/templates/projects/executable-wx-xrc
@dirrm %%DATADIR%%/templates/projects/executable-wx-frame
@dirrm %%DATADIR%%/templates/projects/executable-wx-enabled
@dirrm %%DATADIR%%/templates/projects/executable-wx-dialog
@@ -274,11 +295,12 @@ share/applications/codelite.desktop
@dirrm %%DATADIR%%/templates/projects/cobra-staticU
@dirrm %%DATADIR%%/templates/projects/cobra-libraryU
@dirrm %%DATADIR%%/templates/projects/cobra-executableU
-@dirrm %%DATADIR%%/templates/projects/ConsoleClang++
-@dirrm %%DATADIR%%/templates/projects/ConsoleClang
@dirrm %%DATADIR%%/templates/projects/c_gtk3_template
@dirrm %%DATADIR%%/templates/projects/c_gtk24_template
@dirrm %%DATADIR%%/templates/projects/UnitTest++
+@dirrm %%DATADIR%%/templates/projects/ConsoleClang++
+@dirrm %%DATADIR%%/templates/projects/ConsoleClang
+@dirrm %%DATADIR%%/templates/projects/CMake_Executable
@dirrm %%DATADIR%%/templates/projects
@dirrm %%DATADIR%%/templates/gizmos
@dirrm %%DATADIR%%/templates/formbuilder
@@ -291,7 +313,6 @@ share/applications/codelite.desktop
@dirrm %%DATADIR%%/gdb_printers/libstdcxx/v6
@dirrm %%DATADIR%%/gdb_printers/libstdcxx
@dirrm %%DATADIR%%/gdb_printers
+@dirrm %%DATADIR%%/config/cfg
@dirrm %%DATADIR%%/config
@dirrm %%DATADIR%%
-@dirrmtry share/locale/cz/LC_MESSAGES
-@dirrmtry share/locale/cz