aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Device-USB/Makefile14
-rw-r--r--devel/p5-Device-USB/files/patch-Makefile.PL14
2 files changed, 25 insertions, 3 deletions
diff --git a/devel/p5-Device-USB/Makefile b/devel/p5-Device-USB/Makefile
index b5ce22cf31ce..4aa7abf43658 100644
--- a/devel/p5-Device-USB/Makefile
+++ b/devel/p5-Device-USB/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Device-USB
PORTVERSION= 0.35
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN \
http://personalpages.tds.net/~jwbacon/Ports/distfiles/
@@ -12,11 +12,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= josh.carroll@gmail.com
COMMENT= Perl wrapper for libusb
-BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
-RUN_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline \
+ p5-Inline-C>=0:${PORTSDIR}/devel/p5-Inline-C
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_UNSAFE=yes
USES= perl5
USE_PERL5= configure
+post-patch:
+ @${REINPLACE_CMD} -e 's|dump_usb.pl|lib/Device/&|' ${WRKSRC}/MANIFEST
+ @${MV} ${WRKSRC}/dump_usb.pl ${WRKSRC}/lib/Device/
+
.include <bsd.port.mk>
diff --git a/devel/p5-Device-USB/files/patch-Makefile.PL b/devel/p5-Device-USB/files/patch-Makefile.PL
new file mode 100644
index 000000000000..33ce38684615
--- /dev/null
+++ b/devel/p5-Device-USB/files/patch-Makefile.PL
@@ -0,0 +1,14 @@
+--- Makefile.PL.orig 2010-03-21 23:29:00.000000000 +0800
+--- Makefile.PL 2015-01-03 03:18:10.000000000 +0800
+@@ -2,6 +2,11 @@
+ use warnings;
+ use Inline::MakeMaker;
+
++sub MY::libscan {
++ return if ($_[1] eq 'USB.pm' or $_[1] eq 'lib/Device/dump_usb.pl');
++ return $_[1];
++}
++
+ if($^O eq 'MSWin32')
+ {
+ if(!$ENV{LIBUSB_LIBDIR} or !$ENV{LIBUSB_INCDIR})