aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/notecase/Makefile8
-rw-r--r--graphics/exact-image/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/deskutils/notecase/Makefile b/deskutils/notecase/Makefile
index c7609bf94aba..2f72b3fffb7b 100644
--- a/deskutils/notecase/Makefile
+++ b/deskutils/notecase/Makefile
@@ -24,6 +24,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
INSTALL_TARGET= install docinstall
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+BROKEN= Does not compile
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|prefix=/usr|prefix=${PREFIX}|' \
${WRKSRC}/Makefile
@@ -32,4 +38,4 @@ post-install:
@-update-mime-database ${PREFIX}/share/mime
@-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 65b3cd0dae4a..dbbc086d8946 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -37,6 +37,12 @@ PLIST_FILES= ${BINS:S|^|bin/|} %%SITE_PERL%%/ExactImage.so \
%%SITE_PERL%%/ExactImage.pm
PORT_VERBS= ExactImage ${BINS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+BROKEN= Does not compile, missing endian.h header
+.endif
+
post-extract:
@${RM} -rf ${WRKSRC}/agg-2.4/
@@ -66,4 +72,4 @@ do-install:
${INSTALL_PROGRAM} ExactImage.so ${SITE_PERL}/;\
${INSTALL_DATA} ExactImage.pm ${SITE_PERL}/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>