aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/php5/Makefile.ext2
-rw-r--r--lang/php55/Makefile.ext2
-rw-r--r--net/php5-xmlrpc/files/patch-config.m423
-rw-r--r--net/php55-xmlrpc/files/patch-config.m423
4 files changed, 48 insertions, 2 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 9edf926ad540..de3e00f9255b 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -427,7 +427,7 @@ CONFIGURE_ARGS+=--with-xmlrpc \
--with-libxml-dir=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USES+= iconv::translit
+USES+= iconv:translit
USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index f7793db94d0b..74e38a29710a 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -431,7 +431,7 @@ CONFIGURE_ARGS+=--with-xmlrpc \
--with-libxml-dir=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USES+= iconv::translit
+USES+= iconv:translit
USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc
diff --git a/net/php5-xmlrpc/files/patch-config.m4 b/net/php5-xmlrpc/files/patch-config.m4
new file mode 100644
index 000000000000..098855a191dd
--- /dev/null
+++ b/net/php5-xmlrpc/files/patch-config.m4
@@ -0,0 +1,23 @@
+--- config.m4.orig 2014-05-15 08:00:57.801291749 +0000
++++ config.m4 2014-05-15 08:01:40.161014307 +0000
+@@ -61,11 +61,9 @@
+ fi
+ fi
+
+- dnl if iconv is shared or missing then we should build iconv ourselves
+- if test "$PHP_ICONV_SHARED" = "yes" || test "$PHP_ICONV" = "no"; then
+-
+ if test "$PHP_ICONV_DIR" != "no"; then
+ PHP_ICONV=$PHP_ICONV_DIR
++ PHP_ADD_INCLUDE($PHP_ICONV_DIR/include)
+ fi
+
+ if test -z "$PHP_ICONV" || test "$PHP_ICONV" = "no"; then
+@@ -75,7 +73,6 @@
+ PHP_SETUP_ICONV(XMLRPC_SHARED_LIBADD, [], [
+ AC_MSG_ERROR([iconv not found, in order to build xmlrpc you need the iconv library])
+ ])
+- fi
+ fi
+
+ if test "$PHP_XMLRPC" = "yes"; then
diff --git a/net/php55-xmlrpc/files/patch-config.m4 b/net/php55-xmlrpc/files/patch-config.m4
new file mode 100644
index 000000000000..d2dc85f26a48
--- /dev/null
+++ b/net/php55-xmlrpc/files/patch-config.m4
@@ -0,0 +1,23 @@
+--- config.m4.orig 2014-04-29 08:04:30.000000000 +0000
++++ config.m4 2014-05-15 08:04:00.883004682 +0000
+@@ -61,11 +61,9 @@ if test "$PHP_XMLRPC" != "no"; then
+ fi
+ fi
+
+- dnl if iconv is shared or missing then we should build iconv ourselves
+- if test "$PHP_ICONV_SHARED" = "yes" || test "$PHP_ICONV" = "no"; then
+-
+ if test "$PHP_ICONV_DIR" != "no"; then
+ PHP_ICONV=$PHP_ICONV_DIR
++ PHP_ADD_INCLUDE($PHP_ICONV_DIR/include)
+ fi
+
+ if test -z "$PHP_ICONV" || test "$PHP_ICONV" = "no"; then
+@@ -75,7 +73,6 @@ if test "$PHP_XMLRPC" != "no"; then
+ PHP_SETUP_ICONV(XMLRPC_SHARED_LIBADD, [], [
+ AC_MSG_ERROR([iconv not found, in order to build xmlrpc you need the iconv library])
+ ])
+- fi
+ fi
+
+ if test "$PHP_XMLRPC" = "yes"; then