aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-PSGI/Makefile23
-rw-r--r--www/p5-PSGI/distinfo3
-rw-r--r--www/p5-PSGI/files/patch-Makefile.PL9
-rw-r--r--www/p5-PSGI/pkg-descr3
-rw-r--r--www/p5-PSGI/pkg-plist5
6 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9580748af6ed..abc179544a38 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1025,6 +1025,7 @@
SUBDIR += p5-POE-Component-Server-SOAP
SUBDIR += p5-POE-Component-Server-SimpleHTTP
SUBDIR += p5-POE-Filter-HTTP-Parser
+ SUBDIR += p5-PSGI
SUBDIR += p5-ParallelUA
SUBDIR += p5-Path-Class-URI
SUBDIR += p5-Plack
diff --git a/www/p5-PSGI/Makefile b/www/p5-PSGI/Makefile
new file mode 100644
index 000000000000..d9792f79a43b
--- /dev/null
+++ b/www/p5-PSGI/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: PSGI
+# Date created: 13 Oct 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PSGI
+PORTVERSION= 1.00
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/MI/MIYAGAWA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Pod documentation for Perl Web Server Gateway Interface Specification
+
+PERL_CONFIGURE= yes
+
+MAN3= PSGI::FAQ.3 \
+ PSGI.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-PSGI/distinfo b/www/p5-PSGI/distinfo
new file mode 100644
index 000000000000..c07ba29523f6
--- /dev/null
+++ b/www/p5-PSGI/distinfo
@@ -0,0 +1,3 @@
+MD5 (PSGI-1.00.tar.gz) = 086e0a81a8661f5366533300e1d39732
+SHA256 (PSGI-1.00.tar.gz) = a4abb1e255d7197e36be698c65a5fac2af42797fd9dde01e8df634f466bf9d1c
+SIZE (PSGI-1.00.tar.gz) = 27678
diff --git a/www/p5-PSGI/files/patch-Makefile.PL b/www/p5-PSGI/files/patch-Makefile.PL
new file mode 100644
index 000000000000..703499149e41
--- /dev/null
+++ b/www/p5-PSGI/files/patch-Makefile.PL
@@ -0,0 +1,9 @@
+--- Makefile.PL.orig 2009-10-13 23:00:47.267814042 +0900
++++ Makefile.PL 2009-10-13 23:00:55.231925535 +0900
+@@ -1,6 +1,5 @@
+ use inc::Module::Install;
+ name 'PSGI';
+ version '1.00';
+-all_from 'PSGI.pm';
+ auto_set_repository;
+ WriteAll;
diff --git a/www/p5-PSGI/pkg-descr b/www/p5-PSGI/pkg-descr
new file mode 100644
index 000000000000..2c7e8a8b318c
--- /dev/null
+++ b/www/p5-PSGI/pkg-descr
@@ -0,0 +1,3 @@
+Perl Web Server Gateway Interface Specification (pod only).
+
+WWW: http://search.cpan.org/dist/PSGI/
diff --git a/www/p5-PSGI/pkg-plist b/www/p5-PSGI/pkg-plist
new file mode 100644
index 000000000000..75752f8919b2
--- /dev/null
+++ b/www/p5-PSGI/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/PSGI/.packlist
+%%SITE_PERL%%/PSGI/FAQ.pod
+%%SITE_PERL%%/PSGI.pod
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PSGI
+@dirrmtry %%SITE_PERL%%/PSGI