aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/linphone/Makefile7
-rw-r--r--net/linphone/files/patch-08-313aa6829
2 files changed, 33 insertions, 3 deletions
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index d24d17837d9d..b4bd4ff06e23 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -2,7 +2,7 @@
PORTNAME= linphone
PORTVERSION= 4.1.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= https://www.linphone.org/releases/sources/linphoneqt/
@@ -16,8 +16,9 @@ LIB_DEPENDS= libbctoolbox.so:net/bctoolbox \
liblinphone++.so:net/liblinphone
USES= cmake:outsource compiler:c++11-lib pkgconfig qt:5
-USE_QT= buildtools_build concurrent core declarative gui linguisttools network \
- qmake_build quickcontrols2 speech svg testlib widgets
+USE_QT= buildtools_build concurrent core declarative \
+ graphicaleffects_run gui linguisttools network qmake_build \
+ quickcontrols_run quickcontrols2 speech svg testlib widgets
post-patch:
@${REINPLACE_CMD} 's/LINPHONE_QT_GIT_VERSION/"${PORTVERSION}"/' \
diff --git a/net/linphone/files/patch-08-313aa68 b/net/linphone/files/patch-08-313aa68
new file mode 100644
index 000000000000..5a4029332ee6
--- /dev/null
+++ b/net/linphone/files/patch-08-313aa68
@@ -0,0 +1,29 @@
+From 313aa682738fc877ee8ba78b1d4060e08739cc24 Mon Sep 17 00:00:00 2001
+From: Ronan Abhamon <ronan.abhamon@belledonne-communications.com>
+Date: Fri, 19 Jan 2018 15:16:03 +0100
+Subject: [PATCH] feat(AppController): force default theme style
+
+---
+ src/app/AppController.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/app/AppController.cpp b/src/app/AppController.cpp
+index 2d353884..711e1a9b 100644
+--- src/app/AppController.cpp
++++ src/app/AppController.cpp
+@@ -23,6 +23,7 @@
+ #include <QDirIterator>
+ #include <QFontDatabase>
+ #include <QMessageBox>
++#include <QQuickStyle>
+
+ #include "gitversion.h"
+
+@@ -85,6 +86,7 @@ AppController::AppController (int &argc, char *argv[]) {
+ QCoreApplication::setApplicationVersion(APPLICATION_VERSION);
+
+ mApp = new App(argc, argv);
++ QQuickStyle::setStyle("Default");
+ if (mApp->isSecondary()) {
+ #ifdef Q_OS_MACOS
+ mApp->processEvents();