aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/qscintilla/Makefile162
-rw-r--r--x11-toolkits/qscintilla/distinfo4
-rw-r--r--x11-toolkits/qscintilla/files/patch-Qt4Qt5_qscintilla.pro35
-rw-r--r--x11-toolkits/qscintilla/files/patch-designer-Qt4_designer.pro15
-rw-r--r--x11-toolkits/qscintilla/pkg-plist284
5 files changed, 161 insertions, 339 deletions
diff --git a/x11-toolkits/qscintilla/Makefile b/x11-toolkits/qscintilla/Makefile
index c407a766b0ff..82ead10e405f 100644
--- a/x11-toolkits/qscintilla/Makefile
+++ b/x11-toolkits/qscintilla/Makefile
@@ -1,156 +1,70 @@
-# New ports collection makefile for: qscintilla
-# Date created: 2003-08-02
-# Whom: arved
-#
+# Created by: arved
# $FreeBSD$
PORTNAME= qscintilla
-PORTVERSION= 1.7.1
-PORTREVISION= 8
+PORTVERSION= 2.7
CATEGORIES= x11-toolkits
-MASTER_SITES= http://www.riverbankcomputing.com/static/Downloads/QScintilla1/ \
- http://ns.ael.ru/~fluffy.khv/pyqt/QScintilla1/
-DISTNAME= QScintilla-1.71-gpl-${PORTVERSION}
+MASTER_SITES= SF/pyqt/QScintilla2/QScintilla-${PORTVERSION}
+DISTNAME= QScintilla-gpl-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= QT port of the Scintilla C++ editor class
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
-DEPRECATED= Depends on QT3; unmaintained
-EXPIRATION_DATE= 2013-07-01
+USE_QT4= corelib qmake gui
-USE_QT_VER= 3
-MAKE_ENV= QTDIR="${QT_PREFIX}"
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DESIGNER_PLUGIN DOCS EXAMPLES LANG_DE LANG_FR LANG_PTBR LANG_RU
-OPTIONS_DEFAULT= DESIGNER_PLUGIN DOCS EXAMPLES LANG_DE LANG_FR LANG_PTBR LANG_RU
+OPTIONS_DEFINE= DESIGNER_PLUGIN DOCS EXAMPLES
+OPTIONS_DEFAULT=DESIGNER_PLUGIN DOCS EXAMPLES
DESIGNER_PLUGIN_DESC= Install plugin for Qt Designer
-LANG_DE_DESC= Install German translation
-LANG_FR_DESC= Install French translation
-LANG_PTBR_DESC= Install Brazilian Portuguese translation
-LANG_RU_DESC= Install Russian translation
-QMAKE= ${LOCALBASE}/bin/qmake
-SPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-PLUGINDIR= ${LOCALBASE}/lib/plugins/designer
+PLUGINDIR= ${LOCALBASE}/lib/qt4/plugins/designer
+WRKDIRS= Qt4Qt5
-.include <bsd.port.pre.mk>
+PORTDOCS= *
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_SUB+= DOCS=""
-.else
-PLIST_SUB+= DOCS="@comment "
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
-PLIST_SUB+= EXAMPLES=""
-.else
-PLIST_SUB+= EXAMPLES="@comment "
-.endif
.if ${PORT_OPTIONS:MDESIGNER_PLUGIN}
+USE_QT4+= designer
+WRKDIRS+= designer-Qt4
PLIST_SUB+= DESIGNER_PLUGIN=""
.else
PLIST_SUB+= DESIGNER_PLUGIN="@comment "
.endif
-.if ${PORT_OPTIONS:MLANG_DE}
-PLIST_SUB+= LANG_DE=""
-.else
-PLIST_SUB+= LANG_DE="@comment "
-.endif
-.if ${PORT_OPTIONS:MLANG_FR}
-PLIST_SUB+= LANG_FR=""
-.else
-PLIST_SUB+= LANG_FR="@comment "
-.endif
-.if ${PORT_OPTIONS:MLANG_PTBR}
-PLIST_SUB+= LANG_PTBR=""
-.else
-PLIST_SUB+= LANG_PTBR="@comment "
-.endif
-.if ${PORT_OPTIONS:MLANG_RU}
-PLIST_SUB+= LANG_RU=""
-.else
-PLIST_SUB+= LANG_RU="@comment "
-.endif
-.if !empty(PORT_OPTIONS:MLANG_DE) && !empty(PORT_OPTIONS:MLANG_FR) && !empty(PORT_OPTIONS:MLANG_PTBR) && !empty(PORT_OPTIONS:MLANG_RU)
-PLIST_SUB+= TRANSLATIONS=""
-.else
-PLIST_SUB+= TRANSLATIONS="@comment "
-.endif
+
+post-patch:
+ ${FIND} ${WRKSRC} -name "*.pro" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|%%PREFIX%%|${PREFIX}|g; s|%%DATADIR%%|${DATADIR}|'
do-configure:
- ( cd ${WRKSRC}/qt && \
- ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${SPEC} qscintilla.pro )
-
-post-configure:
- ( cd ${WRKSRC}/qt && \
- ${CAT} qscintilla.pro | ${GREP} -v DESTDIR > qscintilla.tmp && \
- ${CAT} Makefile | ${GREP} -v DEL_FILE | ${GREP} -v MOVE | \
- ${GREP} -v DESTDIR > Makefile.tmp && \
- ${MV} qscintilla.tmp qscintilla.pro && \
- ${MV} Makefile.tmp Makefile && \
- cd ${WRKSRC}/designer && \
- ${CAT} designer.pro | ${GREP} -v lqscintilla > designer.tmp && \
- ${ECHO} "INCPATH += ${LOCALBASE}/include ../qt" >> \
- designer.tmp && \
- ${ECHO} "LIBS += -L../qt -L${LOCALBASE}/lib -lqscintilla" >> \
- designer.tmp && \
- ${ECHO} "DESTDIR = ." >> designer.tmp && \
- ${MV} designer.tmp designer.pro )
+.for wrkdir in ${WRKDIRS}
+ (cd ${WRKSRC}/${wrkdir} && ${SETENV} ${MAKE_ENV} ${QMAKE})
+.endfor
do-build:
- ( cd ${WRKSRC}/qt && ${SETENV} ${MAKE_ENV} ${MAKE} )
-
-post-build:
-.if ${PORT_OPTIONS:MDESIGNER_PLUGIN}
- ( cd ${WRKSRC}/designer && ${SETENV} ${MAKE_ENV} \
- ${QMAKE} -spec ${SPEC} designer.pro && ${MAKE} )
-.endif
+.for wrkdir in ${WRKDIRS}
+ (cd ${WRKSRC}/${wrkdir} && ${SETENV} ${MAKE_ENV} ${MAKE})
+.endfor
do-install:
- ( cd ${WRKSRC} && \
- ${INSTALL_DATA} qt/qextscintilla*.h ${PREFIX}/include && \
- ${INSTALL_DATA} qt/libqscintilla.so.7.0.1 \
- ${PREFIX}/lib/libqscintilla.so.7 && \
- ${LN} -sf ${PREFIX}/lib/libqscintilla.so.7 \
- ${PREFIX}/lib/libqscintilla.so )
-.if ${PORT_OPTIONS:MDESIGNER_PLUGIN}
- ( cd ${WRKSRC} && \
- ${INSTALL_DATA} designer/libqscintillaplugin.so ${PLUGINDIR} )
-.endif
-.if !empty(PORT_OPTIONS:MLANG_DE) || !empty(PORT_OPTIONS:MLANG_FR) || !empty(PORT_OPTIONS:MLANG_PTBR) || !empty(PORT_OPTIONS:MLANG_RU)
- ${MKDIR} -m 0755 ${DATADIR}/translations
-.endif
-.if ${PORT_OPTIONS:MLANG_DE}
- ( cd ${WRKSRC} && \
- ${INSTALL_DATA} qt/qscintilla_de.qm ${DATADIR}/translations )
-.endif
-.if ${PORT_OPTIONS:MLANG_FR}
- ( cd ${WRKSRC} && \
- ${INSTALL_DATA} qt/qscintilla_fr.qm ${DATADIR}/translations )
-.endif
-.if ${PORT_OPTIONS:MLANG_PTBR}
- ( cd ${WRKSRC} && \
- ${INSTALL_DATA} qt/qscintilla_pt_br.qm ${DATADIR}/translations )
-.endif
-.if ${PORT_OPTIONS:MLANG_RU}
- ( cd ${WRKSRC} && \
- ${INSTALL_DATA} qt/qscintilla_ru.qm ${DATADIR}/translations )
-.endif
+.for wrkdir in ${WRKDIRS}
+ (cd ${WRKSRC}/${wrkdir} && ${SETENV} ${MAKE_ENV} ${MAKE} install)
+.endfor
+
+post-install:
.if ${PORT_OPTIONS:MDOCS}
- ( cd ${WRKSRC} && \
- ${MKDIR} -m 0755 ${DOCSDIR}/html ${DOCSDIR}/Scintilla && \
- ${INSTALL_DATA} ChangeLog NEWS README ${DOCSDIR} && \
- ${INSTALL_DATA} doc/qscintilla.dxy ${DOCSDIR} && \
- ${INSTALL_DATA} doc/html/* ${DOCSDIR}/html && \
- ${INSTALL_DATA} doc/Scintilla/* ${DOCSDIR}/Scintilla )
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc/html-Qt4Qt5 && ${COPYTREE_SHARE} \* ${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- ( cd ${WRKSRC} && \
- ${MKDIR} -m 0755 ${EXAMPLESDIR} && \
- ${INSTALL_DATA} example/* ${EXAMPLESDIR} )
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/example-Qt4Qt5 && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qscintilla/distinfo b/x11-toolkits/qscintilla/distinfo
index cb38d8069421..1979acc4e51b 100644
--- a/x11-toolkits/qscintilla/distinfo
+++ b/x11-toolkits/qscintilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (QScintilla-1.71-gpl-1.7.1.tar.gz) = 437e5fc6e5905f9aa7d0f4ea8eb41c96fcddf7ce3cb9b786066a315c5b9ff70c
-SIZE (QScintilla-1.71-gpl-1.7.1.tar.gz) = 1060119
+SHA256 (QScintilla-gpl-2.7.tar.gz) = 75bb242527aa83c6db2f8f2e655a79b6f0911f07fd7fee26ad5801de3a0f8a0e
+SIZE (QScintilla-gpl-2.7.tar.gz) = 2839325
diff --git a/x11-toolkits/qscintilla/files/patch-Qt4Qt5_qscintilla.pro b/x11-toolkits/qscintilla/files/patch-Qt4Qt5_qscintilla.pro
new file mode 100644
index 000000000000..637a015951a3
--- /dev/null
+++ b/x11-toolkits/qscintilla/files/patch-Qt4Qt5_qscintilla.pro
@@ -0,0 +1,35 @@
+--- Qt4Qt5/qscintilla.pro.orig 2012-12-08 10:25:28.000000000 +0100
++++ Qt4Qt5/qscintilla.pro 2013-02-05 11:33:55.000000000 +0100
+@@ -42,28 +42,24 @@
+ #DEFINES += SCI_NAMESPACE
+
+ # Handle both Qt v4 and v3.
+-target.path = $$[QT_INSTALL_LIBS]
+ isEmpty(target.path) {
+- target.path = $(QTDIR)/lib
++ target.path = %%PREFIX%%/lib/qt4
+ }
+
+-header.path = $$[QT_INSTALL_HEADERS]
+ header.files = Qsci
+ isEmpty(header.path) {
+- header.path = $(QTDIR)/include/Qsci
++ header.path = %%PREFIX%%/include/qt4/Qsci
+ header.files = Qsci/qsci*.h
+ }
+
+-trans.path = $$[QT_INSTALL_TRANSLATIONS]
+ trans.files = qscintilla_*.qm
+ isEmpty(trans.path) {
+- trans.path = $(QTDIR)/translations
++ trans.path = %%DATADIR%%/translations
+ }
+
+-qsci.path = $$[QT_INSTALL_DATA]
+ qsci.files = ../qsci
+ isEmpty(qsci.path) {
+- qsci.path = $(QTDIR)
++ qsci.path = %%DATADIR%%
+ }
+
+ INSTALLS += header trans qsci target
diff --git a/x11-toolkits/qscintilla/files/patch-designer-Qt4_designer.pro b/x11-toolkits/qscintilla/files/patch-designer-Qt4_designer.pro
new file mode 100644
index 000000000000..7410b4c26df6
--- /dev/null
+++ b/x11-toolkits/qscintilla/files/patch-designer-Qt4_designer.pro
@@ -0,0 +1,15 @@
+--- designer-Qt4/designer.pro.orig 2011-06-13 14:16:23.000000000 +0200
++++ designer-Qt4/designer.pro 2013-02-05 11:25:33.000000000 +0100
+@@ -9,7 +9,9 @@
+ HEADERS = qscintillaplugin.h
+ SOURCES = qscintillaplugin.cpp
+
+-target.path = $$[QT_INSTALL_PLUGINS]/designer
+-INSTALLS += target
+
+-LIBS += -lqscintilla2
++LIBS += -L../Qt4Qt5 -lqscintilla2
++INCLUDEPATH = . ../Qt4Qt5
++
++target.path = %%PREFIX%%/lib/qt4/plugins/designer
++INSTALLS += target
diff --git a/x11-toolkits/qscintilla/pkg-plist b/x11-toolkits/qscintilla/pkg-plist
index d1175e43b53d..f7cf40dc03f4 100644
--- a/x11-toolkits/qscintilla/pkg-plist
+++ b/x11-toolkits/qscintilla/pkg-plist
@@ -1,213 +1,71 @@
-include/qextscintilla.h
-include/qextscintillaapis.h
-include/qextscintillabase.h
-include/qextscintillacommand.h
-include/qextscintillacommandset.h
-include/qextscintilladocument.h
-include/qextscintillaglobal.h
-include/qextscintillalexer.h
-include/qextscintillalexerbash.h
-include/qextscintillalexerbatch.h
-include/qextscintillalexercpp.h
-include/qextscintillalexercsharp.h
-include/qextscintillalexercss.h
-include/qextscintillalexerdiff.h
-include/qextscintillalexerhtml.h
-include/qextscintillalexeridl.h
-include/qextscintillalexerjava.h
-include/qextscintillalexerjavascript.h
-include/qextscintillalexerlua.h
-include/qextscintillalexermakefile.h
-include/qextscintillalexerperl.h
-include/qextscintillalexerpov.h
-include/qextscintillalexerproperties.h
-include/qextscintillalexerpython.h
-include/qextscintillalexerruby.h
-include/qextscintillalexersql.h
-include/qextscintillalexertex.h
-include/qextscintillamacro.h
-include/qextscintillaprinter.h
-lib/libqscintilla.so
-lib/libqscintilla.so.7
-%%DESIGNER_PLUGIN%%lib/plugins/designer/libqscintillaplugin.so
-%%DOCS%%%%DOCSDIR%%/ChangeLog
-%%DOCS%%%%DOCSDIR%%/NEWS
-%%DOCS%%%%DOCSDIR%%/README
-%%DOCS%%%%DOCSDIR%%/Scintilla/Design.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/Icons.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/Lexer.txt
-%%DOCS%%%%DOCSDIR%%/Scintilla/License.txt
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciBreak.jpg
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciCoding.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciRest.jpg
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciTEIco.png
-%%DOCS%%%%DOCSDIR%%/Scintilla/SciWord.jpg
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaDoc.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaDownload.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaHistory.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaRelated.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaToDo.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaUsage.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/Steps.html
-%%DOCS%%%%DOCSDIR%%/Scintilla/index.html
-%%DOCS%%%%DOCSDIR%%/html/annotated.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintilla-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintilla.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaAPIs-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaAPIs.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaBase-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaBase.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaCommand-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaCommand.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaCommandSet-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaCommandSet.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaDocument-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaDocument.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexer-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexer.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerBash-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerBash.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerBatch-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerBatch.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCPP-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCPP.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCSS-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCSS.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCSharp-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCSharp.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerDiff-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerDiff.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerHTML-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerHTML.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerIDL-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerIDL.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerJava-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerJava.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerJavaScript-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerJavaScript.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerLua-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerLua.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerMakefile-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerMakefile.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPOV-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPOV.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPerl-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPerl.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerProperties-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerProperties.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPython-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPython.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerRuby-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerRuby.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerSQL-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerSQL.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerTeX-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerTeX.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaMacro-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaMacro.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaPrinter-members.html
-%%DOCS%%%%DOCSDIR%%/html/classQextScintillaPrinter.html
-%%DOCS%%%%DOCSDIR%%/html/deprecated.html
-%%DOCS%%%%DOCSDIR%%/html/doxygen.css
-%%DOCS%%%%DOCSDIR%%/html/doxygen.png
-%%DOCS%%%%DOCSDIR%%/html/functions.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x62.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x63.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x64.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x65.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x66.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x67.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x68.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x69.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6a.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6b.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6c.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6d.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6e.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x6f.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x70.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x71.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x72.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x73.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x74.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x75.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x76.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x77.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x78.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x7a.html
-%%DOCS%%%%DOCSDIR%%/html/functions_0x7e.html
-%%DOCS%%%%DOCSDIR%%/html/functions_enum.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x62.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x63.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x64.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x65.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x66.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x67.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x68.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x69.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6a.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6b.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6c.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6d.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6e.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x6f.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x70.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x71.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x72.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x73.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x74.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x75.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x76.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x77.html
-%%DOCS%%%%DOCSDIR%%/html/functions_eval_0x78.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x62.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x63.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x64.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x65.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x66.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x67.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x68.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x69.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x6b.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x6c.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x6d.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x70.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x71.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x72.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x73.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x74.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x75.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x76.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x77.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x7a.html
-%%DOCS%%%%DOCSDIR%%/html/functions_func_0x7e.html
-%%DOCS%%%%DOCSDIR%%/html/hierarchy.html
-%%DOCS%%%%DOCSDIR%%/html/index.html
-%%DOCS%%%%DOCSDIR%%/html/pages.html
-%%DOCS%%%%DOCSDIR%%/html/tab_b.gif
-%%DOCS%%%%DOCSDIR%%/html/tab_l.gif
-%%DOCS%%%%DOCSDIR%%/html/tab_r.gif
-%%DOCS%%%%DOCSDIR%%/html/tabs.css
-%%DOCS%%%%DOCSDIR%%/qscintilla.dxy
-%%EXAMPLES%%%%EXAMPLESDIR%%/License.txt
-%%EXAMPLES%%%%EXAMPLESDIR%%/README
-%%EXAMPLES%%%%EXAMPLESDIR%%/application.cpp
-%%EXAMPLES%%%%EXAMPLESDIR%%/application.h
-%%EXAMPLES%%%%EXAMPLESDIR%%/application.pro
-%%EXAMPLES%%%%EXAMPLESDIR%%/fileopen.xpm
-%%EXAMPLES%%%%EXAMPLESDIR%%/fileprint.xpm
-%%EXAMPLES%%%%EXAMPLESDIR%%/filesave.xpm
-%%EXAMPLES%%%%EXAMPLESDIR%%/main.cpp
-%%LANG_DE%%%%DATADIR%%/translations/qscintilla_de.qm
-%%LANG_FR%%%%DATADIR%%/translations/qscintilla_fr.qm
-%%LANG_PTBR%%%%DATADIR%%/translations/qscintilla_pt_br.qm
-%%LANG_RU%%%%DATADIR%%/translations/qscintilla_ru.qm
-%%DOCS%%@dirrm %%DOCSDIR%%/Scintilla
-%%DOCS%%@dirrm %%DOCSDIR%%/html
-%%DOCS%%@dirrm %%DOCSDIR%%
-%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%TRANSLATIONS%%@dirrm %%DATADIR%%/translations
-%%TRANSLATIONS%%@dirrm %%DATADIR%%
-%%DESIGNER_PLUGIN%%@unexec /sbin/ldconfig -R
+include/qt4/Qsci/qsciabstractapis.h
+include/qt4/Qsci/qsciapis.h
+include/qt4/Qsci/qscicommand.h
+include/qt4/Qsci/qscicommandset.h
+include/qt4/Qsci/qscidocument.h
+include/qt4/Qsci/qsciglobal.h
+include/qt4/Qsci/qscilexer.h
+include/qt4/Qsci/qscilexerbash.h
+include/qt4/Qsci/qscilexerbatch.h
+include/qt4/Qsci/qscilexercmake.h
+include/qt4/Qsci/qscilexercpp.h
+include/qt4/Qsci/qscilexercsharp.h
+include/qt4/Qsci/qscilexercss.h
+include/qt4/Qsci/qscilexercustom.h
+include/qt4/Qsci/qscilexerd.h
+include/qt4/Qsci/qscilexerdiff.h
+include/qt4/Qsci/qscilexerfortran.h
+include/qt4/Qsci/qscilexerfortran77.h
+include/qt4/Qsci/qscilexerhtml.h
+include/qt4/Qsci/qscilexeridl.h
+include/qt4/Qsci/qscilexerjava.h
+include/qt4/Qsci/qscilexerjavascript.h
+include/qt4/Qsci/qscilexerlua.h
+include/qt4/Qsci/qscilexermakefile.h
+include/qt4/Qsci/qscilexermatlab.h
+include/qt4/Qsci/qscilexeroctave.h
+include/qt4/Qsci/qscilexerpascal.h
+include/qt4/Qsci/qscilexerperl.h
+include/qt4/Qsci/qscilexerpostscript.h
+include/qt4/Qsci/qscilexerpov.h
+include/qt4/Qsci/qscilexerproperties.h
+include/qt4/Qsci/qscilexerpython.h
+include/qt4/Qsci/qscilexerruby.h
+include/qt4/Qsci/qscilexerspice.h
+include/qt4/Qsci/qscilexersql.h
+include/qt4/Qsci/qscilexertcl.h
+include/qt4/Qsci/qscilexertex.h
+include/qt4/Qsci/qscilexerverilog.h
+include/qt4/Qsci/qscilexervhdl.h
+include/qt4/Qsci/qscilexerxml.h
+include/qt4/Qsci/qscilexeryaml.h
+include/qt4/Qsci/qscimacro.h
+include/qt4/Qsci/qsciprinter.h
+include/qt4/Qsci/qsciscintilla.h
+include/qt4/Qsci/qsciscintillabase.h
+include/qt4/Qsci/qscistyle.h
+include/qt4/Qsci/qscistyledtext.h
+lib/qt4/libqscintilla2.so
+lib/qt4/libqscintilla2.so.9
+lib/qt4/libqscintilla2.so.9.0
+lib/qt4/libqscintilla2.so.9.0.0
+%%DATADIR%%/qsci/api/python/Python-2.7.api
+%%DATADIR%%/qsci/api/python/Python-2.5.api
+%%DATADIR%%/qsci/api/python/Python-2.6.api
+%%DATADIR%%/qsci/api/python/Python-2.4.api
+%%DATADIR%%/qsci/api/python/Python-3.1.api
+%%DATADIR%%/qsci/api/python/Python-3.2.api
+%%DATADIR%%/qsci/api/python/Python-3.3.api
+%%DATADIR%%/translations/qscintilla_cs.qm
+%%DATADIR%%/translations/qscintilla_de.qm
+%%DATADIR%%/translations/qscintilla_es.qm
+%%DATADIR%%/translations/qscintilla_fr.qm
+%%DATADIR%%/translations/qscintilla_pt_br.qm
+%%DATADIR%%/translations/qscintilla_ru.qm
+%%DESIGNER_PLUGIN%%lib/qt4/plugins/designer/libqscintillaplugin.so
+@dirrm include/qt4/Qsci
+@dirrm %%DATADIR%%/qsci/api/python
+@dirrm %%DATADIR%%/qsci/api
+@dirrm %%DATADIR%%/qsci
+@dirrm %%DATADIR%%/translations
+@dirrm %%DATADIR%%