aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/gcompris/Makefile2
-rw-r--r--games/gcompris2/Makefile2
2 files changed, 4 insertions, 0 deletions
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index e756fc99e55a..9e3e719515f9 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -26,6 +26,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFLICTS= gcompris2*
+
post-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
diff --git a/games/gcompris2/Makefile b/games/gcompris2/Makefile
index 795138e8ce78..4ec85dcaec5b 100644
--- a/games/gcompris2/Makefile
+++ b/games/gcompris2/Makefile
@@ -28,4 +28,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
INFO= gcompris
+CONFLICTS= gcompris-*
+
.include <bsd.port.mk>