aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/totem/Makefile4
-rw-r--r--multimedia/totem/files/patch-src::bacon-video-widget-xine.c15
2 files changed, 18 insertions, 1 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 9f7c07c20d46..bb5bf386bf2a 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -7,7 +7,7 @@
PORTNAME= totem
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION}
@@ -91,6 +91,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
${WRKSRC}/src/bacon-video-widget-gst.c
.endif
+ @${REINPLACE_CMD} -e 's|@LOCALBASE@|${LOCALBASE}|' \
+ ${WRKSRC}/src/bacon-video-widget-xine.c
post-install:
@-update-desktop-database
diff --git a/multimedia/totem/files/patch-src::bacon-video-widget-xine.c b/multimedia/totem/files/patch-src::bacon-video-widget-xine.c
new file mode 100644
index 000000000000..903e5b2e2b3e
--- /dev/null
+++ b/multimedia/totem/files/patch-src::bacon-video-widget-xine.c
@@ -0,0 +1,15 @@
+--- src/bacon-video-widget-xine.c.orig Wed Mar 9 18:03:18 2005
++++ src/bacon-video-widget-xine.c Wed Mar 9 18:05:59 2005
+@@ -2504,10 +2504,8 @@
+
+ /* And we try and create symlinks from /usr/lib/win32 to
+ * the local user path */
+- totem_create_symlinks ("/usr/lib/win32", path);
+- totem_create_symlinks ("/usr/lib/RealPlayer9/Codecs/", path);
+- totem_create_symlinks ("/usr/lib/RealPlayer9/users/Real/Codecs/", path);
+- totem_create_symlinks ("/usr/lib/RealPlayer8/Codecs", path);
++ totem_create_symlinks ("@LOCALBASE@/lib/win32", path);
++ totem_create_symlinks ("@LOCALBASE@/lib/RealPlayer/codecs", path);
+
+ g_free (bvw->priv->codecs_path);
+ bvw->priv->codecs_path = g_strdup (path);