aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/superkaramba-lwp/Makefile51
-rw-r--r--deskutils/superkaramba-lwp/distinfo3
-rw-r--r--deskutils/superkaramba-lwp/pkg-descr5
-rw-r--r--deskutils/superkaramba-lwp/pkg-plist2
5 files changed, 62 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index b07a95150f70..c1a9fdce47c3 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -138,6 +138,7 @@
SUBDIR += splashsetter
SUBDIR += sugarcrm
SUBDIR += sunbird
+ SUBDIR += superkaramba-lwp
SUBDIR += superswitcher
SUBDIR += taskjuggler
SUBDIR += teapot
diff --git a/deskutils/superkaramba-lwp/Makefile b/deskutils/superkaramba-lwp/Makefile
new file mode 100644
index 000000000000..df6573632328
--- /dev/null
+++ b/deskutils/superkaramba-lwp/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: superkaramba-lwp
+# Date created: Sun, May 28, 2006
+# Whom: Jason E. Hale <bsdkaffee@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= lwp
+PORTVERSION= 12.2
+CATEGORIES= deskutils kde
+MASTER_SITES= http://www.message.co.nz/~matt-sarah/ \
+ http://mirror1.liquidweather.net/ \
+ http://mirrors.borgnet.us/matt-lw/ \
+ http://liquidweather.net/
+PKGNAMEPREFIX= superkaramba-
+EXTRACT_SUFX= .skz
+
+MAINTAINER= bsdkaffee@gmail.com
+COMMENT= Liquid Weather ++ a Superkaramba weather applet
+
+EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+ superkaramba:${PORTSDIR}/misc/kdeutils3 \
+ pyuic:${PORTSDIR}/x11-toolkits/py-qt
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+EXTRACT_CMD= ${UNZIP_CMD}
+EXTRACT_BEFORE_ARGS= -q -d ${DISTNAME}
+EXTRACT_AFTER_ARGS= # empty
+
+NO_BUILD= yes
+
+PLIST_SUB= LWPVER=${DISTFILES}
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ @cd ${WRKSRC} && ${RM} -f *~ locale/*/LC_MESSAGES/*.po*
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|/usr/bin|${LOCALBASE}/bin|' \
+ create_po.py debug.py test_gui.py
+
+pre-install:
+ @cd ${WRKSRC} && zip -qr ${DISTFILES} *
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/apps/superkaramba/themes
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${DISTFILES} \
+ ${PREFIX}/share/apps/superkaramba/themes
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/superkaramba-lwp/distinfo b/deskutils/superkaramba-lwp/distinfo
new file mode 100644
index 000000000000..a51f48f5c0ee
--- /dev/null
+++ b/deskutils/superkaramba-lwp/distinfo
@@ -0,0 +1,3 @@
+MD5 (lwp-12.2.skz) = 9b291ee8a8b29af20834958f76fd5e05
+SHA256 (lwp-12.2.skz) = fe930758f27c314ffc76c3580d5286d52a12fdec29f2a1df0cbf8fc47c1ac9e9
+SIZE (lwp-12.2.skz) = 4060818
diff --git a/deskutils/superkaramba-lwp/pkg-descr b/deskutils/superkaramba-lwp/pkg-descr
new file mode 100644
index 000000000000..6a4096240077
--- /dev/null
+++ b/deskutils/superkaramba-lwp/pkg-descr
@@ -0,0 +1,5 @@
+Liquid Weather ++ is a Superkaramba theme and desktop applet for
+displaying weather information and forecasts in a compact and easy
+to read format - it's pretty too.
+
+WWW: http://liquidweather.net/
diff --git a/deskutils/superkaramba-lwp/pkg-plist b/deskutils/superkaramba-lwp/pkg-plist
new file mode 100644
index 000000000000..c0a62a95924a
--- /dev/null
+++ b/deskutils/superkaramba-lwp/pkg-plist
@@ -0,0 +1,2 @@
+share/apps/superkaramba/themes/%%LWPVER%%
+@dirrmtry share/apps/superkaramba/themes